Routed IPTV over eigen asus router (RT AC3200)

  • 2 augustus 2017
  • 3 reacties
  • 1116 keer bekeken

Hoi,
Ik heb al 1 jaar lang de experiabox links liggen
inprincipe alleen nog maar voor telefonie
destijds heb ik hier allemaal posts gevonden met custom scripts waardoor je IPTV (routed) en internet over je eigen (asus) router kon laten lopen
Dit werkte een hele lange tijd
Nu kan ik 5 min naar een zender kijken en dan krijg ik Zender niet beschikbaar
Vooral op 711 en 12 Gebeurd dit (Comedy central)

IGMP Snooping staat aan
Dus snap niet waarom het niet werkt

Mijn scripts:

nat-start:
code:

#!/bin/sh

#Disable rp_filter. Needed for multicast
echo 0 > /proc/sys/net/ipv4/conf/vlan4/rp_filter

#Enable NAT for vlan4
iptables -t nat -D POSTROUTING -o vlan4 -j MASQUERADE
iptables -t nat -I POSTROUTING -o vlan4 -j MASQUERADE


vlan4.script:
code:

#!/bin/sh

[ -z "$1" ] && echo "Error: should be called from udhcpc" && exit 1

[ -n "$broadcast" ] && BROADCAST="broadcast $broadcast"
[ -n "$subnet" ] && NETMASK="netmask $subnet"

set_classless_routes() {
local max=128
local type
while [ -n "$1" -a -n "$2" -a $max -gt 0 ]; do
[ ${1##*/} -eq 32 ] && type=host || type=net
echo "udhcpc: adding route for $type $1 via $2"
/sbin/route add -$type "$1" gw "$2" dev "$interface"
max=$(($max-1))
shift 2
done
}

case "$1" in
deconfig)
/sbin/ifconfig $interface 0.0.0.0
;;

leasefail|nak)
echo "Failed to obtain lease..."
;;
renew|bound)
/sbin/ifconfig $interface $ip $BROADCAST $NETMASK
[ -n "$staticroutes" ] && set_classless_routes $staticroutes
[ -n "$msstaticroutes" ] && set_classless_routes $msstaticroutes
;;
esac

exit 0


wan-start:
code:

#!/bin/sh

# Leave VOIP traffic tagged for original router
/usr/sbin/robocfg vlan 7 ports "0t 4t 5t"

# Setup VLAN4 on the CPU as well so we can talk to it
/usr/sbin/robocfg vlan 4 ports "0t 5t"
/usr/sbin/robocfg vlan 1 ports "1 2 3 5t"

# Add VLAN4 as a physical interface
/sbin/vconfig add eth0 4

# Request an IP-address and setup static routes

/usr/bin/killall udhcpc
sleep 1

udhcpc -i vlan4 --clientid-none -O msstaticroutes -O staticroutes -V IPTV_RG -s /jffs/scripts/vlan4.script -p /var/run/vlan4.pid -b -O33 -O249

# Restart IGMP proxy

sleep 20
/usr/bin/killall igmpproxy
sleep 1
/usr/sbin/igmpproxy /jffs/configs/igmpproxy.conf


dnsmasq.conf.add:
code:

dhcp-option=60,IPTV_RG
dhcp-option=28,192.168.1.255


igmpproxy.conf
code:

quickleave

phyint vlan4 upstream ratelimit 0 threshold 1
altnet 0.0.0.0/0

phyint br0 downstream ratelimit 0 threshold 1
phyint lo disabled
phyint vlan1 disabled
phyint vlan6 disabled
phyint ppp0 disabled
phyint eth0 disabled
phyint eth1 disabled
phyint eth2 disabled


Kortom het heeft een tijdje gewerkt
maar zenders beginnen te stoppen en melding zender niet beschikbaar
heeft iemand toevallig een oplossing voor mij? :D

Bij voorbaat dank!

3 reacties

Reputatie 7
Badge +30
Heb je sinds kort een nieuw Accesspoint of Repeater?

Stel je vraag hier ook even: https://gathering.tweakers.net/forum/list_messages/1772709/0
Dankje voor je reactie!
Nee heb alleen de router
KPN tv ontvanger staat direct met één 2 meter cat6a kabel op de router aangesloten
Alles volgens de handleiding 1 op 1 opnieuw gedaan
Duurt al een stuk langer voordat ik Zender niet beschikbaar krijg
Maar na 1 uurtje krijg ik de melding weer

Iemand nog ideeën?

Reageer