ASUS router achter experiabox v10

  • 9 januari 2016
  • 24 reacties
  • 2094 keer bekeken

Met hulp van dit forum is het mij gelukt om een eigen asus router (rt-ac68u) achter de experiabox v10 te plaatsen en alles intestellen.

Nu heb ik echter nog een probleem waar ik niet uitkom,De asus router heeft een functie voor vpn deze heb ik ingesteld op pptp en dit werkt ook vannaf mijn iphone. Maar wil dit ook graag op mij laptop instellen (w7).

Dit is ook gelukt maar wanneer ik het public ip invul bij vpn server dan lukt het niet om te verbinden (fout code 807) wanneer ik het wan ip van mijn asus invul bij vpn server dan lukt het direct om verbinding te maken alleen dit werkt natuurlijk alleen lokaal :(

Kan iemand mij hiermee verder helpen?

Alvast bedankt!


24 reacties

Reputatie 7
Lees deze pagina eens, niet geschoten is altijd mis. ;)

Dit kwam ik inderdaad ook tegen, heb een nieuwe d-word 32bit aagemaakt zoals beschreven en opnieuwe opgestart maar helaas is dit nog niet de oplossing.. zou het kunnen dat het een 64bit word moet zijn omdat ik ee 64bit windows 7 heb??

Reputatie 7
Theun1993 schreef op 9 jan '16 om 20:22u
Dit kwam ik inderdaad ook tegen, heb een nieuwe d-word 32bit aagemaakt zoals beschreven en opnieuwe opgestart maar helaas is dit nog niet de oplossing.. zou het kunnen dat het een 64bit word moet zijn omdat ik ee 64bit windows 7 heb??

Nee, ook bij 64bit Windows blijft dit gewoon een 32bit veld.

Heb je overigens de Home, Professional of Ultimate versie van Windows 7?

Overigens jammer dat het nog steeds niet werkt. :(

wjb schreef op 9 jan '16 om 20:27u
Theun1993 schreef op 9 jan '16 om 20:22uDit kwam ik inderdaad ook tegen, heb een nieuwe d-word 32bit aagemaakt zoals beschreven en opnieuwe opgestart maar helaas is dit nog niet de oplossing.. zou het kunnen dat het een 64bit word moet zijn omdat ik ee 64bit windows 7 heb??

Nee, ook bij 64bit Windows blijft dit gewoon een 32bit veld.

Heb je overigens de Home, Professional of Ultimate versie van Windows 7?

Overigens jammer dat het nog steeds niet werkt. Smiley Verdrietig

 
oke nou dat is het dan ook niet haha, het is windows 7 professional sp1

Ben het nu nog maals met openvpn aan het proberen want dik kan schijnbaa ook op iphone werken, alleen loop hiermee tegen het zelfde probleem aan als met de vpn pptp. Ik vermoed dat het wordt geblokeerd in de experiabox zou dit kunnen?

en heeft er iemand evaring met het aanpassen van het openvpn configuratie bestand?

Reputatie 7
Badge +30
De Experiabox blokkeert een VPN niet, echter kan het wel zijn dat door dubbel NAT de VPN niet goed werkt omdat de header wordt aangepast en daardoor de VPN Server de packets niet vertrouwd en "laat vallen"

Robin
Reputatie 7
RobinFlikkema schreef op 9 jan '16 om 21:36u
De Experiabox blokkeert een VPN niet, echter kan het wel zijn dat door dubbel NAT de VPN niet goed werkt omdat de header wordt aangepast en daardoor de VPN Server de packets niet vertrouwd en "laat vallen"

Robin
Het klopt dat de Experia Box geen VPN verbindingen blokkeert.

Het is overigens niet de VPN server die bij double-NAT packets negeert, maar de Windows cliënt.

Dit issue is puur toe te wijzen aan Microsoft en met alle andere platforms zou double-NAT geen enkel probleem mogen zijn.

Overigens zou ik nog steeds willen opteren om voor openVPN verbindingen te gaan i.p.v. PPTP. Dit omdat de encryptie van openVPN vele malen sterker is dan PPTP. PPTP was zo ongeveer het eerste VPN protocol, maar daarmee ook de eerste die met pensioen gestuurd zou moeten worden. Eigenlijk is PPTP vandaag de dag niet veilig genoeg.

Dat openVPN op de iPhone niet zou werken vind ik vreemd. Ik zou dan verwachten dat Internet vol zou staan met meldingen daarover.

wjb schreef op 9 jan '16 om 21:56u
RobinFlikkema schreef op 9 jan '16 om 21:36uDe Experiabox blokkeert een VPN niet, echter kan het wel zijn dat door dubbel NAT de VPN niet goed werkt omdat de header wordt aangepast en daardoor de VPN Server de packets niet vertrouwd en "laat vallen"

RobinHet klopt dat de Experia Box geen VPN verbindingen blokkeert.

Het is overigens niet de VPN server die bij double-NAT packets negeert, maar de Windows cliënt.

Dit issue is puur toe te wijzen aan Microsoft en met alle andere platforms zou double-NAT geen enkel probleem mogen zijn.

Overigens zou ik nog steeds willen opteren om voor openVPN verbindingen te gaan i.p.v. PPTP. Dit omdat de encryptie van openVPN vele malen sterker is dan PPTP. PPTP was zo ongeveer het eerste VPN protocol, maar daarmee ook de eerste die met pensioen gestuurd zou moeten worden. Eigenlijk is PPTP vandaag de dag niet veilig genoeg.

Dat openVPN op de iPhone niet zou werken vind ik vreemd. Ik zou dan verwachten dat Internet vol zou staan met meldingen daarover.

 
Oke de openvpn lijkt me ook prima. Ik heb de openvpn client gedownload zowel op windows 7 als op mijn iphone via de openvpn app,

via mijn asus modem heb ik de pptp vpn verwijderd en de openvpn geactiveerd. Via het asus modem kon ik het vpn configuratie bestand downloaden en in de map programfiles van openvpn plaatsen.

Het asus modem maakt echter de openvpn bestand aan op zijn eigen wan ip "192.168.2.252" en wanner ik nu de vpn client open en verbinding maak werkt dit ook direct goed! Alleen hiermee ben ik helaas nog niks verder dan met de oude pptp vpn verbinding.

ik kan ik de openvpn configuratie file wel het ip-adres aan passen naar mijn public ip maar dan lukt het niet om verbinding te maken.

hierbij een screenshot van de openvpn file zoals hij aangemaakt is door het asus modem.

https://

Reputatie 7
Badge +30
Ik zou de screenshot even aanpassen zodat het certificaat (het blok tekst) niet zichtbaar is.
Je kan je bericht bewerken via Opties (kan niet op de mobiele versie van het KPN Forum)

Robin
Reputatie 7
Als je in dat configuratiebestand jouw publieke IP adres invult en via 3G/4G een VPN verbinding maakt, lukt dat dan wel of niet?

heb het ipadres aangepast naar het public ip maar helaas het werkt nog niet zie hieronder het log van 

de openvpn client:

Sat Jan 09 22:27:43 2016 OpenVPN 2.3.10 x86_64-w64-mingw32 [SSL (OpenSSL)] [lzo] [PKCS11] [IPv6] built on Jan 4 2016
Sat Jan 09 22:27:43 2016 Windows version 6.1 (Windows 7)
Sat Jan 09 22:27:43 2016 library versions: OpenSSL 1.0.1q 3 Dec 2015, LZO 2.09
Sat Jan 09 22:27:52 2016 UDPv4 link local: [undef]
Sat Jan 09 22:27:52 2016 UDPv4 link remote: [AF_INET]xx.xx.xx.xxx:1194
Sat Jan 09 22:28:53 2016 [undef] Inactivity timeout (--ping-restart), restarting
Sat Jan 09 22:28:53 2016 SIGUSR1[soft,ping-restart] received, process restarting
Sat Jan 09 22:28:55 2016 UDPv4 link local: [undef]
Sat Jan 09 22:28:55 2016 UDPv4 link remote: [AF_INET]xx.xx.xx.xxx:1194
Sat Jan 09 22:29:55 2016 [undef] Inactivity timeout (--ping-restart), restarting
Sat Jan 09 22:29:55 2016 SIGUSR1[soft,ping-restart] received, process restarting
Sat Jan 09 22:29:57 2016 UDPv4 link local: [undef]
Sat Jan 09 22:29:57 2016 UDPv4 link remote: [AF_INET]xx.xx.xx.xxx:1194

ps: het zelf het public ip aangepast in de log naar xx.xx.xx.xxx deze staat in de echte log wel goed.

Reputatie 7
Is dit dan via een 3G/4G verbinding en niet terwijl die PC via wifi of met een kabel met de Experia Box verbonden is?

Goedemorgen! 

Dit was inderdaad via de hotspot functie van mijn iphone, 4g dus. Kan het zijn dat ik nog poorten moet forwarden in de experiabox?

zie hieronder een printscreen van de instellingen van de vpn in mijn asus modem, zoals je kunt zien wordt de udp poort 1194 gebruikt wordt deze wel via dmz doorgelaten? Of ziet iemand misschien nog een andere instelleling die verkeerd staat?

ScreenHunter_06 Jan. 10 12.46.jpg

Reputatie 7
Zolang het WAN IP adres van jouw Asus als DMZ Host op de Experia Box ingesteld is, de DMZ Host actief is en er geen port-forwarding voor UDP poort 1194 op de Experia Box gedefinieerd is, zal deze poort doorgestuurd worden naar jouw Asus.

Mijns inziens zou het dan ook gewoon moeten werken.

Kan jij ook eens met jouw iPhone zelf testen.

ik heb het net even met mijn iphoen geprobeerd ook hierbij krijg ik een time out. Als ik mijn iphone.laptop met mijn experiabox verbind en dan probeer de vpn optezetten naar het wan ip van mijn asus dan werkt het direct zowel op mijn iphone als op mijn  laptop.

Dus naar mijn mening lijkt het erop dat er toch echt iets niet goed gaat met het doorlaten in de experiabox van pulic ip naar het wan ip van mijn eigen asus router. De dmz va de eb staat ingesteld op het wan ip van mijn asus.

Zou het kunnen dat de dmz niet goed werkt? en hoe zou ik dit kunnen controleren?

dus nog even een samenvatting de vp werkt prima als ik eenmaal verbonden ben met de experiabox maar werkt niet vannaf mijn public ip ook niet als ik op 4g zit.

Dankjewel nog maals voor de hulp, hoop dat iemand nog opties heeft :)

Reputatie 7
Ook ik heb een tweede router achter mijn V10 voor de scheiding van mijn zakelijke netwerk (achter de tweede router) en ons privé netwerk (achter de V10).

Deze tweede router draait een IPSec VPN server en dit functioneert prima.

Ook bij jou zou het dus moeten werken.

Je kunt jouw DMZ Host controleren door

  • een webserver te installeren op een PC (bijvoorbeeld de bij Windows standaard meegeleverde IIS server)
  • de PC op jouw Asus aan te sluiten
  • een port-forwarding voor TCP poort 80 op de Asus te definiëren richting die PC
  • een eventuele port-forwarding voor TCP poort 80 op de Experia Box te verwijderen
  • de webserver op jouw publieke IP adres te benaderen.
wjb schreef op 10 jan '16 om 16:02u
Ook ik heb een tweede router achter mijn V10 voor de scheiding van mijn zakelijke netwerk (achter de tweede router) en ons privé netwerk (achter de V10).

Deze tweede router draait een IPSec VPN server en dit functioneert prima.

Ook bij jou zou het dus moeten werken.

Je kunt jouw DMZ Host controleren door

  • een webserver te installeren op een PC (bijvoorbeeld de bij Windows standaard meegeleverde IIS server)
  • de PC op jouw Asus aan te sluiten
  • een port-forwarding voor TCP poort 80 op de Asus te definiëren richting die PC
  • een eventuele port-forwarding voor TCP poort 80 op de Experia Box te verwijderen
  • de webserver op jouw publieke IP adres te benaderen.
 
Oke dit ga ik vanavond doen  als ik de tijd er voor vind, zou dit ook de webpage van de asus kunne zijn? want dan weet ik toch of de dmz richting de asus goed werkt? En dan nog een vraagje als ik via mijn iphone op 4g de udp poort 1194 van mijn public ip controleer dan geeft hij aan dat de poort gesloten is. Staat deze poort dan wel open in de eb?

Ook zat ik nog te denken... kan het ook een instelling in de vpn zijn? bijvoorbeeld dat het ee direct verbinding moet zijn of een verbinding die genat wordt?

Reputatie 7
Ja hoor, als je de Asus zo kan instellen dat deze vanaf Internet benaderd mag worden.

Wat ook al voldoende is, indien mogelijk, is de Asus laten reageren op pings vanaf Internet. Als jouw publieke IP adres dan reageert op een ping weet je ook al dat de DMZ functioneert.

wjb schreef op 9 jan '16 om 20:16u
Lees deze pagina eens, niet geschoten is altijd mis. Smiley Knipoog

 
(Dat gaat helaas niet op voor Windows10.) Het helpt me dus ook niet bij mijn zoektocht naar uitwerking van jou (veel) eerdere opmerking dat je vanuit het netwerk onder de eigen router (een TP Link Touch5 in mijn geval) gewoon de apparaten op de Experia10 moet kunnen benaderen. Is daar ook zo'n handige uitleg voor te geven als je gemaakt heb op 13-12-2013?:D

En leg dan (in dezelfde begrijpelijke taal) ook even uit hoe je van buitenaf bepaalde eigen netwerkonderdelen veilig en netjes kunt benaderen?

Het zou mij (en meer gebruikers) zeer helpen. Van de uitleg van mijn leverancier ben ik niet veel wijzer geworden en van de "uitleg" in de handleiding nog veel minder.

groeten

bram

Reputatie 7
Die registry settings om L2TP/IPSec met NAT mogelijk te maken is ook voor Windows 10 van toepassing.

De apparaten die op het LAN van de Experia Box aangesloten zijn kunnen gewoon op hun IP adres (192.168.2.?) benaderd worden vanaf een apparaat achter jouw eigen router.. Daarvoor is geen VPN verbinding nodig.

Het veilig benaderbaar maken van services op jouw eigen netwerk doe je door port-forwardings te maken van de poorten die voor die service benodigd zijn.

Dank voor je reactie wjb maar,

  1. Die registry settings om L2TP/IPSec met NAT mogelijk te maken is ook voor Windows 10 van toepassing.. Zouden ze dat bij Gates cs wel weten? Het staat nl niet bij de "properties" van het artikel.
  2. Als ik (in dit geval) mijn oude NAS op de Experia benader met zijn 192.168.2.xxx adres kom ik alleen in het instellingen menu van die NAS, niet in de (sub)directories, dus niet bij de bestanden.
  3. moeten dan die port-forwardings (ook) in de experia10 of (alleen) in de router?
sorry als ik wat domme vragen stel, maar ik raak een beetje het spoor bijster door allerlei verschillende definities en benamingen, die de diverse fabrikanten gebruiken :catembarrassed:

Bram

Reputatie 7
bramMH9 schreef op 20 jan '16 om 19:57u
Dank voor je reactie wjb maar,

  1. Die registry settings om L2TP/IPSec met NAT mogelijk te maken is ook voor Windows 10 van toepassing.. Zouden ze dat bij Gates cs wel weten? Het staat nl niet bij de "properties" van het artikel.
  2. Als ik (in dit geval) mijn oude NAS op de Experia benader met zijn 192.168.2.xxx adres kom ik alleen in het instellingen menu van die NAS, niet in de (sub)directories, dus niet bij de bestanden.
  3. moeten dan die port-forwardings (ook) in de experia10 of (alleen) in de router?
sorry als ik wat domme vragen stel, maar ik raak een beetje het spoor bijster door allerlei verschillende definities en benamingen, die de diverse fabrikanten gebruiken Verlegen kat

Bram

Er zijn legio andere artikelen op Internet te vinden waarin aangegeven wordt dat die registry entry ook voor Windows 10 van toepassing is.

Begrijp ik het goed dat jouw oude NAS op de Experia Box aangesloten is?

Welke merk en type heeft die NAS?

Als de NAS op de Asus is aangesloten, dan moet de Asus als DMZ Host van de Experia Box ingesteld worden en maak je de port-forwardings alleen op de Asus.

Ik geloof je wjb,

kijk toch maar eens op:  https://support.microsoft.com/en-us/kb/926179

zelfs Windows 7 wordt niet genoemd. En ik ga het ook niet proberen, de registries van Windows zijn me veel te gevoelig voor ruwe behandeling 😃 en wie het wel durft: chapeau!

Nu even serieus: die oude NAS is een Freecom WDC met 500MB schijf: WDC WD5000AAVS-00ZTB0 WD-WCASU4784357 01.01B01

firmware version NAS2891-009B2 LOADER 3.2. Ik had zo gedacht die buiten mijn netwerk te houden (dan kan ik bij langere afwezigheid dat netwerk afkoppelen) en voor noodgevallen toch een plek hebben waar ik (en naaste familie) items kunnen plaatsen en uitwisselen.

Dat van die hosting ga ik morgen proberen.

groet

Bram

Reputatie 7
bramMH9 schreef op 20 jan '16 om 22:47u
Ik geloof je wjb,

kijk toch maar eens op:  https://support.microsoft.com/en-us/kb/926179

zelfs Windows 7 wordt niet genoemd. En ik ga het ook niet proberen, de registries van Windows zijn me veel te gevoelig voor ruwe behandeling Smiley LOL en wie het wel durft: chapeau!

Moet je wel naar documenten zoeken die geschreven zijn toen Windows 7 er ook was. Dit artikel dateert uit het pre-Windows 7 tijdperk.

Overigens is het zetten van zo'n registry entry helemaal niet zo spannend hoor. :D

Reageer