Vraag

IPv6 adressen uitdelen vanuit interne dhcp server

  • 24 december 2016
  • 15 reacties
  • 1144 keer bekeken

Badge
Hi,
Ik kwam er sinds kort achter dat ik op mijn KPN glasvezel verbinding ook ipv6 binnen krijg.
Nu heb ik achter mijn experiav9 box nog een eigen router zitten, waardoor ik niet standaard op mijn clients een ip6 adres toegewezen krijg.

Ik zie op de experia box een ipv6 GUA 2a02:xxxx:yyyy::1
mijn experiabox heeft aan de interne kant een 2a02:xxxx:yyyy:2:1234🔢1234:1234/64 en fe80:🔢1234🔢1234/64

Via DHCP van de experia box krijg ik 2a02:xxxx:yyyy:1::/64 toegewezen met als gateway het fe80 adres van de experiabox.

Ik ben niet helemaal thuis in ipv6, maar zou ik nu vanuit mijn interne dhcp server
nu gewoon alles uitkunnen delen in de ranges 2a02:xxxx:yyyy:3::/64 ( of alles behalve 1 en 2 voor de 3? )

Wat is de prefix van het netwerk wat je van KPN krijgt want daar wordt ik ook nog niet helemaal wijs uit. Zoals te zijn nog een leek in ipv6 maar misschien heeft iemand wat goede tips en tricks over hoe e.e.a. in te stellen?

Alvast bedankt,

Gr,

Rex

Admin: titel aangevuld zodat je bericht beter is te vinden

15 reacties

Reputatie 7
Van KPN heb jij een 2a02:xxxx:yyyy/48 adres gekregen.
Bij mij heeft de Experia Box aan de WAN zijde een 2a02:xxxx:yyyy:0::/64 IP adres en aan de LAN zijde een 2a02:xxxx:yyyy:1::/64 IP adres. Alle apparaten aangesloten op de Experia Box krijgen ook een 2a02:xxxx:yyyy:1::/64 IP adres.

Aan de LAN zijde van mijn tweede router gebruik ik IP adressen in de 2a02:xxxx:yyyy:2::/64 reeks en de aangesloten apparaten krijgen deze ook netjes toegewezen. Mijn tweede router is een Cisco RV180W en daar heb ik de DHCPv6 server aan gezet en de DHCP mode staat op stateless.
Badge
Een beetje late reactie, maar het werkt nu... Ik heb nu de experiabox ertussen uit gehaald en laat miijn eigen router nu alles regelen ( behalve voor telefonie ).

Nu heb ik nog 1 probleem dat ik nog niet helemaal kan plaatsen. Ik heb op mijn pc's nu dual stack en over het algemeen werkt dit goed. Er zijn alleen een aantal sites bij www.microsoft.com, www.mikrotik.com of bijv. www.bit.nl welke ik nu niet meer kan benaderen nu ipv6 gepreferred wordt ( via IE en Chrome ). Een traceroute bijv gaat wel goed. Dan wordt netjes het ipv6 'spoor' gevolgd. Andere sites zoals bijv. dit forum of ipv6.google.com en facebook werken wel.

Zou dat iets mijn instellingen kunnen zijn?

Gr,

Rex
Reputatie 4
Badge +1
@rexdekoning Check de MTU van je eigen router.
Ik had hetzelfde probleem. Oplossing:

set firewall options mss-clamp interface-type pppoe
set firewall options mss-clamp mss 1452
set firewall options mss-clamp6 mss 1432
set interfaces ethernet eth0 vif 6 pppoe 0 mtu 1492


Ofwel, de MTU op de pppoe interface op 1492 zetten. Dit omdat het via een vlan loopt en je vlan header 8 bits toevoegt.
Daarnaast voegt ook pppoe weer bits toe aan je header.

Normaal zullen al je connecties op 1500 staan. Dit gaat vaak goed, maar dus niet altijd.

edit: Als je een experiabox ertussen hebt doet deze al dit soort dingen voor je. nu je die ertussenuit gehaald hebt, zal je eigen router het moeten doen.
Met bovenstaande instellingen is alles op mijn interne lan gewoon default (dus 1500) en zorgt mijn edgerouter dus voor de juiste pakketgroote op de extern lijn.

Succes.
@rexdekoning Check de MTU van je eigen router.
Ik had hetzelfde probleem. Oplossing:

set firewall options mss-clamp interface-type pppoe
set firewall options mss-clamp mss 1452
set firewall options mss-clamp6 mss 1432
set interfaces ethernet eth0 vif 6 pppoe 0 mtu 1492


Ofwel, de MTU op de pppoe interface op 1492 zetten. Dit omdat het via een vlan loopt en je vlan header 8 bits toevoegt.
Daarnaast voegt ook pppoe weer bits toe aan je header.

Normaal zullen al je connecties op 1500 staan. Dit gaat vaak goed, maar dus niet altijd.

edit: Als je een experiabox ertussen hebt doet deze al dit soort dingen voor je. nu je die ertussenuit gehaald hebt, zal je eigen router het moeten doen.
Met bovenstaande instellingen is alles op mijn interne lan gewoon default (dus 1500) en zorgt mijn edgerouter dus voor de juiste pakketgroote op de extern lijn.

Succes.

Klopt dit nog wel.

Ik heb een Edgerouter-X.
NTU gaat naar Managed Switch Tagged VLAN 4,6 en 7
VLAN 6 untagged naar ETH0 op ER-X
ETH0 op ER-X op 1500 MTU
ETH0.6 op 1500
PPPOE op 1492.
Ik kan geen website opvragen.

Config die ik eest had:
ETH0 op 1512,
ETH0.6 op 1508
PPPOE op 1500.

Maar dan heb ik een hoge Bufferbloat.

Gr
Rveupen
Reputatie 7
Badge +30
Volgensmij kan je gewoon 1500 over PPPoE pleuren omdat RFC4638 wordt ondersteund. En volgensmij heeft dit als voordeel dat je EdgeRouter geen packets hoeft om te bouwen/bufferen etc omdat alles 1500 is.
Of wil je juist 1492 om het ICMP Dont Fragment bit?

Waarom gebruik je Eth/0.6? Je laat de switch de VLANs toch afhandelen in dit geval?

Robin
Reputatie 4
Badge +1
Ik heb de NTU direct op mijn edge router aangesloten. Ik lees dat jij het via een managed switch doet. Daar zit dus het verschil.
Volgensmij kan je gewoon 1500 over PPPoE pleuren omdat RFC4638 wordt ondersteund. En volgensmij heeft dit als voordeel dat je EdgeRouter geen packets hoeft om te bouwen/bufferen etc omdat alles 1500 is.
Of wil je juist 1492 om het ICMP Dont Fragment bit?

Waarom gebruik je Eth/0.6? Je laat de switch de VLANs toch afhandelen in dit geval?

Robin


Omdat VLAN 6 (4 en 7 ook) tagged op poort 2 de Managed Switch binnenkomen vanaf de NTU en via poort 6 gaat VLAN 6 Untagged naar de Edgerouter gaat dien ik een VLAN 6 te definiern dus ETH0.6 waar ETH0 mijn WAN poort is. Vervolgens heb je PPPoE voor internet.
Dus op ETH0 heb ik 1512, ETH0.6 1508 (4bits) en op PPPoE 1500.
Echter met deze opzet heb ik BufferBloat.
Reputatie 4
Badge +1
Als het untagged op poort 6 van de switch staat, hoef je op de edgerouter geen vlan mee te geven. De switch zal zelf voor elk pakket wat op poort 6 binnenkomt, en geen vlan tag bevat, vlan 6 toevoegen. Dat is hoe untagged ports werken.

Ik zou in jou geval doen:
ETH0 MTU 1500, en vanaf daar steeds kleiner (vlan, pppoe). Ik weet niet of de KPN infra goed om kan gaan met 1508.
Aan de LAN zijde van mijn tweede router gebruik ik IP adressen in de 2a02:xxxx:yyyy:2::/64 reeks en de aangesloten apparaten krijgen deze ook netjes toegewezen. Mijn tweede router is een Cisco RV180W en daar heb ik de DHCPv6 server aan gezet en de DHCP mode staat op stateless.

Hoi wjb, hoe heb je de Experiabox en de Cisco router aan elkaar geknoopt op laag 3? Ik heb op mijn router dhcpv6 aanstaan op de wan interface, maar dat lijkt niet te werken.
Mag helaas mijn bericht niet aanpassen, dus ik mention @wjb even zo. Hoop dat je het laatste stukje inzicht even kunt geven!
Met 'mijn router' hierboven doel ik natuurlijk op de tweede (eigen) router. Dat had ik beter kunnen beschrijven 🙂
Reputatie 7
Aan de WAN zijde wordt het IPv6 adres m.b.v. DHCPv6 vastgesteld.


Welke Experia Box heb je, een V10?
Bedankt voor je reactie, ik heb inderdaad een V10.

Ik ben met name benieuwd naar het adres dat via dhcpv6 uitgedeeld, ik ga er van uit dat deze (het voorbeeld aanhalend) in de reeks 2a02:xxxx:yyyy:1::/64 zit? Wat is het ipv6 gateway adres voor de Cisco, is dit het link local adres van de Experiabox?

Aan de LAN zijde van mijn tweede router gebruik ik IP adressen in de 2a02:xxxx:yyyy:2::/64. Ik heb een Ubiquiti USG waar ik alle zonering intern mee doe, ik heb hierop inmiddels een /64 aan de binnenzijde draaien. De clients krijgen ook netjes een ipv6 adres.

Aan de WAN zijde krijg ik via dhcpv6 geen adres aangeboden. Dat kan liggen aan het feit dat ik in het beta programma zit voor ipv6 support in de gui. :)
Ik ga het zo even testen met een Cisco router die ik nog heb liggen, ben daarom met name benieuwd daar de adressen die je op de wan zijde in gebruik hebt.
Reputatie 7
De IPv6 gateway en IPv6 DNS server worden ingesteld op het fe80 IPv6 adres van de LAN zijde van de Experia Box. (Zie op de v10: Status -> Geavanceerd -> LAN)

Ook ik gebruik achter mijn tweede router (Cisco) IP adressen met de prefix 2a02:xxxx:yyyy:2::/64.

Onderstaand een voorbeeld van mijn Android tablet aangesloten op de V10 resp. Cisco RV180W.

V10:


Cisco RV180W:

@wjb dankjewel.

De IPv6 gateway en IPv6 DNS server worden ingesteld op het fe80 IPv6 adres van de LAN zijde van de Experia Box. (Zie op de v10: Status -> Geavanceerd -> LAN)
Die configuratie loopt volledig via dhcpv6?

De appliances die ik nu 'even' wilde proberen om te controleren of dhcpv6 op de usg nou echt kapot is werken niet helemaal mee... Straks even verder proberen.
Reputatie 7
De IPv6 gateway en IPv6 DNS server worden ingesteld op het fe80 IPv6 adres van de LAN zijde van de Experia Box. (Zie op de v10: Status -> Geavanceerd -> LAN)Die configuratie loopt volledig via dhcpv6?Via stateless DHCPv6.

Dat houdt in dat het IPv6 adres van de cliënt op basis van Router Advertisement gaat, maar dat het IPv6 adres van de DNS server door de DHCPv6 server aangeleverd wordt.
Feitelijk wordt het WAN IPv6 adres dus op basis van SLAAC bepaald.

Reageer