Beantwoord

Website met ADSL en 4G buitengebied

  • 30 december 2017
  • 20 reacties
  • 590 keer bekeken

Ik had twee websites draaien op mijn - langzame - ADSL. Blij ben ik overgegaan op KPN buitengebied, maar nu heb ik geen vast IP, ondanks mijn ADSL lijn. Er stond hier ook niets over in de reclame, en ook de KPN medewerker repte hier niet over, hoewel ik de websites noemde. Er moet toch een manier zijn om dit te omzeilen, want anders is er geen toegevoegde waarde van die ADSL verbinding, en zou alleen een 4G modem voldoende zijn.

Als dit niet mogelijk is, rest mij alleen de mogelijkheid om het abonnement op te zeggen.
icon

Beste antwoord door Joran 5 februari 2018, 09:56

Sorry voor de (hele) late reactie. Het Sagemcom 4G modem ondersteunt NAT loopback niet, de Experiabox V10 wel. Dit betekent dat als het 4G modem zit aangesloten NAT loopback niet functioneert. De enige workaround is om dit modem los te koppelen. Ik heb een verbetervoorstel ingediend om dit wel mogelijk te maken. Of/wanneer dat in behandeling genomen gaat worden kan ik je helaas nog niet vertellen. De workaround met het hostsbestand aanpassen is daarom nu de enige optie. Ik hoop dat dit gaat veranderen in de toekomst!
Bekijk origineel

20 reacties

Het is me gelukt, met DDSN, zelf, want niet dat de helpdesk medewerkers daar iets van af wisten. Het schijnt, dat als je zakelijk internet hebt, je wel een vast IP kan krijgen met ADSL/4G. Vreemd, dat een particulier dat niet kan krijgen, juist voor een particulier is een vast IP een stuk makkelijker.
Ik zit nog wel met een vraag. Binnen mijn LAN kan ik de website niet krijgen, alleen door .een regel toe te voegen aan de hostfile.
Maar ik wil juist thuis kunnen zien of mijn website in de buitenwereld te zien is. Het schijn te maken te hebben met de router, moeite heeft met een 'thuis-'adres, dus het is een Xperiaprobleem.
Reputatie 7
Badge +28
Welkom reindu, sorry voor de erg late reactie!

Het IP-adres is bij alle consumentenaansluitingen, ook bij ADSL, dynamisch. Het verandert in de praktijk echter zelden. Bij de overstap naar Sneller Internet Buitengebied ontvang je eenmalig een nieuw IP-adres, zie ook de veelgestelde vragen onderaan Sneller Internet Buitengebied. In de laatste 3 weken zie ik geen wijziging in dit nieuwe IP-adres.

Het probleem dat je in het tweede bericht beschrijft klinkt als een probleem met NAT loopback. Dat betekent dat je jouw externe IP-adres kan aanroepen binnen het netwerk en dat je het lokale apparaat benadert waarvoor een portforward is ingesteld. De V10 ondersteunt dit. Werkt het wel als je via jouw externe IP-adres (dus niet via de DDNS service) de website benadert?
Inderdaad, ik heb nu DDNS uitgeschakeld en mijn website is buiten wel bereikbaar. Ik was helemaal de verkeerde richting gaan zoeken (door een helpdeskmedewerker) , toen ik geen website kreeg.. Maar in mijn LAN werkt het dus niet. In een ver verleden werkte het wel op een vorige Xperia, en de instellingen in mijn Synology zijn dezelfde.
Reputatie 7
Badge +28
We komen er vast wel uit 🙂 Is de Experiabox het enige netwerkapparaat of is er ook nog een router aanwezig? Dan bestaat het geval dat je hier last van hebt: wjb in NAT Loopback BUG. Die bug doet zich voor als de router in DMZ staat. Als dat niet van toepassing is doe ik navraag bij het modembeheer of het 4G modem de werking van NAT loopback beïnvloed.
Ik heb wel een TP-link en twee Engeniussen in mijn LAN als accesspoint. Ik heb ze uitgezet: geen effect. Maar die waren er eerder ook met de Fritzbox-router van XS4all, en die had er geen moeite mee (ik ben overgegaan naar KPN vanwege dat 4Gmodem). Ook in de Xperia staat DMZ uit. Het Sagemcom menu zegt er niets over.
Reputatie 7
Badge +28
Extra apparatuur is in principe geen probleem. Voor zover bekend doet deze storing zich alleen voor als een router in een DMZ zone is geplaatst. NAT loopback werkt dan alleen vanuit andere apparaten die ook in de DMZ zone zitten. Je mag gerust extra netwerkapparatuur aansluiten, alleen maakt dit het wat lastiger om de oorzaak van de storing te achterhalen.

Als test is het volgende het makkelijkst; sluit de server rechtstreeks aan op de Experiabox. Zorg dat de server een DHCP binding heeft in de V10 (Settings > DHCP) en dat de portforward klopt (Settings > Port Forwarding - IPv4). Start de Experiabox of server opnieuw op (of sluit de kabel even opnieuw aan) om zeker te weten dat de server het goede IP adres heeft. Sluit het apparaat waarmee je test ook rechtstreeks aan op de Experiabox. Dat mag bekabeld of via WiFi. Open vervolgens je externe IP-adres in de browser en controleer of je uitkomt op de webserver.
Ik had de NAS op een vast IP via een switch, nu direct verbonden, maakt niet uit. Toen die DHCP binding ingesteld, port forarding gekoppeld aan het nieuwe IP, alles weer opnieuw opgestart: geen effect. Gelukkig is de website nog steeds buiten wel bereikbaar.
Reputatie 7
Badge +28
In ieder geval bedankt voor het testen! Dat de server bereikbaar is is het belangrijkste. NAT loopback is wel een handige functie die gewoon moet werken. Ik ga er achteraan en laat het weten als ik terugkoppeling heb.
Nog geen terugkoppeling? Ik vind het nog steeds hoogst hinderlijk dat ik in mijn LAN de eigen website niet kan bereiken. Ligt het aan de Xperia,of aan de combinatie Xperia/modem?
Reputatie 7
Badge +28
Sorry voor de (hele) late reactie. Het Sagemcom 4G modem ondersteunt NAT loopback niet, de Experiabox V10 wel. Dit betekent dat als het 4G modem zit aangesloten NAT loopback niet functioneert. De enige workaround is om dit modem los te koppelen. Ik heb een verbetervoorstel ingediend om dit wel mogelijk te maken. Of/wanneer dat in behandeling genomen gaat worden kan ik je helaas nog niet vertellen. De workaround met het hostsbestand aanpassen is daarom nu de enige optie. Ik hoop dat dit gaat veranderen in de toekomst!
Hallo Joran,

Ik heb last van hetzelfde probleem. V10 aangesloten met 4g SIB. Gebruik een tp link en heb die als DMZ HOST ingesteld. Echter zijn alle smart Home applicatie niet meer intern te benaderen op het externe ip adres Maar wel extern te benaderen via get externe ip adres
Reputatie 5
Badge +11
Een goedemiddag!

Helaas is er nog geen andere oplossing voor handen dan de 'workaround' die Joran hierboven beschrijft. Kun je daarmee uit de voeten?

Het loskoppelen van het 4g modem is voor mij geen goede workaround omdat ik die hard nodig heb voor het behouden van voldoende bandbreedte. Wat betreft het aanpassen van hostbestand, daar ben ik onvoldoende bekend mee. Kun je mij van achtergrondinfo en uitleg voorzien dan verwacht ik deze workaround uit te kunnen voeren.
Reputatie 7
Badge +30
Het hostbestand zorgt er gewoon voor dat je DNS entries statisch in kan stellen. Dat klinkt leuk, maar werkt alleen als je en DNS naam / hostnaam aan je externe IP hebt gekoppeld. Die kan je dan in het hostbestand overrulen zodat je dan hem aan het interne IP kan binden.
Ongeveer zelfde workaround is je eigen (interne) DNS server draaien.

Zie o.a. https://serverfault.com/questions/283585/how-to-setup-my-host-file
Reputatie 6
Badge +7
Hallo Joran,

Ik heb last van hetzelfde probleem. V10 aangesloten met 4g SIB. Gebruik een tp link en heb die als DMZ HOST ingesteld. Echter zijn alle smart Home applicatie niet meer intern te benaderen op het externe ip adres Maar wel extern te benaderen via get externe ip adres

Joran heeft het over een Sagemcom i.c.m. EB v10, dus hybride ADSL+4G. Jij hebt het over een 'tp link' en EB v10.
Wat voor abo gaat het hier dan?
En hoe heb je de apparaten op elkaar aangesloten?
Is het SIB4G (dus gescheiden ADSL en 4G) of SIB (gecombineerd) ?
In het laaste geval verwondert het mij dat je iets aan het 4G apparaat moet veranderen en heb ik blijkbaar een ander idee van implementatie van SIB (hybride) dan dat het in werkelijk is. Dat Robin aangaf in andere thread dat bij hybride het 4G apparaat op een LAN poort van de EB v10 dient te worden aangesloten geeft wel te denken, voor mij in ieder geval.
Joran: "Ik heb een verbetervoorstel ingediend om dit wel mogelijk te maken. Of/wanneer dat in behandeling genomen gaat worden kan ik je helaas nog niet vertellen."

Dat is inmiddels 5 maanden geleden. Het blijft mal, dat je je website in je eigen LAN niet kan bereiken. Dat is toch een duidelijke fout in de apparatuur, waar wat aan gedaan moet worden?
Reputatie 7
Badge +30
Nou, het is gewoon het ontbreken van Hairpin NAT, maar dat is nogal lastig te realiseren omdat het externe IP niet altijd het IP op de Experiabox is.

Verder is Hairpin NAT bijna standaard voor de meeste gebruikers, maar bij heel veel iets professionelere apparatuur moet je dat zelf instellen.

Daarnaast kan je met DNS heel makkelijk verbinden met je interne IP als je in je eigen netwerk zit en op die manier gewoon verbinden. Het enigste probleem is dat je externe IP niet terugloopt.
Ik ben niet zo ingevoerd in het netwerkgebeuren, en om er voor dit probleem nou een studie van te maken.
Ik krijg reacties op de inhoud van mijn website, en dan wil ik thuis er naar kijken. Alleen op de MS computer kan ik dat, omdat ik daar een host file op heb. Als ik op mijn mobiel het moet zien, moet ik de wifi uitschakelen, en omdat ik in het buitengebied woon, heb ik slecht bereik. Leg mij eens uit hoe ik op mijn mobiel mijn eigen website thuis kan bereiken?
Reputatie 7
Badge +30
Boven in de adres balk http://192.168.2.x typen (het adres van je website).

Wil je per se hostnaam gebruiken dan moet je of een hostfile gebruiken, of een DNS server die je via DHCP meegeeft.
Adresbalk lukte niet, Synology maakt een virtuele host. Welk adres ik dan moet intikken is weer een zoekpartij.
Moest overigens vandaag weer de Experia resetten, omdat de website ook buiten niet bereikbaar was. Dat gebeurt regelmatig. Met de Fritzbox van Xs4all was dat niet zo.

Reageer