Vraag

Kpn buitengebied v10 modem+dsl geen poort forwarding

  • 25 april 2019
  • 9 reacties
  • 1100 keer bekeken

Beste,

Bij een vriend van me, vanavond zijn kpn buitengebied aangesloten. Hij heeft de nieuwe variant, een V10 modem + 4g modem. Gezien hij camera's heeft en een domotica systeem, had ik eerst het v10 modem aangesloten.

Ik heb de devices die van buitenaf bereikbaar moesten zijn, op basis van het mac-adres een vaste ip gegeven in de DHCP scoop. Vervolgens een app aangemaakt voor beide zaken en de poorten geforward.

Zover verliep het prima, camera's weet van buitenaf bereikbaar en ook zijn domotica. Vervolgens sluit ik het 4G modem op de V10 aan. Speedtest gedaan, werkt super. Heeft zomaar 40-50 mb ipv 7

Als ik nu de camera's en domotica probeer te bereiken van buitenaf, geeft dit niet thuis. Trek ik de kabel van het 4g modem uit de V10, dan is alles weer wel bereikbaar.

Hoe kan dat komen ? Is het wellicht van belang welke van de 4 aansluitingen van de V10 gebruikt word voor het 4g modem ?

Met vriendelijke groet,
Peter Huygens

9 reacties

Reputatie 7
Badge +28
Hoi Peter, vreemd dat het niet werkt. Het maakt niet uit welke ethernet aansluiting je gebruikt.

Zijn de apparaten vanuit het interne netwerk welk bereikbaar als het 4G modem zit aangesloten? Gaat het alleen om TCP verkeer of ook UDP verkeer?
Reputatie 5
Badge +6
Zover verliep het prima, camera's weet van buitenaf bereikbaar en ook zijn domotica. Vervolgens sluit ik het 4G modem op de V10 aan. Speedtest gedaan, werkt super. Heeft zomaar 40-50 mb ipv 7

Als ik nu de camera's en domotica probeer te bereiken van buitenaf, geeft dit niet thuis. Trek ik de kabel van het 4g modem uit de V10, dan is alles weer wel bereikbaar.

Met het aansluiten van de Sagemcom verandert ook het publieke IP adres waarna je naar toe verbindt voor de domotica enz. Het is mij niet duidelijk of hier wel rekening mee is gehouden.

Zover verliep het prima, camera's weet van buitenaf bereikbaar en ook zijn domotica. Vervolgens sluit ik het 4G modem op de V10 aan. Speedtest gedaan, werkt super. Heeft zomaar 40-50 mb ipv 7

Als ik nu de camera's en domotica probeer te bereiken van buitenaf, geeft dit niet thuis. Trek ik de kabel van het 4g modem uit de V10, dan is alles weer wel bereikbaar.
Met het aansluiten van de Sagemcom verandert ook het publieke IP adres waarna je naar toe verbindt voor de domotica enz. Het is mij niet duidelijk of hier wel rekening mee is gehouden.


Beste tmoesel,

Volgens www.mijnip.nl is het publieke ip niet anders. Ook als ik van zijn Domotica, naar mijn Domotica connect, zie ik in het log het zelfde ip adres inloggen als zonder 4g.

Met vriendelijke groet,
Peter
Hoi Peter, vreemd dat het niet werkt. Het maakt niet uit welke ethernet aansluiting je gebruikt.

Zijn de apparaten vanuit het interne netwerk welk bereikbaar als het 4G modem zit aangesloten? Gaat het alleen om TCP verkeer of ook UDP verkeer?


Beste Joran,

Dat zal ik van de week even checken als ik daar ben. Ik heb dat volgens mij gecheckt. Nu begin ik echter te twijfelen. Ik zet UDP en TCP altijd beide aan als ik poorten forward, ik weet nooit wat ik moet kiezen.

Met vriendelijke groet,
Peter
Reputatie 5
Badge +6
@PtjeHuygens Het kan best zo zijn het wisselen van publiek IP-adres niet meer aan de orde is als met 4G koppelt of ontkoppelt. KPN heeft wel meer zaken aangepast m.b.t. buitengebied internet, zie https://forum.kpn.com/internet-9/storing-port-forwarding-op-4g-buitengebied-470529

Zoals Joran ook al naar hint, het is verstandig om in handleiding o.i.d. te kijken wat de betreffende apparaten of services nodig hebben.
Voor TCP is er versnelling middels het bijschakelen van 4G, voor UDP niet.
Reputatie 7
Badge +28
Klopt. Wordt wel aan gewerkt overigens, naar verwachting kunnen we later dit jaar ook UDP signaal via 4G versnellen, met uitzondering van iTV streams.

Of dat met dit probleem te maken heeft weet ik niet, aangezien het zonder 4G modem wel werkt. Je hebt dan in ieder geval genoeg snelheid via ADSL om het beeld te uploaden. Ik ben benieuwd of de camera wel via het interne netwerk is te benaderen (via http://192.168.2.xx) als het 4G modem zit aangesloten.

Verder kan dit ook nog een probleem zijn met NAT loopback (zie NAT loopback met v10 werkt toch niet (Hairpinning) | KPN Community). NAT Loopback zorgt er voor dat je vanaf het thuisadres het externe IP-adres kunt aanroepen. Als je dus met een mobiel met hetzelfde WiFi netwerk verbonden bent kun je naar http://[extern ip adres]:[poort camera] gaan. Als NAT loopback niet werkt kun je niet het externe IP-adres gebruiken als je op hetzelfde netwerk zit, alleen het interne IP-adres. Als je de portfowarding testte terwijl je met hetzelfde netwerk verbonden was kan dit het probleem zijn. Het werkt dan wel via andere netwerken, je kunt dat testen met een mobiel op 4G.

NAT Loopback werkt niet met een V10 + 4G modem. Wel met alleen een V10. Een update voor de V10 waarin dit is opgelost is praktisch klaar maar heeft wat vertraging opgelopen door problemen met andere diensten. Exacte datum nog onbekend.
Beste allemaal,

Ik ben op locatie geweest en wat dingen bekeken. Of ik tcp of udp nodig heb weet ik alleen niet. Het gaat om het gebruik van Domoticz en Hikvision camera's. De apparaten zijn op een lokaal ip met aangesloten 4g modem wel bereikbaar.

Ik lees hierboven wel iets wat best zou kunnen. Ik heb inderdaad terwijl ik zelf in datzelfde netwerk zit, geprobeerd om van buitenaf in te loggen. Als dat een probleem kan zijn, ga ik dat eerst nog eens testen.

Alvast bedankt weer.

Gr.
Peter
Reputatie 7
Badge +28
@PtjeHuygens: We hebben inmiddels een fix voor het NAT loopback probleem. Die zal in de aankomende maanden worden uitgerold, ik kan die eerder naar het modem laten versturen. Als je kunt bevestigen dat dat het probleem is, laat het me weten. Kun je dan het klantnummer/adresgegevens van je vriend in een privébericht sturen? Naar verwachting kunnen we die dan volgende week op het modem zetten.
Reputatie 7
Badge +28
Ik heb nog geen bericht gezien @PtjeHuygens. Als ik hier nog bij kan helpen, laat het weten 🙂

Reageer