Vraag

Arris VIP 5202 update niet unifi usg

  • 11 mei 2020
  • 52 reacties
  • 2138 keer bekeken

Reputatie 2
Badge

Ik hoor allerlei berichten van mensen dat met een Unifi USG ze geen updates binnen kunnen halen op de VIP5202. Weet iemand of hier nog speciale instellingen op je router voor nodig zijn?

Na het, tijdelijk, terugplaatsen van de experiabox schijnt het weer te werken.

Of is het mogelijk om zelf een 5202 te kunnen ontvangen om het te testen? Er zijn een aantal mensen die mijn configuratie gebruiken, ik kan ze nu moeilijk helpen omdat ik zelf geen VIP 5202 heb. 


52 reacties

Reputatie 7

Dit zal sowieso door KPN ondersteund moeten gaan worden en ik heb daar ook alle vertrouwen is. Ik heb het gevoel dit te maken heeft met een ontbrekend DNS record.

Het lijkt er op dat de 5202 contact zoekt met sap.stb.itvonline.nl maar voor die url mist de DNS entry.

Nu wordt/is itvonline.nl door KPN omgezet in tv.kpn.com dus wellicht moet de 5202 contact zoeken met sap.stb.tv.kpn.com en daar is wel een DNS record voor vastgelegd.

Een work-around zou wellicht kunnen zijn om sap.stb.itvonline.nl ook naar dat IP adres te laten verwijzen.

 

Op een EdgeRouter kan je static host mappings maken...

...wat feitelijk DNS entries zijn in de lokale DNS server van de router.

Daarmee kan je dus zelf die workaround implementeren.

En dan maar hopen dat dat ontbrekende DNS record ook werkelijk de oorzaak is.

Reputatie 7
Badge +29

Beste @coolhva, goede vraag! We zijn dit aan het uitzoeken en ik hoop dan ook dat hier snel meer duidelijkheid over komt. Wil jij je forumprofiel aanvullen met je postcode + huisnummer en evt. klantnummer(s)? Mochten er meer voorbeelden nodig zijn, dan heb ik ze alvast :-).

Ik ervaar ook issues i.c.m. de Arris5202 (twee stuks). Mijn situatie is de USG Pro en grotendeels de config die @coolhva op zijn Github heeft gezet. Software updates worden niet gedownload en regelmatig hangen de 5202's in bootloop, er verschijnt dan error DBL-307. Oplossing is dan Experia-box terughangen, STB booten/updaten en daarna het geheel weer terugwisselen. 

Wat opvalt is dat als ik de STB aan de Experia-box aansluit, er een IP-adres tussen haakjes getoond wordt achter sap://sap.stb.itvonline.nl. Dat adres wordt niet zichtbaar zodra de STB achter de eigen Unifi-router is aangesloten.

De suggestie van @wjb triggerde me om een local entry te maken in de USG via:

set system static-host-mapping host-name sap.stb.itvonline.nl inet 145.128.80.135

Helaas geen verschil, voor die tijd resolvede die host overigens niet. Wel kwam er een resultaat op het TXT-record ("SAP/1/224.3.2.6:9875"). Ik gebruik de DNS-servers van Cloudflare. 

Zou wel gaaf zijn als we deze kunnen fixen. 

Na de DHCP-server configuratie in de USG aan te passen om de KPN DNS-servers uit te delen op het LAN (195.121.1.34/195.121.1.66), en een provision/reboot van de USG4P lijkt de STB nu wel de software te kunnen downloaden. Het multicast-adres wordt nu ook getoond op de status page.

Fingers crossed. 

Reputatie 7

En wat heb je dan aan de DHCP configuratie moeten aanpassen?

Reputatie 2
Badge

En wat heb je dan aan de DHCP configuratie moeten aanpassen?

De DNS servers die uitgedeeld worden door de DHCP server. Ik neem aan dat IPv4 DNS servers voldoende zijn of gebruikt de 5202 ook IPv6?

Voor zover ik kan zien doet de 5202 geen IPv6.

Ik vind 't overigens wel vreemd dat het probleem zich oplost heeft door de KPN DNS-servers te gebruiken. Hopelijk helpt het iemand bij het vinden van de echte oorzaak. Hier werkt het (voorlopig) prima. 

 

Reputatie 7

En wat heb je dan aan de DHCP configuratie moeten aanpassen?

De DNS servers die uitgedeeld worden door de DHCP server. Ik neem aan dat IPv4 DNS servers voldoende zijn of gebruikt de 5202 ook IPv6?

Op vlan 4 (IPTV) wordt alleen IPv4 gebruikt.

Een TV ontvanger hoeft dus alleen op basis van IPv4 te communiceren en vraagt zelf ook (nog) geen IPv6 adres aan.

 

Ik vind 't overigens wel vreemd dat het probleem zich oplost heeft door de KPN DNS-servers te gebruiken.

@kind0r, begrijp ik het goed dat je de standaard DNS servers van KPN hebt ingesteld en dat daarmee de installatie en configuratie van de Arris VIP5202 wel goed is verlopen?

En wat heb je dan aan de DHCP configuratie moeten aanpassen?

De DNS servers die uitgedeeld worden door de DHCP server. Ik neem aan dat IPv4 DNS servers voldoende zijn of gebruikt de 5202 ook IPv6?

Op vlan 4 (IPTV) wordt alleen IPv4 gebruikt.

Een TV ontvanger hoeft dus alleen op basis van IPv4 te communiceren en vraagt zelf ook (nog) geen IPv6 adres aan.

 

Ik vind 't overigens wel vreemd dat het probleem zich oplost heeft door de KPN DNS-servers te gebruiken.

@kind0r, begrijp ik het goed dat je de standaard DNS servers van KPN hebt ingesteld en dat daarmee de installatie en configuratie van de Arris VIP5202 wel goed is verlopen?

Dat klopt. Op mijn LAN worden nu ns1/ns2.wxs.nl uitgedeeld. Standaard was de USG DNS-server voor het LAN, en die forwarde in mijn geval naar Cloudflare.

Dus na die KPN DNS-servers te configureren gingen de 5202's hun updates downloaden en werken ze weer prima. 

Reputatie 7

Dat klopt. Op mijn LAN worden nu ns1/ns2.wxs.nl uitgedeeld. Standaard was de USG DNS-server voor het LAN, en die forwarde in mijn geval naar Cloudflare.

Dus na die KPN DNS-servers te configureren gingen de 5202's hun updates downloaden en werken ze weer prima. 

Dat is zeer interessante informatie.

Reputatie 1

Ik heb zelf de KPN DNS servers gebruikt op de FritzBox dit was voor mij geen oplossing. Ik deel echter wel het IP adres van mijn FritzBox uit aan de LAN clients als DNS server adres. Wat ik dus niet geprobeerd heb is de KPN DNS servers aan mijn LAN clients uitdelen.

 

Reputatie 7

Ik heb zelf de KPN DNS servers gebruikt op de FritzBox dit was voor mij geen oplossing. Ik deel echter wel het IP adres van mijn FritzBox uit aan de LAN clients als DNS server adres. Wat ik dus niet geprobeerd heb is de KPN DNS servers aan mijn LAN clients uitdelen.

Ik ben wel geïnteresseerd of dat wellicht andere resultaten geeft.

Het zou uiteraard niet zo mogen zijn maar soms zijn de wegen van KPN ondoorgrondelijk. :wink:

Reputatie 4
Badge +2

Heb deze week ook 2 maal een vip5202 gekregen. Heb deze achter mijn edgerouter hangen maar daar geeft het geen enkel probleem. Zojuist een nieuwe vip5202 geïnstalleerd en deze ging gewoon zijn updates binnen halen zonder ook maar iets aan de DNS te wijzigen. Is denk ik dus echt iets USG specifieks.

Reputatie 7
Badge +29

Dank voor je bericht, @Frank3523! Fijn om te lezen dat het bij jou wel gewoon werkt :-).

Hoi, hier ook een USG-Pro en nu een paar Arris vip5202’s. Bij initalisatie een 307 foutmelding en geen software. Totdat ik de experiabox er weer tussen hing.


Zal eens proberen om een A record aan te maken voor het resolven van de dns-naam en kijken of het helpt om de dns-en van KPN te gebruiken….

Als ik nu een nslookup vanuit mijn netwerk doe naar bovenstaande adressen dan krijg ik geen resultaat.

 

Misschien kan @Frank3523 verder specificeren hoe het kan dat het bij hem wel werkt?
Speciale routing ingesteld? Speciale DNS ingesteld? Welk type USG etc..

Reputatie 4
Badge +2

Misschien kan @Frank3523 verder specificeren hoe het kan dat het bij hem wel werkt?
Speciale routing ingesteld? Speciale DNS ingesteld? Welk type USG etc..

Ik heb dan ook geen USG maar een edgerouter. Deze is wat makkelijker te configureren dan een USG.

Ik heb gewoon het script gebruikt wat wjb heeft gemaakt. Ik denk dat het probleem echt alleen in de USG zit.

Thnx Frank,

Dan ga ik zelf wat knutselen met mn config :-)

Reputatie 1

@mintnl Ik heb hetzelfde probleem met een FritzBox, het ligt dus niet aan de USG alleen. Hier loopt al een draadje over dit probleem: Nieuwe 4k ontvangers willen niet opstarten

Ik heb een A record in dnsmasq gezet: sap.stb.itvonline.nl & sap.stb.tv.kpn.com deze liet ik verwijzen naar het door @wjb genoemde ip-adres 145.128.80.135.
Dit gaf geen verschil, behalve dat andere STB’s bij een reboot bleven hangen op 85% van de config. waarna een fout 562 werd weergegeven.

Dus er is verkeer van of naar naar dat adres/naam… Maar wat en hoe? Zover gaat mijn kennis niet.
 

Na het verwijderen van de A record uit de dns van de usg en een force-reload starten de STB’s wel weer door.
Maar kies je voor software verwijderen of fabrieksreset dan blijft het hele zaakje weer op DBL307 hangen.

Hier zojuist weer tv ontvanger vip5202 die niet wil starten en op update blijft hangen met foutcode 307. TV ontvanger op slaapkamer is ook een vip5202 en die draait nog als een zonnetje. DHCP nameserver staat op auto in mijn USG.

 

Zou het echt op prijs stellen als KPN met een oplossing komt hiervoor.

Reputatie 3
Badge

Hier een Edgerouter Lite gebruiker met 3 vip5202 in huis. Deze updaten gewoon prima!

Reputatie 2
Badge

Kunnen mensen eens proberen om 8.8.8.8 en 8.8.4.4 in te vullen als DHCP Name Servers bij het LAN netwerk (zodat de clients deze DNS servers krijgen) en daarna de tv kastjes opnieuw starten (zodat ze een nieuwe DHCP lease krijgen) en kijken of dit het probleem oplost?

Reputatie 3
Badge

Kunnen mensen eens proberen om 8.8.8.8 en 8.8.4.4 in te vullen als DHCP Name Servers bij het LAN netwerk (zodat de clients deze DNS servers krijgen) en daarna de tv kastjes opnieuw starten (zodat ze een nieuwe DHCP lease krijgen) en kijken of dit het probleem oplost?

Ik gebruik een Edgerouter lite 3 Deze DNS servers gebruik ik enig jaren zonder problemen. Ook het updaten werkt prima.

Reputatie 7

Ik gebruik een Edgerouter lite 3 Deze DNS servers gebruik ik enig jaren zonder problemen. Ook het updaten werkt prima.

Ik neem aan dat jij niet de "publieke" DNS servers doorzet naar de cliënts, maar dat je het IP adres van de EdgeRouter zelf als DNS server naar de cliënts doorzet en gebruik maakt van DNS forwarding.

Zo geef ik 192.168.4.254 als DNS server door aan de TV ontvangers en zijn op de EdgeRouter de DNS servers van CloudFlare en KPN gedefinieerd als DNS forwarding servers.

Hiermee verloopt de het updaten van onze TV ontvangers (ZXV8001 en HMB2260) probleemloos.

Reputatie 3
Badge

Ik gebruik een Edgerouter lite 3 Deze DNS servers gebruik ik enig jaren zonder problemen. Ook het updaten werkt prima.

Ik neem aan dat jij niet de "publieke" DNS servers doorzet naar de cliënts, maar dat je het IP adres van de EdgeRouter zelf als DNS server naar de cliënts doorzet en gebruik maakt van DNS forwarding.

Zo geef ik 192.168.4.254 als DNS server door aan de TV ontvangers en zijn op de EdgeRouter de DNS servers van CloudFlare en KPN gedefinieerd als DNS forwarding servers.

Hiermee verloopt de het updaten van onze TV ontvangers (ZXV8001 en HMB2260) probleemloos.

Nee inderdaad.

 IP van de router is DNS voor de cliënts

Reageer