Beantwoord

FTTH met Edgerouter geen interactieve TV of IPv6

  • 8 juli 2020
  • 18 reacties
  • 211 keer bekeken

Gisteren heb ik de door KPN verstrekte router vervangen door een Edgerouter X SFP. Nu werkt IPv6 niet meer en daarnaast werkt ook interactieve TV niet meer. De TV gids is wel zichtbaar en het menu, maar bv opnemen of vanaf het begin kijken werkt niet meer.

 

TV kijken zelf en IPv4 werkt wel. Telefonie gebruik bij de FTTH verbinding gebruik ik niet.

 

Mijn complete config staat op: https://pastebin.com/44z1pFYn

 

Heeft iemand een idee wat mogelijk het probleem is?

icon

Beste antwoord door wjb 13 juli 2020, 13:09

@mark8244, Heb je al naar de configuratiescripts voor de EdgeRouter gekeken die in het startbericht van het topic "Gebruik een eigen router i.p.v. de Experia Box" opgenomen zijn?

Die scripts activeren ook IPv6.

Ik adviseer je ook om het configuratiescript voor de EdgeRouter X gewoon te installeren op jouw EdgeRouter want ook jouw aanpassing t.a.v. IPTV zal maar tijdelijk werken aangezien het IP adres van de next hop zal kunnen wijzigen. Om dat definitief goed te zetten zal je rfc3442-classless-static-routes moeten implementeren. Ook dat is in die configuratiescripts opgenomen.

Bekijk origineel

18 reacties

Na contact met iemand op IRC die ook KPN heeft is het probleem rond TV opgelost. Nu mist enkel IPv6 nog.

 

Oplossing:

delete protocols static route 213.75.112.0/21 next-hop 10.228.208.1

set protocols static route 213.75.112.0/21 next-hop 10.254.96.1

 

De next-hop is de .1 (eerste ip na .0) van de /21 die je krijgt als IP eth0.4 (IPTV vlan naar KPN).

Reputatie 6
Badge +9

Dag @mark8244. Van harte welkom hier. Goed om te lezen dat de problemen rond iTV met de EdgeRouter zijn opgelost. Je geeft aan dat IPv6 nog mist. Heb je een Experia Box V10a? Dan kan het kloppen dat IPv6 uit staat in je modem. Het development team heeft IPv6 bij alle V10a gebruikers (remote) uitgezet wegens firewall issues.

Kun je anders verder toelichten waar je tegenaan loopt? Kun je IPv6 niet aanzetten of zie je de optie niet? En zou je verder je profiel aan kunnen vullen met je postcode/huisnummer, klantnummer en de naam van de contracthouder? Geef een seintje als je dit hebt gedaan.

Dag @mark8244. Van harte welkom hier. Goed om te lezen dat de problemen rond iTV met de EdgeRouter zijn opgelost. Je geeft aan dat IPv6 nog mist. Heb je een Experia Box V10a? Dan kan het kloppen dat IPv6 uit staat in je modem. Het development team heeft IPv6 bij alle V10a gebruikers (remote) uitgezet wegens firewall issues.

Kun je anders verder toelichten waar je tegenaan loopt? Kun je IPv6 niet aanzetten of zie je de optie niet? En zou je verder je profiel aan kunnen vullen met je postcode/huisnummer, klantnummer en de naam van de contracthouder? Geef een seintje als je dit hebt gedaan.

 

Welke Experia box ik heb durf ik zo niet te zeggen. Die is er in ieder geval tussen uit en staat uit. Dat is hopelijk niet het probleem (hoewel dit wel afhankelijk is van hoe jullie het uit hebben gezet).

 

De informatie heb ik zoveel mogelijk toegevoegd. Overigens is het hier ook gekoppeld aan mijn KPN account als het goed is.

Reputatie 6
Badge +9

Duidelijk, @mark8244. Voor zover ik kan zien, is IPv6 in ieder geval actief. Ik moet wel zeggen dat ik verder weinig verstand heb van de configuratie van de EdgeRouter. @wjb, wil/kun jij eens meedenken? :slight_smile:

Reputatie 7

@mark8244, Heb je al naar de configuratiescripts voor de EdgeRouter gekeken die in het startbericht van het topic "Gebruik een eigen router i.p.v. de Experia Box" opgenomen zijn?

Die scripts activeren ook IPv6.

Ik adviseer je ook om het configuratiescript voor de EdgeRouter X gewoon te installeren op jouw EdgeRouter want ook jouw aanpassing t.a.v. IPTV zal maar tijdelijk werken aangezien het IP adres van de next hop zal kunnen wijzigen. Om dat definitief goed te zetten zal je rfc3442-classless-static-routes moeten implementeren. Ook dat is in die configuratiescripts opgenomen.

Reputatie 6
Badge +9

Kun je met deze adviezen van @wjb eerst uit de voeten, @mark8244:thumbsup_tone2:

Reputatie 6
Badge +9

Hallo @mark8244. Ik heb geen reactie meer van je gezien. Ik hoop dat dit betekent dat het inmiddels is opgelost. Mocht je toch nog ergens hulp bij nodig hebben, dan lees ik het graag.

@mark8244, Heb je al naar de configuratiescripts voor de EdgeRouter gekeken die in het startbericht van het topic "Gebruik een eigen router i.p.v. de Experia Box" opgenomen zijn?

Die scripts activeren ook IPv6.

Ik adviseer je ook om het configuratiescript voor de EdgeRouter X gewoon te installeren op jouw EdgeRouter want ook jouw aanpassing t.a.v. IPTV zal maar tijdelijk werken aangezien het IP adres van de next hop zal kunnen wijzigen. Om dat definitief goed te zetten zal je rfc3442-classless-static-routes moeten implementeren. Ook dat is in die configuratiescripts opgenomen.

Daar heb ik naar gekeken en onder andere het stuk rond IPTV heb ik overgenomen en dat gaat goed met reboots. IPv6 gaat nog niet goed. Daar ga ik vanavond een nieuwe poging voor doen om alles te vergelijken. Het volledig overnemen van de daar gebruikte configs zorgt dat onder andere de IP ranges worden aangepast en wat andere zaken mogelijk stuk gaan. Daarom vergelijk ik de verschillen en kijk ik wat over te nemen is zonder IPv4 te slopen. Zodra ik een werkende configuratie heb zal ik die ergens delen (en als ik wat tijd en energie er voor heb maak ik gelijk een simpele pagina om een complete (maatwerk) configuratie te krijgen). Aan de hand van voorbeelden die ik heb gekregen van verschillende kanten werkt het gasten netwerk inmiddels al wel goed.

Inmiddels heb ik alles doorgevoerd en dit maakt voor IPv6 niet uit. De firmware van de Edgerouter ook gelijk bijgewerkt naar de laatste versie en dat lost het niet op.

 

Het lijkt wel alsof IPv6 op de verbinding uit staat. Enkel een fe80: adres zie ik en dat is voor link local. Ten minste ik zie nergens een IP dat publiek is of lijkt.

Na nog wat verder stoeien lijkt het in de basis nu te werken. Nu even afwachten of het over een paar dagen nog werkt (zo ja dan zal ik even ergens een config delen).

Reputatie 7

Bij mij is IPv6 al jaren operationeel, ook achter mijn EdgeRouter Lite 3 die bijna twee jaar terug de Experia Box vervangen heeft.

 

Reputatie 6
Badge +9

Als ik het goed begrijp heb je nu alles in de basis, dus ook iTV, werkend. Dat is fijn. Anders zou je nog even kunnen kijken naar de IPv6 instellingen die @wjb bovenstaand deelt. :slight_smile:

IPv6 met statische IP adressen werkt. Verder nog niet. Naar de voorbeelden van @wjb heb ik gekeken. Apparaten die IPv6 nodig hebben geef ik voorlopig wel een statisch IPv6 adres en anders regel ik dat probleem binnenkort wel met een Raspberry PI die hier ook nog hangt.

 

Hiermee is het opgelost.

Reputatie 7

Hoezo statische IPv6 adressen, elk apparaat dat op basis van SLAAC een IPv6 verkregen heeft, heeft naast een dynamisch (frequent wijzigend) IPv6 adres, sowieso een statisch IPv6 adres.

Kan je eens de configuratie van jouw EdgeRouter X SFP met ons delen.

 

@wjb De complete config is te vinden op https://p.6core.net/p/3TVOWNGY6LncZwZi9CFBJ9Ri

Reputatie 7

Waarom heb je een DHCPv6 relay gedefinieerd?

Ik zou je ook aan willen raden nog eens goed naar de configuratie t.a.v. IPTV te kijken want daar ga je nog problemen mee krijgen op de manier waarop dat nu geconfigureerd is.

Zorg er voor, als dat nog niet het geval is, dat rfc3442 classless static routes geïnstalleerd is (Zie configuratiescripts in het openingsbericht van dit topic) en verwijder de static route naar 213.75.112.0/21.

Ook nat rule 5000 is niet nodig.

Waarom heb je een DHCPv6 relay gedefinieerd?

Ik zou je ook aan willen raden nog eens goed naar de configuratie t.a.v. IPTV te kijken want daar ga je nog problemen mee krijgen op de manier waarop dat nu geconfigureerd is.

Zorg er voor, als dat nog niet het geval is, dat rfc3442 classless static routes geïnstalleerd is (Zie configuratiescripts in het openingsbericht van dit topic) en verwijder de static route naar 213.75.112.0/21.

Ook nat rule 5000 is niet nodig.

 

Het probleem met IPTV is opgelost. Dat gebeurd via het scriptje uit het andere topic voor de rfc3442 classles static routes installatie doet. Dit werkt al enkele reboots goed.

 

IPv6 werkt inmiddels ook. Zodra er binnenkort verder niemand thuis is ga ik de DHCPv6 relay weg halen en ook nat rule 5000 verwijderen.

Reputatie 6
Badge +9

Fijn dat je alles inmiddels werkend hebt gekregen, @mark8244. Als je toch nog ergens tegenaan loopt, laat het dan gerust weten.

Reageer