Gebruik een eigen router i.p.v. de Experia Box

  • 8 september 2018
  • 1180 reacties
  • 102789 keer bekeken


Toon eerste bericht

1180 reacties

@Ronald Heirbaut,
Hmm, ik kan zo niet inschatten wat die extra toevoegingen zouden moeten oplossen maar.... Waarom je STB direct op de edge?. Dat gaat bij iedereen fout gezien de multicast streams op alle devices komt te lopen en dat is hapering of vastlopen.

als je storing loos wil kijken is het:
NTU---> Edgerouter ---> Switch op eth1 van de ER, met IGMP snooping AAN!!----> STB en overige apparaten op poorten switch en dus niet een bypass maken.
Als je meerdere switches hebt, wederom IGMP snooping AAN.

Niet op overige poorten van de edge andere apparatuur aansluiten of direct de STB, dit gaat fout!


Klopt, dat heb, en had ik zo. Dat heeft het een poosje gedaan en toen kreeg ik gedoe. Dan doe je een soort omgekeerde deductie test. Als test, en alleen als test, alleen de EdgeRouter en 1 STB en verder helemaal niks: dat werkte. Dan switch toevoegen (uiteraard met IGMP snooping aan) en de STB aan de switch natuurlijk, en langzaam maar zeker van alles er bij. Het ging fout toen ik een Cisco SLM2008 (met IGMP snooping aan) er bij zette. Blijkbaar is die implementatie net even anders. Die er weer af, en dan zou je verwachten dan als je alles herstart, je weer een goede werkende situatie zou krijgen; immers, dat was net voor het aansluiten van de SLM2008 ook zo. Maar nee, toen werkte alles weer niet. Daar kan ik slecht tegen, iets wat eerst wel werkt, en daarna in dezelfde configuratie niet meer.

Dus ik besloot om die hele !@&*^!#*-KPN er maar uit te flikkeren. Gaan kijken bij Tweak, en daar vond ik de whitelist-oplossing. Voor mij werkt het.
Reputatie 3
Badge +3
Dus ik besloot om die hele !@&*^!#*-KPN er maar uit te flikkeren. Gaan kijken bij Tweak, en daar vond ik de whitelist-oplossing. Voor mij werkt het.

Als het werkt is het uiteraard fijn maar welke switches gebruik je nu? Zou het dan toch in het gebruik van de randapparatuur liggen. Dit gezien @wjb nagenoeg en toevallig dezelfde switches gebruikt als ik.

Genexis NTU---> ER lite v3----> Netgear GS108Ev3----->Netgear GS110TP---> 2 x GS105Ev2
Reputatie 7
Dus ik besloot om die hele !@&*^!#*-KPN er maar uit te flikkeren. Gaan kijken bij Tweak, en daar vond ik de whitelist-oplossing. Voor mij werkt het.
Heb je een link?

Kijk overigens ook eens op die Cisco switch of daar IGMP querying wellicht aan staat.
Dat zou namelijk precies die problemen verklaren, IGMP querying moet uit staan op die SLM2008.

Dus ik besloot om die hele !@&*^!#*-KPN er maar uit te flikkeren. Gaan kijken bij Tweak, en daar vond ik de whitelist-oplossing. Voor mij werkt het.Heb je een link?

Tuurlijk! http://www.nickd.nl/tweak/edgerouter/
Dan heeft hij een link naar zijn configfile: http://www.nickd.nl/tweak/edgerouter/edgeos_ubnt_20171024.tar.gz
Uiteraard is dat voor tweak, maar KPN wijkt niet veel af.

Dat zou namelijk precies die problemen verklaren, IGMP querying moet uit staan op die SLM2008.


Klopt. Staat uit. Maar uit of aan, maakt geen verschil. Misschien komende week nog eens proberen en testen met die switches. Ik heb er een paar.
Reputatie 3
Badge +3
En daar duikt ook de benodigdheden weer op, heeft denk ik gewoon te maken met type switch, IGMP snooping V2/V3

Benodigdheden


  • EdgeRouter Lite, voorzien van firmware v1.9.0. Gebruik port 0 voor je LAN en port 1 voor WAN.
  • Achter de EdgeRouter Lite is een switch nodig om devices op het netwerk aan te sluiten. Gebruik bij voorkeur een switch met IGMP Snooping. Ik gebruik zelf een Netgear GS108Ev3.
  • Haal uit de ZyXEL interface de MAC-adressen van de ETHWAN interface en IPTV interface. Deze MAC-adressen kunnen weer worden gebruikt door de EdgeRouter. Zo is het mogelijk om hetzelfde IP adres te behouden.
  • Linux kennis, met name vi editor.
Reputatie 7
Kijk ook nog even naar jouw SLM2008 want ik krijg toch echt het vermoeden dat IGMP querying daarop aan staat.
In principe zou je absoluut geen whitelist op hoeven geven bij de IGMP proxy server.
Is er echter in het netwerk een tweede IGMP proxy server of een IGMP queryer, dan kan je wachten op problemen en wel precies zoals je die ervaart. Je kunt de klok er dan ongeveer op gelijk zetten, telkens na exact dezelfde tijd zal het scherm "bevriezen" omdat de TV ontvanger "denkt" de TV stream bij die andere IGMP proxy server dan wel IGMP queryer op te moeten halen.

Als het werkt is het uiteraard fijn maar welke switches gebruik je nu? Zou het dan toch in het gebruik van de randapparatuur liggen. Dit gezien @wjb nagenoeg en toevallig dezelfde switches gebruikt als ik.

Genexis NTU---> ER lite v3----> Netgear GS108Ev3----->Netgear GS110TP---> 2 x GS105Ev2

Van alles:
NTU --> ER PoE --> UBNT US-24 --> SLM2005|SLM2008|TPlink SG108|Cisco SE2800
Die Linksys/Cisco SLM liggen er nu even uit.
Reputatie 7
Van alles:
NTU --> ER PoE --> UBNT US-24 --> SLM2005|SLM2008|TPlink SG108|Cisco SE2800
Die Linksys/Cisco SLM liggen er nu even uit.

Een EdgeRouter PoE.
Welk configuratiescript had je dan gebruikt immers er is er nog geen voor de EdgeRouter PoE in het openingsbericht van dit topic opgenomen.
Kijk ook nog even naar jouw SLM2008 want ik krijg toch echt het vermoeden dat IGMP querying daarop aan staat.
In principe zou je absoluut geen whitelist op hoeven geven bij de IGMP proxy server.
Is er echter in het netwerk een tweede IGMP proxy server of een IGMP queryer, dan kan je wachten op problemen en wel precies zoals je die ervaart. Je kunt de klok er dan ongeveer op gelijk zetten, telkens na exact dezelfde tijd zal het scherm "bevriezen" omdat de TV ontvanger "denkt" de TV stream bij die andere IGMP proxy server dan wel IGMP queryer op te moeten halen.

Helemaal mee eens, maar hoe vind je uit welk device die andere IGMP proxy of querier is? Ben al een poosje aan het gluren geweest met wireshark, maar noppes nada te zien.

Van alles:
NTU --> ER PoE --> UBNT US-24 --> SLM2005|SLM2008|TPlink SG108|Cisco SE2800
Die Linksys/Cisco SLM liggen er nu even uit.
Een EdgeRouter PoE.
Welk configuratiescript had je dan gebruikt immers er is er nog geen voor de EdgeRouter PoE in het openingsbericht van dit topic opgenomen.

Maakt niks uit tov een Edgerouter Lite. Ik gebruik port 2, 3 en vier toch niet. Maar ik wil je wel een link doen naar mijn config.boot hoor.
Reputatie 3
Badge +3

Van alles:NTU --> ER PoE --> UBNT US-24 --> SLM2005|SLM2008|TPlink SG108|Cisco SE2800Die Linksys/Cisco SLM liggen er nu even uit.


Overigens zitten alle STB's 1 x direct en 1 x indirect (met tussenkomst van een GS105Ev2) op de GS108Ev3 aangesloten. 1 dingetje heb ik wel, als beide STB's op hetzelfde kanaal kijken heb ik even een kleine hapering. Als ik eerst de Netgear GS110TP poe switch achter de ER hang is het hier NOGO.

Los dat KPN, ongevraagd, portforwards aanmaakt voor de STB's gebruiken ze volgens mij hetzelfde principe als de mikrotik routers. deze isoleren op basis van MAC adressen waar de broadcast streams heen moeten dus hebben de overige aangesloten apparaten hier geen hinder van.
Reputatie 7
Maakt niks uit tov een Edgerouter Lite. Ik gebruik port 2, 3 en vier toch niet. Maar ik wil je wel een link doen naar mijn config.boot hoor.
Graag.

Maakt niks uit tov een Edgerouter Lite. Ik gebruik port 2, 3 en vier toch niet. Maar ik wil je wel een link doen naar mijn config.boot hoor.Graag.

https://www.heirbaut.org/config.ubnt
Overigens heb ik een aantal multicast adressen in de whitelist staan. 239.0.0.0 range was wel voldoende. Die range zit ik in.
Reputatie 7
Zo op het eerste gezicht zie ik geen significante verschillen tussen jouw config en de config voor de EdgeRouter Lite 3 zonder telefonie die de problemen die jij ervaart met de TV ontvangers zou kunnen verklaren.
Ik zie bij jou het alt-subnet op 217.166.0.0/16 staan terwijl ik 0.0.0.0/0 gebruik. Beide is goed.
Jij gebruikt dus die drie whitelists terwijl ik geen whitelists gebruik. De reden is dat de documentatie aangeeft dat alle IP adressen "whitelisted" zijn als je geen whitelist definieert.

Welke versie van EdgeMAX draait op jouw EdgeRouter ... 1.10.8?
Ik zie bij jou het alt-subnet op 217.166.0.0/16 staan terwijl ik 0.0.0.0/0 gebruik. Beide is goed.
Jij gebruikt dus die drie whitelists terwijl ik geen whitelists gebruik. De reden is dat de documentatie aangeeft dat alle IP adressen "whitelisted" zijn als je geen whitelist definieert.


Klopt, dat is een bewuste keuze mocht ik ooit met andere multicasters te maken hebben. Mijn zoon kijkt regelmatig naar twitch.tv. Nu weet ik niet of dat unicast of multicast is, maar nu hoef ik me er niet meteen zorgen over te maken. Nadeel is dat ik aan het werk moet als KPN besluit om die IP range weer aanpast. Dat is al eens gebeurd.

Welke versie van EdgeMAX draait op jouw EdgeRouter ... 1.10.8?

Klopt. Doorgaans zit ik altijd op de laatste versie, al kijk ik natuurlijk niet elke dag of er een update is.
Reputatie 7
Ik zie bij jou het alt-subnet op 217.166.0.0/16 staan terwijl ik 0.0.0.0/0 gebruik. Beide is goed.Klopt, dat is een bewuste keuze mocht ik ooit met andere multicasters te maken hebben. Mijn zoon kijkt regelmatig naar twitch.tv. Nu weet ik niet of dat unicast of multicast is, maar nu hoef ik me er niet meteen zorgen over te maken. Nadeel is dat ik aan het werk moet als KPN besluit om die IP range weer aanpast. Dat is al eens gebeurd.
IGMP multicasts worden alleen gebruikt bij live streaming diensten of in ieder geval streaming diensten waarbij de stream op hetzelfde moment aan meerdere afnemers aangeboden moet worden.
Ook als er andere "multicasters" zullen komen kan je het alt-subnet rustig op 0.0.0.0/0 laten staan. Dit subnet definieert vanaf welke adressen IGMP multicasts geaccepteerd worden.
0.0.0.0/0 geeft dus aan dat IGMP multicasts vanaf alle adressen geaccepteerd worden.
Let op, dit zijn dus alle adressen op vlan 4, het IPTV vlan. Die andere "multicasters" zullen binnenkomen op vlan 6 en daar is geen IGMP proxy server voor geconfigureerd. Die zal je dan apart in de configuratie moeten opnemen en ook daar zou je weer als alt-subnet 0.0.0.0/0 kunnen gebruiken als je alle "multicasters" wilt accepteren.

Mijn advies is om het alt-subnet voor de IGMP proxy server t.b.v. IPTV (vlan 4) op 0.0.0.0/0 te zetten immers dan heb je er ook geen omkijken naar mocht KPN haar multicast adressen weer eens wijzigen.

Let op, dit zijn dus alle adressen op vlan 4, het IPTV vlan. Die andere "multicasters" zullen binnenkomen op vlan 6 en daar is geen IGMP proxy server voor geconfigureerd. Die zal je dan apart in de configuratie moeten opnemen en ook daar zou je weer als alt-subnet 0.0.0.0/0 kunnen gebruiken als je alle "multicasters" wilt accepteren.

Mijn advies is om het alt-subnet voor de IGMP proxy server t.b.v. IPTV (vlan 4) op 0.0.0.0/0 te zetten immers dan heb je er ook geen omkijken naar mocht KPN haar multicast adressen weer eens wijzigen.


Daar heb je een punt 😉

Ik heb de EdgeRouter Lite 3 aangesloten en mijn netwerk functioneert. De IP-TV ontvangers willen niet registreren als ze niet op de Experiabox aangesloten zitten. Dus daarvoor de Box aan moeten sluiten.Nee, dat zou niet nodig moeten zijn, de TV ontvangers behoren gewoon te werken achter de EdgeRouter. Ik neem aan dat je de configuratiescripts uit het openingsbericht van dit topic gebruikt hebt en na configuratie de EdgeRouter nog een keer gereboot hebt.

Ik neem aan de je de Experia Box niet in jouw netwerk hebt hangen.

De configuratie van die Netgear is prima.

Heb je nog een andere router als wifi accesspoint in jouw netwerk hangen?


Hoi Wjb,

Ik heb de edgerouter weer even teruggehangen maar IPTV is niet te doen. Beeld bevriest meteen.
Op jouw vraag of ik nog een wifi accesspoint heb hangen is het antwoord ja. Dit is een Fritzbox 7490 met daaraan gekoppeld 2 Fritz repeaters voor het draadloze netwerk. Hierin zit ook mijn Cheapconnect telefonie.
Wat ik begrijp is dat de Fritzbox mogelijk roet in het eten gooit. Deze beschikt nl niet over IMGP snooping. Is het wellicht dan een idee om het draadloze netwerk aan eth2 te hangen van de Edgerouter? Heeft dit nog voor- of nadelen dan? Of heb jij mogelijk nog een andere suggestie?

Ik heb het aansluiten nog niet geprobeerd met de Fritzbox losgekoppeld overigens.

Hopelijk komen we tot een oplossing Alvast bedankt weer.
Gr. Hans
Reputatie 7
Op jouw vraag of ik nog een wifi accesspoint heb hangen is het antwoord ja. Dit is een Fritzbox 7490 met daaraan gekoppeld 2 Fritz repeaters voor het draadloze netwerk.
Een Fritz!Box 7490, dat betekent dat je een LAN-LAN verbinding tussen de EdgeRouter en de Fritz!Box hebt gemaakt immers de 7490 heeft geen RJ45 WAN poort.
Dit druist tegen alle richtlijnen in en het is ook sterk af te raden.

Koppel die Fritz!box los en ik verwacht dat het dan direct zal werken.
Die Fritz!Box heeft vast een ingebouwde IGMP proxy server en daar gaat het mis met die LAN-LAN verbinding.
Zie het laatste stukje van het openingsbericht van het topic "Gebruik een eigen router achter de Experia Box".


Een Fritz!Box 7490, dat betekent dat je een LAN-LAN verbinding tussen de EdgeRouter en de Fritz!Box hebt gemaakt immers de 7490 heeft geen RJ45 WAN poort.
Dit druist tegen alle richtlijnen in er het is ook sterk af te raden.

Koppel die Fritz!box los en ik verwacht dat het dan direct zal werken.
Die Fritz!Box heeft vast een ingebouwde IGMP proxy server en daar gaat het mis met die LAN-LAN verbinding.
Zie het laatste stukje van het openingsbericht van het topic "Gebruik een eigen router achter de Experia Box".



Als ik de instructies van de Fritzbox begrijp zou het een Wan-LAN verbinding zijn maar goed, ik ga het proberen. Hoe is bij jou de cheap Connect verbinding geregeld?
ik heb de Fritz gehouden ivm de mogelijkheid om hierop de telefonie te regelen en de mesh WiFi die hierop nu actief is. Maar dit is dus op deze wijze niet aan te raden? Gr Hans
Reputatie 3
Badge +3

Als ik de instructies van de Fritzbox begrijp zou het een Wan-LAN verbinding zijn maar goed, ik ga het proberen. Hoe is bij jou de cheap Connect verbinding geregeld?
ik heb de Fritz gehouden ivm de mogelijkheid om hierop de telefonie te regelen en de mesh WiFi die hierop nu actief is. Maar dit is dus op deze wijze niet aan te raden? Gr Hans


Zo te zien heeft wjb gelijk, er zit alleen een dsl aansluiting op die ze op glasvezel van bijvoorbeeld xs4all niet gebruiken maar port 1 lan:
https://www.xs4all.nl/service/diensten/internet/installeren/glasvezel-aansluiten/7390-7490-aansluiten.htm

Als je wel een WAN port zou hebben dan gaat dat prima, router op de WAN port aansluiten en via de DHCP een ip adres laten verkrijgen van de ER. Mogelijk kan je op die fritsbox wel een WAN port aanmaken op bv LAN 1
Reputatie 7
Hoe is bij jou de cheap Connect verbinding geregeld?
Mijn CheapConnect verbinding heb ik op een Gigaset N300A IP geconfigureerd, maar je kunt ook bijvoorbeeld een Cisco SPA112 VoIP ATA of een Grandstream Handytone HT801 gebruiken.

Ik lees overigens dat LAN poort 1 ook als WAN poort gebruikt kan worden, maar dan moet je wel ergens kunnen configureren dat die poort als WAN poort gezien moet worden.
Ik lees overigens dat LAN poort 1 ook als WAN poort gebruikt kan worden, maar dan moet je wel ergens kunnen configureren dat die poort als WAN poort gezien moet worden.

Dat klopt wjb. Maar zover ik het nu lees moet ik deze zo configureren dat de Fritzbox een eigen internet verbinding opbouwt.
(https://nl.avm.de/service/fritzbox/fritzbox-7390/knowledge-base/publication/show/3229_FRITZ-Box-configureren-als-gecascadeerde-router/)

Ik ga dat deze week nog wel even proberen. Hopelijk is dit het laatste puzzelstukje.

Reageer