Sticky

Gebruik een eigen router i.p.v. de Experia Box

  • 8 September 2018
  • 8546 reacties
  • 560620 keer bekeken
Gebruik een eigen router i.p.v. de Experia Box

Toon eerste bericht

8546 reacties

Reputatie 7

Heb het vermoeden dat er bij de KPN met een nieuwe software update wat veranderd is.

Mijn stelling is dat je nooit naar anderen moet wijzen voordat je vastgesteld hebt dat het issue niet door eigen componenten veroorzaakt wordt.

Wat is het probleem dat je ervaart?

Welke software update verdenk je dan?

Ik heb op mijn Edgemax Pro 8 niet veranderd gisteren.

Wanneer ik de Experia Box terug plaats en dan start de VIP5202 en werkt het. Wanneer ik dan alles weer terug prik naar de Edgemax werkt de tv nog steeds.

Dus denk dat de software update van de VIP5202 problemen heeft krijg een 561 error.

 

Reputatie 7

Dus denk dat de software update van de VIP5202 problemen heeft krijg een 561 error.

Welke DNS server(s) heb je ingesteld staan op jouw EdgeRouter?

Ik neem aan dat je de 5202 wel even van stroom afgehaald hebt nadat je de EdgeRouter weer teruggeplaatst hebt, klopt dat?

Ik denk overigens niet dat dit veroorzaakt is door een software update van de 5202 immers dan had mijn 5202 ook problemen moeten geven.

Ik heb mijn OPENWRT router ingesteld voor internet van KPN met PPPOE / vlan6, probleem is echter dat de verbinding na circa 10 seconden weer wegvalt, daarna weer opbouwd enzovoorts. 

Dus het werkt wel want in die 10 seconden is er ook internet toegang maar dan voor korte duur. 

Waar zou dat aan kunnen liggen? Welke parameter kan een dergelijk gedrag veroorzaken?

OPENWRT is de laatste versie met alle updates. 

 

Ja heb hem 10 minuten van stroom gelaten,

Hier stukken van mijn configuratie:

 

    name WAN_IPTV_IN {
        default-action drop
        rule 1 {
            action accept
            description "Allow established/related"
            log disable
            protocol all
            state {
                established enable
                invalid disable
                new disable
                related enable
            }
        }
        rule 2 {
            action drop
            description "Drop invalid state"
            log disable
            protocol all
            state {
                established disable
                invalid enable
                new disable
                related disable
            }
        }
        rule 3 {
            action accept
            description "Allow IGMP multicasts"
            destination {
                address 224.0.0.0/4
            }
            protocol udp
        }
    } 

 

 ethernet eth1 {
        description "Internet Interface"
        duplex auto
        mtu 1512
        speed auto
        vif 4 {
            address dhcp
            description "XS4ALL VLAN 4 - IPTV"
            dhcp-options {
                client-option "send vendor-class-identifier "IPTV_RG";"
                client-option "request subnet-mask, routers, rfc3442-classless-static-routes;"
                default-route no-update
                default-route-distance 210
                name-server update
            }
            firewall {
                in {
                    name WAN_IPTV_IN
                }
            }
            mtu 1500
        }
        vif 6 {
            description "KPN Internet"
            firewall {
                in {
                    ipv6-name WANv6_IN
                    name WAN_IN
                }
                local {
                    ipv6-name WANv6_LOCAL
                    name WAN_LOCAL
                }
            }
            ipv6 {
                dup-addr-detect-transmits 1
            }
            mtu 1508
            pppoe 0 {
                default-route auto
                dhcpv6-pd {
                    no-dns
                    pd 0 {
                        interface eth7 {
                            host-address ::1
                            no-dns
                            prefix-id :1
                            service slaac
                        }
                        interface pppoe0 {
                            host-address ::1
                            prefix-id :2
                            service slaac
                        }
                        prefix-length /48
                    }
                    rapid-commit enable
                }
                firewall {
                    in {
                        ipv6-name WANv6_IN
                        name WAN_IN
                    }
                    local {
                        ipv6-name WANv6_LOCAL
                        name WAN_LOCAL
                    }
                }
                idle-timeout 180
                ipv6 {
                    address {
                        autoconf
                    }
                    dup-addr-detect-transmits 1
                    enable {
                    }
                }
                mtu 1500
                name-server auto
                password ****************
                user-id 73-A8-8E-6B-1B-99@internet
            }
        }
        vif 7 {
            bridge-group {
                bridge br0
            }
            description "eth1.7 - Telefonie"
        }
    }
 

   ethernet eth7 {
        address 10.1.10.1/24
        description "Management LAN"
        duplex auto
        ipv6 {
            dup-addr-detect-transmits 1
            router-advert {
                cur-hop-limit 64
                link-mtu 0
                managed-flag false
                max-interval 600
                name-server 2001:4860:4860::8888
                name-server 2001:4860:4860::8844
                other-config-flag false
                prefix ::/64 {
                    autonomous-flag true
                    on-link-flag true
                    valid-lifetime 2592000
                }
                radvd-options "RDNSS 2001:4860:4860::8888 2001:4860:4860::8844 {};"
                reachable-time 0
                retrans-timer 0
                send-advert true
            }
        }
        speed auto
        vif 4 {
            address 192.168.4.254/24
            egress-qos "0:5 1:5 2:5 3:5 4:5"
        }
     }
 

service {
    dhcp-server {
        disabled false
        global-parameters "option tftp-server code 150 = ip-address;"
        global-parameters "option vendor-class-identifier code 60 = string;"
        global-parameters "option broadcast-address code 28 = ip-address;"
        hostfile-update disable
        shared-network-name Datacenter {
            authoritative enable
            subnet 10.1.10.0/24 {
                default-router 10.1.10.1
                dns-server 10.1.10.1
                domain-name familie-berg.org
                lease 86400
                ntp-server 10.1.10.1
                start 10.1.10.100 {
                    stop 10.1.10.200
                }
          }
         shared-network-name IPTV {
            authoritative enable
            subnet 192.168.4.0/24 {
                default-router 192.168.4.254
                dns-server 195.121.1.34
                dns-server 195.121.1.66
                domain-name iptv.local
                lease 86400
                start 192.168.4.1 {
                    stop 192.168.4.6
                }
            }
        }
 

    nat {
           rule 5001 {
            description "MASQ corporate_network to IPTV network"
            destination {
                address 213.75.112.0/21
            }
            log disable
            outbound-interface eth1.4
            protocol all
            type masquerade
        }
        rule 5002 {
            description "MASQ corporate_network to IPTV network"
            destination {
                address 10.16.0.0/16
            }
            log disable
            outbound-interface eth1.4
            protocol all
            type masquerade
        }
        rule 5003 {
            description "masquerade for WAN"
            log disable
            outbound-interface pppoe0
            protocol all
            type masquerade
        }
 

protocols {
    igmp-proxy {
        interface eth1.4 {
            alt-subnet 0.0.0.0/0
            role upstream
            threshold 1
        }
        interface eth7.4 {
            alt-subnet 0.0.0.0/0
            role downstream
            threshold 1
        }
    }
    ospf {
    }
    static {
        interface-route6 ::/0 {
            next-hop-interface pppoe0 {
            }
        }
        route 213.75.112.0/21 {
            next-hop 10.84.174.166 {
            }
        }
    }
}
 

Reputatie 7

Waarom heb jij een static route aangemaakt voor het destination subnet 213.75.112.0/21 richting 10.84.174.166.

Die zou weleens de boosdoener kunnen zijn.

Plaats hier eens een screenshot van de routing tab op jouw EdgeRouter.

Poets wel even jouw publieke IP adres weg die vermeld staat in de regel voor de pppoe interface.

 

Reputatie 7

Dit is niet de routng tab.

 

Heb de routering 213.75.112.0/21 richting 10.84.174.166 eruit gehaald maar krijg dan geen kernel routing toegevoegd.

Reputatie 7

Is het rfc3442-classless-static-routes script dan wel geïnstalleerd op jouw EdgeRouter?

Daarnaast kan NAT rule 5002 weg, die heeft geen nut.

Had ik niet geïnstalleerd nu wel, maar wanneer ik in die file kijk zie ik het volgende niet:

 

 cat /var/run/dhclient_eth1.4_lease
Thu Jan 19 16:22:12 CET 2023
reason='RENEW'
interface='eth1.4'
new_expiry='1674143910'
new_dhcp_lease_time='2179'
medium=''
alias_ip_address=''
new_ip_address='10.84.174.166'
new_broadcast_address='10.84.175.255'
new_subnet_mask='255.255.252.0'
new_domain_name=''
new_network_number='10.84.172.0'
new_domain_name_servers=''
new_routers=''
new_static_routes=''
new_dhcp_server_identifier='10.84.172.1'
new_dhcp_message_type='5'
old_ip_address='10.84.174.166'
old_subnet_mask='255.255.252.0'
old_domain_name=''
old_domain_name_servers=''
old_routers=''
old_static_routes=''
 

de new_routers is leeg

Reputatie 7

Had ik niet geïnstalleerd nu wel,

Heb je voor de installatie van rfc3442-classless-static-routes een configuratiescript gebruikt uit het startbericht van dit topic?

Heb je de EdgeRouter na installatie ook gereboot?

Zie je nu dan wel een kernel route naar 213.75.112.0/21 op de routing tab?

 

... maar wanneer ik in die file kijk zie ik het volgende niet:

 

 cat /var/run/dhclient_eth1.4_lease
...

de new_routers is leeg

Daar is niets mis mee.

Dank je wel het werkt nu weer.

 

 

@wjb weet jij of KPN naast de IPv6 prefix delegation ook een uniek routeble IPv6 adres ondersteund op de WAN poort? Nu krijg ik daar alleen een link local en gaan de aangevraagde prefixen naar het LAN en via RA naar de clients. Werkt allemaal top en stabiel.

Ik wil mijn reverse proxy laten luisteren op het WAN adres, in pfSense. Maar voordat ik daar een uitgebreide post maak ben ik benieuwd hoe jouw WAN poort eruit ziet mbt de IPv6 adressen? Ondersteund KPN dit?

 

Only request an IPv6 prefix, do not request an IPv6 address → staat uit maar geeft niet het gewenste resultaat. 

Reputatie 7

De DHCPv6 server van KPN geeft naar mijn weten alleen een IPv6 /48 prefix en geen IPv6 WAN adres. Als je een IPv6 adres aan de WAN (pppoe) Interface wilt toekennen dan zal je dat zelf handmatig moeten doen.

Ik heb met opzet geen IPv6 adres aan de WAN (pppoe) interface toegewezen maar alleen aan de (V)LAN interfaces. (Zie screenshot in het openingsbericht van dit topic.)

Tnx ga ik even doornemen. Het is of een WAN interface met DHCPv6-PD of met een Statisch adres, net even getest. Dan stopt IPv6 voor de clients.

Reputatie 7

Tnx ga ik even doornemen. Het is of een WAN interface met DHCPv6-PD of met een Statisch adres, net even getest. Dan stopt IPv6 voor de clients.

Voor het verkrijgen van een IPv6 prefix zal je inderdaad altijd DHCPv6-PD moeten gebruiken.

Reputatie 7

Vandaag heeft Ubiguiti voor de EdgeRouters firmware v2.0.9-hotfix.6 uitgebracht die een veiligheidslek dicht. Zie dit Security Advisory Bulletin. De configuratiescripts uit het startbericht van dit topic configureren de DHCPv6-PD service echter als “slaac” en niet als “dhcpv6-stateless” of “dhcpv6-stateful”.

Er is dus geen noodzaak om deze hotfix met spoed te installeren.

Reputatie 1

@Bas Gabriels, Jij hebt toch een EdgeRouter X?

Zet de LAN interface dan op switch0 i.p.v. eth1.

Probeer ook protocol "Both" te vermijden. Kies eigenlijk altijd voor TCP of UDP.

vraagje… waarom precies?

Reputatie 7

@Bas Gabriels, Jij hebt toch een EdgeRouter X?

Zet de LAN interface dan op switch0 i.p.v. eth1.

Probeer ook protocol "Both" te vermijden. Kies eigenlijk altijd voor TCP of UDP.

vraagje… waarom precies?

Omdat switch0 de logische interface is voor het hele LAN (alle poorten).

Omdat je de gaten in jouw firewall altijd zou klein mogelijk moet laten zijn.

Reputatie 1

@Bas Gabriels, Jij hebt toch een EdgeRouter X?

Zet de LAN interface dan op switch0 i.p.v. eth1.

Probeer ook protocol "Both" te vermijden. Kies eigenlijk altijd voor TCP of UDP.

vraagje… waarom precies?

Omdat switch0 de logische interface is voor het hele LAN (alle poorten).

Omdat je de gaten in jouw firewall altijd zou klein mogelijk moet laten zijn.

 

bedoelde meer de regel Probeer ook protocol "Both" te vermijden. Kies eigenlijk altijd voor TCP of UDP… is gewoon ter verduidelijking?

Reputatie 7

@Bas Gabriels, Jij hebt toch een EdgeRouter X?

Zet de LAN interface dan op switch0 i.p.v. eth1.

Probeer ook protocol "Both" te vermijden. Kies eigenlijk altijd voor TCP of UDP.

vraagje… waarom precies?

Omdat switch0 de logische interface is voor het hele LAN (alle poorten).

Omdat je de gaten in jouw firewall altijd zou klein mogelijk moet laten zijn.

 

bedoelde meer de regel Probeer ook protocol "Both" te vermijden. Kies eigenlijk altijd voor TCP of UDP… is gewoon ter verduidelijking?

Dat zeg ik, omdat je de gaten in jouw firewall altijd zo klein mogelijk moet houden.

Dus TCP i.p.v. Both als je voor die poort geen UDP nodig hebt en UDP i.p.v. Both als je voor die poort geen TCP nodig hebt.

Door een defecte cloudkey heb ik helaas mijn unifi-switch moeten resetten. Nu werkt mijn IPTV niet meer (de bekende NMC-400 melding). Aan mijn edgerouter 3 is niks veranderd. De netwerken LAN en IPTV staan wel nog in mijn config van unifi. Iemand die mij kan helpen om te troubleshooten wat er mis gaat? 

 

Waar het volgens mij op dit moment blijft hangen : De VIP5202 krijgt geen ip-adress meer in het netwerk van IPTV….

 

Hulp zou fijn zijn :-)

Reputatie 7

Heb je de TV ontvanger(s) op een apart vlan staan?

Staat IGMP snooping aan op de switch?

Reageer