Sticky

Gebruik een eigen router i.p.v. de Experia Box

  • 8 september 2018
  • 3525 reacties
  • 252705 keer bekeken


Toon eerste bericht

3525 reacties

Reputatie 7

@wjbik ben hier nog regelmatig in de hoop te lezen dat mijn Netgear switchje ertussenuit kan i.v.m. vaste telefonie. Al vraag ik me nu ook meteen af hoeveel ik nog eigenlijk vast telefoneer vandaag de dag...

Dat zal niet lang meer op zich laten wachten "mind my words". :sunglasses:

Geweldig bedankt voor de scripts!

Echter, ik krijg het niet aan de praat op mijn Edgerouter 6P.

Heb "EdgeRouter Lite 3 zonder telefonie" gedownload, en precies gedaan wat in de readme staat. Verder alles 100% origineel gelaten zoals in de zip. Geen switches erachter, niets..

Niks werkt. Geen internet en geen iptv. 

Heb ook geprobeerd met mijn mac adres van de experiabox in de config.boot, maar nog niks! Ben er al uren mee bezig geweest. 

 

 

Reputatie 7

Ik denk dat je voor de configuratie van de EdgeRouter 6P beter de scripts voor de EdgeRouter X kunt gebruiken immers daarin wordt de interne switch ook geconfigureerd.

Ik weet overigens ook niet of er nog stukjes in de configuratiescripts ontbreken die essentieel zijn voor de 6P. Ik verwacht het eerlijk gezegd niet maar het zou wel zo kunnen zijn.

Welke versie van de firmware staat op die 6P?

Bedankt voor je hulp! 

De 6p heeft geen switch! WAN eth0 en LAN eth1 is prima! 

Een vriend heeft hem met jouw Lite 3 script aan de praat gekregen. 

Ik heb eerst de config van mijn 6p gebackupt en vergeleken, maar staat niks spannends in wat zou missen. 

De 6p draait op de laatste firmware van 5 december 2019. Versie 2.0.8

Reputatie 7

De 6p heeft geen switch! WAN eth0 en LAN eth1 is prima! 

Maar de 6P heeft toch een ingebouwde switch met 5 poorten waarvan eth0 als WAN poort gebruikt wordt en eth1-4 als 4 poorts LAN switch geconfigureerd kunnen worden.

De 6P heeft ook nog een SFP poort die eventueel gebruikt kan worden als WAN aansluiting door deze rechtstreeks op de glasvezel aan te sluiten. In dat geval zou je zelfs een 5-poort switch kunnen configureren.

Reputatie 2

The ER6P does not have a switch. All ports are individual routed ports.  So no same subnet without using software bridge.

@wjb 

M.i. kun je dan toch beter het Lite script gebruiken i.p.v. erX script.

De erX heeft volgens mij een “chip”-switch.

Reputatie 7
Badge +14

De 6p heeft geen switch! WAN eth0 en LAN eth1 is prima! 

Dus hij werkt eigenlijk prima, maar dan alleen op eth1? Heb je daarop internet en tv?

Als dat zo is, dan moet je volgens mij een bridge configureren, en daar alle 4 de poort aan hangen. En waar je nu in je huidige configuratie eth0 ingesteld hebt daar moet je de bridge instellen.

Reputatie 7

De 6p heeft geen switch! WAN eth0 en LAN eth1 is prima! 

Dus hij werkt eigenlijk prima, maar dan alleen op eth1? Heb je daarop internet en tv?

Als dat zo is, dan moet je volgens mij een bridge configureren, en daar alle 4 de poort aan hangen. En waar je nu in je huidige configuratie eth0 ingesteld hebt daar moet je de bridge instellen.

Nee Nick, geen bridges willen gaan definiëren, zo werkte bridged IPTV maar routed IPTV al jaren niet.

Sinds kort wordt bridged IPTV zelfs helemaal niet meer ondersteund door KPN. Abonnees die nog een eigen router gebruiken met bridged IPTV krijgen nu de melding hun modem te wisselen als op de TV ontvanger naar het menu gaan.

 

De scripts voor de EdgeRouter X bevatten de configuratie voor de ingebouwde switch, het enige is dat eth4 aan die configuratie moet worden toegevoegd.

Reputatie 1

Ik heb begrepen dat de Fritz!Box niet zulke goede Wifi prestaties levert 

Dan zet je de wifi op dat ding uit en koop je losse accespoints. Een edgerouter heeft ook geen wifi.

@ApolloDe ingebouwde wifi functionaliteit van iedere FRITZ!Box zal vast niet in iedere mogelijke denkbare situatie de beste prestaties leveren t.o.v. andere wifi-producten, echter wat wordt er hier door je als “niet zulke goede” beschouwd? Ben ik wel benieuwd naar.

Mijn ervaring:

Ik gebruik in mijn woonhuis (twee-onder-een-kapwoning, noem ik zodat je iets over de grootte in kan schatten) een FRITZ!Box 7581 in de meterkast bij de voordeur en moet zeggen dat ik op veel plekken waar ik me regelmatig bevind gewoon prima bereik heb. Ik heb zelfs op mijn 500/500 mbps glasvezellijn met mijn telefoon (Pixel 3a) rond de 400/400 mbps gemeten op bepaalde plekken dicht in de buurt van de FRITZ!Box. Ik overweeg overigens wel een tweede extra puntje als “mesh”uitbreiding van Fritz!Box hun mesh-techniek onder deze noemer op een verdieping hoger, zodat ik over het algemeen net iets betere dekking heb op de plekken waar de meeste mensen zich het vaakst bevinden. Dat is immers niet in het gangetje direct naast de meterkast.

En dat is ook meteen het punt dat ik wil maken. (extra) wireless-accesspoints, zet men doorgaans niet op precies dezelfde plek als waar de router met wifi-functionaliteit staat toch? In mijn ogen geven dergelijke wireless-accesspoints daarom voor je gevoel al snel een betere dekking of snelheid. En veel van de "mesh” wifi-fabrikanten ontwerpen die puntjes tegenwoordig zo dat ze prima ergens zonder lelijke antennes in een huiskamer of ergens aan de muur/plafond te hangen zijn, zonder dat iemand daar per se over valt wat uiterlijk betreft. Je stopt ze daardoor minder snel uit het zicht is mijn ervaring. Daarom vind ik een vergelijking als “vervanging” van het wifi gedeelte van je router in veel gevallen niet helemaal eerlijk.

Dat gezegd hebbende, denk ik dat zo'n FRITZ!Box echt een hele dikke prima oplossing is voor iemand die net even minder thuis is in de configuratie-mogelijkheden van een Edgerouter, of daar simpelweg geen tijd/zin in heeft m.b.t. onderhoud, updates, etc. Mijn FRITZ!Box, draait stabiel en uit ervaring weet ik dat hun mesh-producten (als uitbreiding van het bestaande wifi-netwerk om eenzelfde wifi-netwerknaam in heel je huis te houden) ook goed werken. Ik wordt overigens niet door FRITZ!Box gesponsord.

@wjbik ben hier nog regelmatig in de hoop te lezen dat mijn Netgear switchje ertussenuit kan i.v.m. vaste telefonie. Al vraag ik me nu ook meteen af hoeveel ik nog eigenlijk vast telefoneer vandaag de dag...

@r132npk546e@Nick83 Bedankt voor jullie reacties en ervaringen. Ik woon samen met mijn mede inwonenden in een nieuwbouw huis (Lees vrijstaand). Ik heb al geopperd om per verdieping een extra UTP cabel te laten leggen voor accesspoints alleen bleek dit niet nodig te zijn volgens de installateur, omdat er al genoeg zijn. Nu heb ik hem verteld dat ik een ‘IT’er’ ben en dat ik wel weet wat goed is en wat niet (Heel zelfverzekerd, maar weet niet hoe ik het anders moet verwoorden).

 

Vandaar ook de conclusie dat accesspoints in ons geval geen optie is omdat we simpel weg niet op de goede locaties UTP kabels hebben liggen (Installateur ook een negatieve review gegeven, voor het doordrukken van zijn advies). Vandaar de oplossing om het met een router en switch op te lossen in de meterkast. Met de ExperiaBox hebben wij ook genoeg bereik alleen we willen toch iets beters qua verbinding maar ook qua hardware. Dus zat ik te kijken naar de nieuwe AX routers, aangezien die volgens reviews wel een goed bereik hebben.

Overigens haal ik alle informatie nu uit reviews over de AX-routers en de Fr!tzBoxen.

Mesh Routers zou een optie kunnen wezen, maar wij willen gewoon af van de ExperiaBox aangezien die niet echt een optie vrijheid geeft en soms er weleens uitvalt.

Daarom wil ik graag een AX-Router in de meterkast, samen met onze switch en wellicht in de toekomst zo’n VoiP ATA voor de telefoon, alhoewel wij ons ook afvragen in hoeveel wij die gebruiken.

De 6P heeft geen interne switch. De 6P is overigens precies hetzelfde als de Edgerouter 4.

Voor de duidelijkheid, het werkt nu niet! Ook niet op eth1.. 

Om te testen heb ik mijn laptop op eth0 geprobeerd en vervolgens iptv kastje op eth0.. Nada..

Ik wil het eerst aan de gang hebben met dat basis script, om te zien of het werkt. Van daaruit ga ik de rest van mijn netwerk weer in orde maken 

Alles werkte overigens prima in bridged modes, maar ik moet dat nu anders gaan maken omdat kpn waarschuwingen op mijn iptv laat zien, dat ik de experiabox moet vervangen. 

Reputatie 7
Badge +14

De 6p heeft geen switch! WAN eth0 en LAN eth1 is prima! 

Dus hij werkt eigenlijk prima, maar dan alleen op eth1? Heb je daarop internet en tv?

Als dat zo is, dan moet je volgens mij een bridge configureren, en daar alle 4 de poort aan hangen. En waar je nu in je huidige configuratie eth0 ingesteld hebt daar moet je de bridge instellen.

Nee Nick, geen bridges willen gaan definiëren, zo werkte bridged IPTV maar routed IPTV al jaren niet.

Sinds kort wordt bridged IPTV zelfs helemaal niet meer ondersteund door KPN. Abonnees die nog een eigen router gebruiken met bridged IPTV krijgen nu de melding hun modem te wisselen als op de TV ontvanger naar het menu gaan.

 

De scripts voor de EdgeRouter X bevatten de configuratie voor de ingebouwde switch, het enige is dat eth4 aan die configuratie moet worden toegevoegd.

Met bridge bedoel ik een netwerk bridge. Dat heeft niks met bridged tv te maken.

Reputatie 7
Badge +14

Ik heb al geopperd om per verdieping een extra UTP cabel te laten leggen voor accesspoints alleen bleek dit niet nodig te zijn volgens de installateur, omdat er al genoeg zijn.

Er liggen er dus al wel? Is prima toch? Je hebt er maar 1 nodig...

Reputatie 7

Om te testen heb ik mijn laptop op eth0 geprobeerd en vervolgens iptv kastje op eth0.. Nada..

Na configuratie moet de NTU op eth0 aangesloten worden en de computer, TV ontvanger, etc. op eth1. Ook moet de EdgeRouter nog één keer extra gereboot worden om de TV ontvangers 100% te laten werken.

Als je een computer op eth1 aangesloten hebt, welk IP adres krijgt die computer dan?

Reputatie 1

Ik heb al geopperd om per verdieping een extra UTP cabel te laten leggen voor accesspoints alleen bleek dit niet nodig te zijn volgens de installateur, omdat er al genoeg zijn.

Er liggen er dus al wel? Is prima toch? Je hebt er maar 1 nodig...

 

Nee de UTP kabels liggen niet op de goede locatie. Er liggen wel UTP kabels maar die liggen voor andere devices… Zoals ook omschreven in mijn uitleg aan @r132npk546e vandaar ook geen mogelijkheid. Want AccessPoints wil je juist centraal gelegen hebben en niet in een kamer aan de noordzijde van je huis, dan want heeft het alsnog vrij weinig nut. Want dan zal de zuidkant van je huis niet dezelfde Wi-Fi ervaring hebben.

Reputatie 7
Badge +14

Nee de UTP kabels liggen niet op de goede locatie. Er liggen wel UTP kabels maar die liggen voor andere devices… Zoals ook omschreven in mijn uitleg aan @r132npk546e

Ik heb 3 pagina's terug gezocht, en die uitleg niet gevonden. Als er kabels liggen, dan zet je er toch een switch tussen, en ga vandaar uit naar een accespoint. Op elke verdieping een accespoint zorgt altijd voor beter resultaat dan in de meterkast de router vervangen voor een zogenaamd betere. Verwacht daar niet teveel van, dat is meest marketingpraat.

Ik ervaar een probleem bij het wisselen van tv-zenders. Na de achtste wisseling binnen één minuut gaat het beeld haperen. In het ergste geval loopt alles vast en moet ik de EdgeRouter Lite 3 herstarten.

Uit mijn analyse blijkt het volgende. In het EdgeMAX dashboard zie ik dat elke zender zo’n 7 Mbps aan dataverkeer heeft. Bij iedere zenderwisseling komt er 7 Mbps bij. Drie minuten na de wisseling valt 7 Mbps dataverkeer weg.

In de Multicast Forwarding Cache (MFC) zie ik de actieve en reeds verlaten streams allemaal staan. In het voorbeeld hieronder staan er 5 (Origin 217.166.226.x).

#show ip multicast mfc
Group Origin In Out Pkts Bytes Wrong
224.3.2.6 213.75.167.58 eth0.4 eth1.44 991 353.96KB 0
224.0.252.135 217.166.226.135 eth0.4 eth1.44 2 2.65KB 0
224.0.252.137 217.166.226.137 eth0.4 eth1.44 2 2.65KB 0
224.0.252.136 217.166.226.136 eth0.4 eth1.44 3 3.97KB 0
224.0.252.128 217.166.226.128 eth0.4 eth1.44 3 3.97KB 0
224.0.252.127 217.166.226.127 eth0.4 eth1.44 53 70.18KB 0

 

Ik concludeer heel voorzichtig dat het igmp-proxy quickleave mechanisme blijkbaar op 3 minuten staat ingesteld. Hoe dit zo is ingesteld weet ik niet.

Mijn vraag is: Is drie minuten normaal of zou de stream sneller moeten verdwijnen?

Om te testen heb ik mijn laptop op eth0 geprobeerd en vervolgens iptv kastje op eth0.. Nada..

Na configuratie moet de NTU op eth0 aangesloten worden en de computer, TV ontvanger, etc. op eth1. Ook moet de EdgeRouter nog één keer extra gereboot worden om de TV ontvangers 100% te laten werken.

Als je een computer op eth1 aangesloten hebt, welk IP adres krijgt die computer dan?

 

Het werkt eindelijk.. 

Factory reset gedaan en PRECIES hetzelfde script erin en nu doet hij het wel. Erg raar. Misschien in je readme.txt zetten. 

En je kunt in je eerste post erbij zetten dat het Lite 3 script ook werkt voor de ER-4 en de ER-6P.. Confirmed! 

Reputatie 7

Uit mijn analyse blijkt het volgende. In het EdgeMAX dashboard zie ik dat elke zender zo’n 7 Mbps aan dataverkeer heeft. Bij iedere zenderwisseling komt er 7 Mbps bij. Drie minuten na de wisseling valt 7 Mbps dataverkeer weg.

Vreemd, na het wisselen van zender behoort de oude stream per direct stopgezet te worden.

Weet je zeker dat igmp-proxy quickleave niet gedisabled is?

 

Uit mijn analyse blijkt het volgende. In het EdgeMAX dashboard zie ik dat elke zender zo’n 7 Mbps aan dataverkeer heeft. Bij iedere zenderwisseling komt er 7 Mbps bij. Drie minuten na de wisseling valt 7 Mbps dataverkeer weg.

Vreemd, na het wisselen van zender behoort de oude stream per direct stopgezet te worden.

Weet je zeker dat igmp-proxy quickleave niet gedisabled is?

 

Goed om te horen dat de oude stream per direct stopgezet moet worden. Iets is er dus nog niet helemaal in orde.

Ik weet zeker dat igmp-proxy quickleave niet gedisabled is. Dat heb ik gecontroleerd. Disabling heeft verder geen effect zoals ik al heb gemerkt.

Zodra ik een zender wissel, stuurt de settop box netjes een bericht. Zie hieronder, maar dat heeft vooralsnog geen effect.

# show interfaces ethernet eth1 vif 44 capture | grep igmp
17:11:31.558565 IP 10.0.44.44 > 224.0.0.2: igmp leave 224.0.252.127
17:11:32.213873 IP 10.0.44.44 > 224.0.252.128: igmp v2 report 224.0.252.128
17:11:35.569363 IP 10.0.44.44 > 224.0.252.128: igmp v2 report 224.0.252.128
17:11:36.219974 IP 10.0.44.44 > 224.0.252.128: igmp v2 report 224.0.252.128
17:11:37.143057 IP 10.0.44.44 > 224.0.252.128: igmp v2 report 224.0.252.128
17:12:01.166718 IP 10.0.44.1 > 224.0.0.1: igmp query v2
17:12:02.670307 IP 10.0.44.43 > 224.3.2.6: igmp v2 report 224.3.2.6
17:12:05.445267 IP 10.0.44.44 > 239.255.255.250: igmp v2 report 239.255.255.250
17:12:08.776585 IP 10.0.44.43 > 239.255.255.250: igmp v2 report 239.255.255.250
17:12:09.193019 IP 10.0.44.44 > 224.0.252.128: igmp v2 report 224.0.252.128
17:12:10.206508 IP 10.0.44.44 > 224.3.2.6: igmp v2 report 224.3.2.6

Zoals je ziet heb ik een VLAN (44) gemaakt voor de settop boxen. Ik ga mijn config.boot nog eens nauwkeurig vergelijken met dat van jou.

Reputatie 7
Badge +14

En je kunt in je eerste post erbij zetten dat het Lite 3 script ook werkt voor de ER-4 en de ER-6P.. Confirmed! 

Kijk het eerst maar eens een paar weekjes aan zou ik zeggen...

Uit mijn analyse blijkt het volgende. In het EdgeMAX dashboard zie ik dat elke zender zo’n 7 Mbps aan dataverkeer heeft. Bij iedere zenderwisseling komt er 7 Mbps bij. Drie minuten na de wisseling valt 7 Mbps dataverkeer weg.

Vreemd, na het wisselen van zender behoort de oude stream per direct stopgezet te worden.

Weet je zeker dat igmp-proxy quickleave niet gedisabled is?

 

Goed om te horen dat de oude stream per direct stopgezet moet worden. Iets is er dus nog niet helemaal in orde.

Ik weet zeker dat igmp-proxy quickleave niet gedisabled is. Dat heb ik gecontroleerd. Disabling heeft verder geen effect zoals ik al heb gemerkt.

Zodra ik een zender wissel, stuurt de settop box netjes een bericht. Zie hieronder, maar dat heeft vooralsnog geen effect.

 # show interfaces ethernet eth1 vif 44 capture | grep igmp
17:11:31.558565 IP 10.0.44.44 > 224.0.0.2: igmp leave 224.0.252.127
17:11:32.213873 IP 10.0.44.44 > 224.0.252.128: igmp v2 report 224.0.252.128
17:11:35.569363 IP 10.0.44.44 > 224.0.252.128: igmp v2 report 224.0.252.128
17:11:36.219974 IP 10.0.44.44 > 224.0.252.128: igmp v2 report 224.0.252.128
17:11:37.143057 IP 10.0.44.44 > 224.0.252.128: igmp v2 report 224.0.252.128
17:12:01.166718 IP 10.0.44.1 > 224.0.0.1: igmp query v2
17:12:02.670307 IP 10.0.44.43 > 224.3.2.6: igmp v2 report 224.3.2.6
17:12:05.445267 IP 10.0.44.44 > 239.255.255.250: igmp v2 report 239.255.255.250
17:12:08.776585 IP 10.0.44.43 > 239.255.255.250: igmp v2 report 239.255.255.250
17:12:09.193019 IP 10.0.44.44 > 224.0.252.128: igmp v2 report 224.0.252.128
17:12:10.206508 IP 10.0.44.44 > 224.3.2.6: igmp v2 report 224.3.2.6

Zoals je ziet heb ik een VLAN (44) gemaakt voor de settop boxen. Ik ga mijn config.boot nog eens nauwkeurig vergelijken met dat van jou.

Ik heb de oorzaak gevonden. Ik had op het VLAN een firewall ingesteld die alleen DNS en DHCP toeliet. Identiek aan het VLAN voor IoT-stuff. Nu ik deze firewall heb verwijderd worden oude streams meteen gestopt. Het kwartje viel toen ik de ‘leave’ berichten van de settop boxen zag. Ik dacht, die komen door de firewall nooit op de plaats van bestemming.

Goedenavond allemaal,

Allereerst wil ik jullie bedanken voor de waardevolle informatie om een eigen modem te kunnen gebruiken. Een jaar geleden had ik besloten om de Experiabox te vervangen voor een DrayTek Vigor 2782 (VDSL verbinding). Dit heeft tot twee weken geleden perfect gedraaid…

Hopelijk kunnen jullie mij verder helpen met het volgende probleem: om de twee/drie uur valt de internetverbinding compleet weg en maakt vervolgens weer opnieuw verbinding met de provider. De verbinding lokaal met de DrayTek blijft werken, dus de DrayTek loopt niet vast etc. In het dashboard van de DrayTek zie ik dat de VDSL-verbinding opnieuw is opgestart, zie onderstaande afbeelding. 

Ik heb zelf het idee dat het probleem is ontstaan doordat twee weken geleden DNSSEC (zie bron) is ingeschakeld door Telfort. Sins die tijd ervaar ik namelijk het probleem. In de firewall settings van de Draytek heb ik een regel gemaakt dat alleen de DNS servers van 1.1.1.1 en 1.0.0.1 worden toegestaan (zie onderstaande afbeelding). Wellicht dat dit voor een probleem zorgt?

Ik ben benieuwd naar jullie reactie.

Alvast bedankt.

Bron: https://forum.telfort.nl/nieuws-251/extra-veilig-internet-met-dnssec-85090

Reputatie 7

Ik zie zo één twee drie geen clausaal verband tussen het introduceren van DNSSEC en het wegvallen van de Internet verbinding.

Is jouw lijn al een keer doorgemeten door Telfort?

Ik zie zo één twee drie geen clausaal verband tussen het introduceren van DNSSEC en het wegvallen van de Internet verbinding.

Is jouw lijn al een keer doorgemeten door Telfort?


Bedankt voor je reactie. Ik zie er ook geen verband tussen maar vind het vreemd dat ik vanaf die dag problemen ervaar. Mijn lijn is nog niet doorgemeten. Moet ik hiervoor bellen?

Reputatie 7

Mijn lijn is nog niet doorgemeten. Moet ik hiervoor bellen?

Daarvoor zal je bij de klantenservice van Telfort moeten zijn.

Als het goed is kunnen zij een zo een overzicht van de storingen op jouw lijn opvragen.

Reageer