Beantwoord

Niet kunnen browsen na opzetten VPN-verbinding

  • 3 april 2018
  • 24 reacties
  • 3428 keer bekeken

Goedendag,

Sinds een week of twee heb ik een glasvezel aansluiting via KPN in mijn nieuwe woning. Helaas heb ik nu zodra ik verbinding maak met de VPN (Cisco AnyConnect) voor werk geen lokaal toegang meer tot internet (Browsen/Spotify/etc.).

Als ik op een andere plek verbinding of via mijn telefoon verbinding maak met de VPN heb ik dit probleem niet, ook bij mijn collega's speelt dit probleem niet (Ziggo/UPC/Mobiele hotspots).

Ik heb een particulier abonnement en zoals aangegeven is alles zeer recent geïnstalleerd.

Ik zie dit probleem vaker langskomen op fora, maar heb nog nergens een definitief antwoord kunnen vinden:
https://forum.kpn.com/internet-9/geen-internet-na-opzetten-cisco-vpn-334483
https://forum.kpn.com/thuisnetwerk-72/geen-enkele-vpn-verbinding-meer-mogelijk-445549
https://forum.kpn.com/thuisnetwerk-72/probleem-gewoon-internet-tijdens-vpn-verbinding-433225

Ik ben slechts een "gebruiker" dus graag uitgebreide tekst en uitleg ;-)

Hopelijk kunnen jullie mij helpen!
icon

Beste antwoord door RobinFlikkema 4 april 2018, 09:55

De WiFi adapter. Betekent wel dat je PC op dat moment geen IPv6 toegang (meer) heeft.
Je kan gewoon de eigenschappen v/d adapter openen en dan het vinkje weg halen bij IPv6.

Robin
Bekijk origineel

24 reacties

Reputatie 7
Badge +30
Kan je deze site bijvoorbeeld wel openen: http://173.194.78.94/
@RobinFlikkema

Ik heb het direct geprobeerd, maar ik kan de link niet openen na het opzetten van een VPN verbinding.
Reputatie 7
Badge +30
Welke error krijg je dan? (liefst via Chrome; of in iedergeval een browser die meer zegt dat "kan pagina niet laden")
Deze:
Reputatie 7
Badge +30
Precies. Probleem met DNS dus, de site werkt. maar redirect je naar google.nl en die kan niet gevonden worden.

Als je commandprompt opent (er van uitgaande dat dit Windows is) en je doet "nslookup google.nl", wat krijg je dan te zien?
Het volgende:
Reputatie 7
Badge +30
@wjb, ben jij bekend met AnyConnect?

Want nu wordt het IPv6 adres van de V10 (vermoedelijk) gebruikt, en die luistert niet naar DNS requests. Is dit dan het probleem?

Robin
Reputatie 7
Ik heb enige tijd Cisco AnyConnect gebruikt echter al enige tijd niet meer.
Als via het IPv6 adres van de Experia Box geen DNS lookups gedaan kunnen worden, dan zou dat prima de oorzaak kunnen zijn.
Reputatie 7
Badge +30
Hoi,

Wat krijg je te zien als je in commandprompt "ipconfig /all" doet, en dan naar Ethernet of WiFi scrollt en daar de DNS servers bekijkt? Welke servers staan daar genoemd?
Welke Experiabox heb je?

Robin
Zie de twee afbeeldingen:
A- Zonder VPN verbinding
B- Met VPN verbinding.

Ik heb een Experiabox V10
Reputatie 7
Badge +30
Die VPN gebruik je om dingen op je werk te openen neem ik aan? Typ je daar dan IP-adressen in of hostnames zoals forum.kpn.com en google.nl?

Die VPN Tunnel heeft namelijk geen geldige DNS, en afhankelijk van hoe het precies werkt zal die gebruikt worden ipv WiFi

Je zegt dat het op andere locaties wel werkt, is dat met dezelfde computer of een andere?
Via Cisco maak ik verbinding met de VPN. Via deze VPN verbinding kan ik vervolgens een remote desktop openen (een Windows Server 2012 R2). Op deze remote desktop gebruik ik verder geen browsers. Lokaal gebruik ik wel browsers en andere internetdiensten die niet meer werken zodra ik de VPN verbinding opstart.

De afgelopen week heb ik wat aan de netwerk instellingen zitten prutsen, met de suggesties die ik her en der heb kunnen vinden. Het lijkt er echter op dat alle instellingen weer "terugspringen" als ik opnieuw verbinding maak met de VPN.

Dit alles doe ik op dezelfde laptop op verschillende plekken.
Reputatie 7
Badge +30
Maar die Windows Server benader je met het IP? En niet met zijn domeinnaam?
Ik neem aan via IP. Maakt dit uit?
Nog voordat ik in log op de Server valt mijn lokale internet verbinding weg doordat ik verbinding met de VPN maak.
Reputatie 7
Badge +30
Ja, want als je die met IP benadert dan doet waarschijnlijk gewoon heel DNS via die tunnel het niet. Doe je het via een domeinnaam werkt DNS van je werk wel, een soort van.

Je kan proberen statisch een DNS server in te stellen. Maar het kan ook zomaar aan de VPN tunnel instellingen liggen (die DNS override), maar dat verklaart niet waarom het op andere locaties wel werkt.

Je kan proberen statisch een DNS server in te stellen. Maar het kan ook zomaar aan de VPN tunnel instellingen liggen (die DNS override), maar dat verklaart niet waarom het op andere locaties wel werkt.


Dus wat moet ik doen?

Ik kan een statisch DNS instellen op zowel mijn Wifi als VPN verbinding...
Reputatie 7
Badge +30
Ik zou zeggen dat je die in de WiFi adapter moet instellen, maar dat is afhankelijk van hoe de tunnel precies functioneert en daar kan ik vrij weinig over zeggen.
Maar aan de andere kant, WiFi heeft ook al een goede DNS server (behalve de eerste).
Deze oplossing (met statische DNS 8.8.8.8) maakt geen verschil.

Kun je vertellen hoe ik kan achterhalen hoe de tunnels functioneren?
@RobinFlikkema

Hierbij nog een afbeelding van als ik verbinding maak via mijn telefoon. Misschien zie je hier nog belangrijke verschillen.
Reputatie 7
Badge +30
Nou, het engiste verschil is dat alle andere aansluitingen (waar je zegt dat het wel werkt) geen IPv6 hebben.

Je kan eventueel IPv6 in de netwerkadapter uitzetten en kijken of het dan werkt. Als dat zo is, dan doet de tunnel vermoedelijk iets verkeerd met IPv6

Robin

Je kan eventueel IPv6 in de netwerkadapter uitzetten en kijken of het dan werkt. Als dat zo is, dan doet de tunnel vermoedelijk iets verkeerd met IPv6
Robin


En waar doe ik dit? In de wifi of VPN netwerkadapter?

Ik heb ook als ik inlog op het modem de mogelijkheid gezien op de IPv6 uit te zetten
Reputatie 7
Badge +30
De WiFi adapter. Betekent wel dat je PC op dat moment geen IPv6 toegang (meer) heeft.
Je kan gewoon de eigenschappen v/d adapter openen en dan het vinkje weg halen bij IPv6.

Robin
Nu kan ik wel browsen tijdens een VPN sessie!

Wat zijn de mogelijke gevolgen van het uitvinken van de IPv6 optie in de netwerkadapter?
Reputatie 7
Badge +30
Cool. Nu is t alleen even zien waarom dit gebeurt.

IPv6 op zichzelf uitzetten is niet direct een probleem. Maar je zal minder dan 1% van de websites niet kunnen bereiken hierdoor. En mogelijk wordt dat meer.

Je zou hem eerst even uit kunnen laten, maar blijkbaar is er iets waardoor het mis gaat. Dit kan zijn omdat de V10 niet reageert op z'n IPv6 adres. Of omdat de tunnel iets met IPv6 doet wat onjuist is.

@ErikFocus, heb jij dit ook ervaren? Dat de V10 niet op DNS queries reageert richting z'n Link-Local address? Terwijl, vermoedelijk, hij die wel meegeeft als DNS server? Zo ja, is dit de bedoeling en/of kan dit aangepast worden?

Reageer