Vraag

port forwarding werkt niet meer.

  • 12 maart 2020
  • 59 reacties
  • 1001 keer bekeken

Badge

Expediabox v10. Plotseling kan ik mijn camera niet meer buiten het netwerk zien en geen alarm mail meer verzenden. Poort checker geeft aan dat de poorten die ik heb ingesteld niet open staan. Alles opnieuw geprogrammeerd. Werkt niet. Wie weet de oplossing??


59 reacties

Reputatie 7
Badge +9

Je zal alle relevante info moeten posten, al was het maar voor jezelf. Dus bedenk welke zaken nodig zijn, te beginnen met de camera zelf. Hoe ging dat benaderen van externe netwerken eerder toen het wel werkte? Heeft die camera b.v. nieuwe firmware gekregen, ander IP adress enz.

Badge

Geen update firmware. ik heb de camera opnieuw gereset en dezelfde instellingen geprogrammeerd. Zelfde poorten en ip adres. 

De modem opnieuw opgestart, geeft ook geen verbetering.

De camera betreft er een van Hikvision. Normaal gesproken kun je die via de app IVMS bereiken buiten het netwerk. Dat werkt ook niet meer. Email versturen vanaf de camera werkt niet meer. 

In de configuratie gekeken van de modem.

De poorten 80 554 en 8000 zouden open moeten staan maar bij een poort checker zegt hij dat ze dicht staan.

Dus ik denk dat de modem van KPN Experia V10 een update heeft gekregen waardoor de zaak niet meer werkt.

Mail versturen vanaf mijn computer gaat wel. Internet op de computer werkt gewoon.

Reputatie 7
Badge +9

Het IP adres moet de camera van de EBv10 krijgen. Daartoe ook een DHCP binding in de v10 aanmaken. Poort 554 is doorgaans UDP verkeer, dat checken heeft met een poortchecker niet zo veel zin. Ik ken de app IVMS niet, kan best zijn dat het geheel ook zonder portforwards kan werken. Misschien maar eens een screenshot van camara en v10 instellingen  aangaande die portforwardposten.

Badge

DHCP uitgeschakeld op de camera. Anders veranderd het ip adres de hele tijd. Vast ip gegeven, zoals voorheen. 

Ik heb nog een zelfde camera ergens anders geïnstalleerd die prima werkt in de app en ook via ipadres is te bereiken.(Ziggo) , maar de camera bij mij thuis (kpn) wil dat niet meer doen hoe vaak ik de zaak ook gereset heb en opnieuw geprogrammeerd.

Reputatie 7
Badge +9

DHCP uitgeschakeld op de camera. Anders veranderd het ip adres de hele tijd. Vast ip gegeven, zoals voorheen.

Daar zit hem hoogstwaarschijnlijk dus het probleem, genoeg voorbeelden op dit forum te vinden. De kans is groot dat de ExperiaBox niet onder alle omstandigheden met zekerheid weet wat het adres van de camera is. KPN kan de firmware in de ExperiaBox geupdate hebben, dus wat eerder wel werkte, hoeft nu niet meer te werken.

Zoals al gezegd, de beste methode is om het via een DHCP binding te regelen, maar als je dat niet wilt of geen zin in hebt dan houdt het wat mij betreft op.

Dat het via Ziggo wel werkt doet er verder niet echt toe, is een andere router, andere firmware, enz.

Badge

Opnieuw ingesteld. Nu met DHCP. Maakt geen verschil. Kan hem thuis op mijn netwerk wel zien maar niet er buiten.

Hoi @Pa driver . Welkom op het forum.

Erg vervelend dat dit zo maar gebeurt. De v10 heeft wel een update gehad maar die zou dit soort zaken ongemoeid moeten laten. De update is ook al weer een tijdje geleden en ik begrijp dat dit recentelijk mis ging?

Soms is het (gek genoeg) raadzaam om het modem even een volledige reset te geven en daarna opnieuw de forwardings er in te zetten. Ik bedoel dus een factory default. Had je die al geprobeerd?

 

Reputatie 7
Badge +9

Hoe zie die DHCP binding eruit, graag screenshot ?

Reputatie 7

Heb je screenshots van

  • De DHCP binding voor de camera
  • De port-forwarding application
  • De toewijzing van de port-forwarding application aan het IP adres van de camera

Kan je de camera op jouw thuisnetwerk wel op zijn eigen LAN IP adres benaderen?

Badge

De screenshots. Is dit wat je bedoelt?

 

Reputatie 7
Badge +9

dit is onleesbaar klein

Reputatie 7
Badge +11

Tsja, dit zie je steeds vaker, zijn we eindelijk van het fax overtypen af, krijgen we dit  :-)

Kijk hier even naar :

https://nl.wikipedia.org/wiki/Schermafbeelding

Niet wetende om welk besturingssysteem het gaat, maar druk even op die ene toets die nog helemaal nieuw is, rechts van F12.

In linux heb je dan ‘m dan in een keer, met shift+F12 kun je een venster trekken.

Reputatie 7

Met Windows 10 kan je de Snip & Sketch tool gebruiken.

 

Badge

 

 

Zo beter leesbaar. Sorry voor het ongemak.

Badge

Ik werk met windows10

Reputatie 7

Dus je kan de camera wel op 192.168.2.7 benaderen maar niet op jouw publieke iP adres?

Zet IPv6 eens uit op die camera, lukt het dan wel?

 

Badge

UPnP staat aan. Vreemd dat de external poort op 81 staat. Bij de andere (goed werkende) camera staat hij op 80.  Ipv6 heeft geen instelling die ik kan uitzetten op de camera.

 

 

 

Reputatie 7
Badge +17

Dat is niet zo vreemd. Achter elke poort kan maar 1 apparaat zitten. Je kunt geen 2 camera's achter poort 80 zetten.

Reputatie 7
Badge +9

UPnP staat aan. Vreemd dat de external poort op 81 staat. Bij de andere (goed werkende) camera staat hij op 80.  Ipv6 heeft geen instelling die ik kan uitzetten op de camera.

 

 

Als dit een screenshot van het configuratie menu van een camera is, dan zijn er dus 2 principes in werking. Als je _en_ met de hand port forwards aanlegt in een router _en_ tegelijkertijd een client apparaat zoals een camera dat ook op zichzelf via UPnP laat uitvoeren, is het niet zo verwonderlijk dat het niet (meer) werkt. 

Ik zou ook maar eens in de handleiding van de Hikvision kijken waarvoor de diverse settings dienen. En e.v.t. de URL ervan berichten, dan kan een ander wellicht zien wat de beste opties zijn.

Badge

Ik heb de UPnP uitgezet. Vervolgens de poort HTTP op 80 gezet. Opgeslagen. Vervolgens de UPnP weer ingeschakeld. Daarna de DCP weer uitgeschakeld en het ip adres weer op de oude instelling gezet.

Nu de mail getest, en die doet het weer. Ik kan m nu ook via zijn eigen ip adres benaderen.

WAAROM??  ik weet het niet.

Als volgende ga ik de modem weer resetten en opnieuw instellen. Kijken of hij ook weer buiten het netwerk te benaderen is. 

Ik begrijp t niet waarom hij nu weer gaat werken.

 

Badge

Alleen in het netwerk bereikbaar. Via wifi op de app bereikbaar maar niet buiten het netwerk op 4G.

Reputatie 7
Badge +9

Hoeveel Hikvision camera’s heb je nu achter de ExperiaBox hangen?

Reputatie 7

Als je UPnP gebruikt, dan moet je juist geen port-forwardings definiëren immers dat neemt UPnP dan voor zijn rekening.

Ik ben zelf absoluut geen voorstander van het gebruik van UPnP, ik foward altijd handmatig.

Op het LAN laat ik de poorten van een apparaat altijd op de standaard staan. Beide camera's zouden bij mij voor http dus ingesteld staan op TCP poort 80.

Om beide camera's extern bereikbaar te maken zou ik bijvoorbeeld TCP poort 6081 doorzetten naar TCP poort 80 van camara 1 en TCP poort 6082 naar TCP poort 80 van camera 2.

Badge

Ik heb één camera op de modem. UPnP zou er voor moeten zorgen dat ik de camera op de app kan zien buiten het netwerk.

vervolgens had ik de poorten 80 554 en 8000 open gezet om hem via het ip adres te kunnen benaderen. Dat werkte allemaal prima, maar sinds twee weken niet meer. Ik kom niet meer door de modem heen.

Alleen nog binnen mijn eigen netwerk.

Reputatie 7

Nogmaals, als je UPnP gebruikt, dan moet je geen port-forwardings instellen want die worden door UPnP al geconfigureerd.

Mijn advies: Zet UPnP uit op zowel de camera als op de Experia Box en maak de port-forwardings handmatig. Zorg er hierbij voor er een DHCP reservering gemaakt is voor de camera zodat het IP adres niet zal wijzigen. Let op: De camera zit met http daarbij gewoon op TCP poort 80.

Plaats vervolgens eens screenshots van alle instellingen die je op de Experia Box gedaan hebt t.b.v. de eerste camera.

Reageer