Vraag

Virtuele Machines hebben geen netwerkverbinding met bindend IP vanuit ExperiaBox

  • 17 februari 2017
  • 30 reacties
  • 1350 keer bekeken


Toon eerste bericht

30 reacties

Reputatie 7
Badge +30
Hmm. kan je /etc/networking/interfaces hier eens plaatsen?

Heb je de networking service herstart of de interface opnieuw gestart of de server herboot zodat de wijziging ook wordt doorgevoerd?

Je hebt geen DHCP Binding terwijl je een statich IP hebt ingesteld in de netwerkadapter?

Ik heb iniedergeval Joran/Justin gevraagd of hij ook even naar dit topic kon kijken
Reputatie 7
Ik heb zojuist even een Hyper-V server direct op onze V10 aangesloten en daarbij voor het (virtuele) MAC adres van één van de VM's een DHCP binding vastgelegd. De VM kreeg keurig het bijbehorende IP adres toegewezen. Mijn gevoel zegt dan ook dat de oorzaak van het probleem niet in de DHCP functionaliteit van de V10 gezocht moet worden. Ik heb helaas maar weinig ervaring met linux aangezien ik zowel privé als zakelijk bijna 100% Microsoft producten gebruik. Ik heb ook wel een Raspberry Pi met Ubuntu draaien maar ook die verkrijgt zijn IP adres keurig via de DHCP server en ook die is m.b.v. een DHCP binding vastgezet. Ik kan je dus ook niet echt verder helpen met de analyse van het probleem, maar gelukkig zijn RobinFlikkema en vele anderen ook actief op dit forum.
Reputatie 7
Badge +28
Ik heb voor de zekerheid ook dezelfde ip-range getest. In bridgemode krijg ik zonder problemen een DHCP binding werkend. Virtualbox met Ubuntu 16.04.





Kun je als test eens een nieuwe VM aanmaken en voor dat mac adres een DHCP bind instellen? Dan weten we zeker dat andere configuratie-instellingen er niet mee te maken hebben.
Excuses voor de vertraging. Ikzelf gebruik VMware Workstation. VMware is voor mij de virtualisatiekoning, en via school krijg ik een 'gratis' licentie. Echter beginnen alle MAC-adressen daar met 00:52:56, als ik mij niet vergis.

Hiermee heb ik zowel Windows-machines als Linux-machines geprobeerd, en allemaal hebben we van hetzelfde 'probleem' last. Wellicht dat de ExperiaBox iets met de eerste 6 cijfers van het MAC-adres te doen heeft. Wellicht heeft het er ook mee te maken of ik mijn 'host' verbindt met het netwerk via een kabel of draadloos.

Inmiddels heb ik een router achter de ExperiaBox staan. Niet alleen omdat de ExperiaBox niet alles deed wat ik wilde, zie hier boven, maar ook voor de algehele dekking in huis. Dit bevalt me prima en inmiddels werkt alles naar behoren, behalve het verbinden met FTP. Waar dit aan ligt weet ik nog niet. De ExperiaBox heb ik geconfigureerd als DMZ met het IP van de router.

Inmiddels heb ik de pogingen gestaakt en gebruik ik vooralsnog naar alle tevredenheid mijn andere router. Echter was dit een vrij prijzig grapje, dus wellicht dat ik een dezer dagen alsnog ga kijken of ik het werkend krijg. In ieder geval bedankt voor de reacties!
Reputatie 7
Op mijn Hyper-V server zijn zelfs de eerste 5 octets van de MAC adressen voor de guests (VM's) allemaal hetzelfde.
Ik kan me ook niet voorstellen dat de Experia Box daar bij het toewijzen van IP adressen iets speciaals mee zal doen.

Reageer