Beantwoord

VPN met V10

  • 4 februari 2018
  • 44 reacties
  • 10481 keer bekeken

Reputatie 2
Badge
Hallo,
als absolute leek op het gebied van routers, vpn etc. wil ik proberen ik een VPN op te zetten.
Deze VPN moet niet op de PC draaien maar op de router. Het gaat om de V.10

Het doel:
De Duitse versie van "Amazon Alexa" en de "Harmony Elite met Hub" kunnen alleen met
elkaar verbonden worden "accounts koppelen" indien mijn IP adres herkend wordt als zijnde Duits !
Het gaat om de Duitse en NIET om de internationale US of UK versie van "Amazon Alexa"

Is er een manier waarop een leek zoiets kan instellen ?
icon

Beste antwoord door Skinamp 20 maart 2018, 12:05

Feedback,

complimenten voor de service van Goose.....

Binnen 1 minuut was de VPN verbinding opgezet, enkele aanpassingen waren nodig.
DNS server 1 & 2 handmatig ingegeven
Firewall op de Asus uitgezet
en gekozen voor L2TP i.p.v. OpenVPN

De medewerker van Goose gaf aan dat L2TP op Asus routers het beste werkt, aangezien hij
een server in Amsterdam had ingesteld "niet wetende dat ik een Duits IP adres wil", ben ik zelf
bezig geweest en heb met OpenVPN nu dat de overige instellingen goed staan, probleemloos
een OpenVPN verbinding kunnen maken met een Duitse server....

Loopt als een trein!

Bedankt voor de support hier op het Forum
draadje kan dicht 😉
Bekijk origineel

44 reacties

Reputatie 2
Badge
@wjb

geweldig, je hebt me net heeeel gelukkig gemaakt :-)
Ik had op de NAS alleen de IP range 192.168.2.xxx vrijgegeven, de nas en laptop even op de V10
aangesloten, IP range 192.168.1.xxx ook vrijgegeven en alles werkt naar behoren !

TOPPIE
Reputatie 7
Klopt, dit heeft niets met port-forwarding te maken.
Wat wel kan is dat jij een automatische IP blokkade ingesteld hebt staan die bij een aantal foutieve logins binnen een bepaalde tijd het IP adres blokkeert. Zou het kunnen dat jouw PC geblokkeerd is. Je zou de Qnap dan wel vanaf een ander apparaat op jouw LAN kunnen benaderen.
Reputatie 2
Badge
Op de App werkt alles naar behoren
via http:// en https:// heb ik vanaf de laptop geen toegang tot de NAS.

Op welke router zou ik portforwarding naar de NAS moeten instellen en hoe
Wat ik niet snap is dat de switch op het subnet 192.186.1 zit en alle apparaten
op deze switch zijn aangesloten... Dan moet ik de NAS toch ook zonder portforwarding
kunnen aanspreken ?
Reputatie 7
Draait er dan wel een service op TCP poort 8080?
Standaard zou daar de beheeromgeving van de Qnap op draaien.
Controleer eens in de app of daar bij de Port ook 8080 ingevuld staat.
Type je http://192.168.1.119:8080 in of https://192.168.1.119:8080
Reputatie 2
Badge
Ach, ik bedoel 192.168.1.119:8080
Ik wil met de Laptop en straks (nu nog niet aangesloten) ook met de MiniX
verbinding kunnen maken met de NAS....
Van extern WAN is het totaal niet interessant de NAS te kunnen bereiken, alleen
via het interne netwerk moet hij bereikbaar zijn .
Reputatie 7
Waarom kan ik via 192.168.2.119:8080 de NAS niet bereikenBedoel je 192.168.2.9:8080 of 192.168.1.119:8080?
Waar is het apparaat waarmee je die verbinding maakt op aangesloten? (Experia Box, Asus of benadering vanaf Internet)
Reputatie 2
Badge
Toch nog even verder met het topic....

ik zit zoals boven al vermeld met het volgende probleem,.
M'n NAS (QNap 4Bay) is niet bereikbaar. Ik weet niet (snap niet) waarom.
Omdat ik niet alle techneuten termen ken, heb ik het met een screenshot
en een schema getracht te verduidelijken.

Waarom kan ik via 192.168.2.119:8080 de NAS niet bereiken en waarom is
ook Qfinder niet instaat de NAS te vinden?

Iemand een idee

P.S.
Nog een screenshot toegevoegd, vanaf de mobiele telefoon welke Wifi verbonden
is met de Asus router, kan ik met Qmanager wel gewoon verbinding maken met de
NAS op het aangegeven IP Adres....
Reputatie 2
Joeri van goose 😉

Misschien dat het meespeelt omdat het een nederlandse VPN met datacenter in amsterdam is dat het daardoor sneller is dan met een duitse server,

Dank beiden voor de reacties,

@Skinamp ik heb een 100/100 glasvezel verbinding btw.
Reputatie 2
Badge
@DigiB

Hi, ja de Router is snel genoeg. Nu heb ik wel een abbo met lage snelheid bij KPN dus of het voldoende is voor een ander kan ik niet zeggen.
In ieder geval heeft de router naar mijn mening voldoende mogelijkheden voor zelfs de doorgewinterde gebruiker.

Goose werkt TOP en Support van Goose is echt geweldig en ze ondersteunen de Asus routers.

Wel valt me op dat de servers die ze gebruiken in Amsterdam sneller zijn dan de servers die ik nodig heb in Duitsland. Maar voor mij is het werkbaar.. Iets trager kan ik mee leven ?

Een topic over het instellen van deze router zou wel leuk zijn, op dit moment weet ik nog niet hoe ik m'n NAS kann bereiken. Dit lukt wel via de Qnap app maar niet via het interne netwerk. In zo een topic vind ik dan misschien de oplossing voor dit probleem ?
Reputatie 7
Ik maak zowel zakelijk als privé veelvuldig gebruik van VPN verbindingen gebaseerd op IPSec. Zolang er maar voor een Diffie-Hellman groep gekozen wordt met een 2048 bit modulus is de VPN tunnel echt wel voldoende beveiligd.
Ja, zo'n hoge modulus betekent ook dat er meer rekencapaciteit benodigd is en dat heeft een impact op de snelheid.
Reputatie 2
Dus de verhalen over dat het langzamer is en makkelijker gekraakt(nsa) kan worden zijn beetje overdreven ;)
Na veel lezen hier beschouw ik jouw @wjb toch wel als redelijke vpn expert vandaar 😉
Reputatie 7
L2TP/IPsec is net als OpenVPN een prima optie qua beveiliging.
Reputatie 2
Mooi dat het werkt maar is openvpn niet een betere optie qua veiligheid, daar was het jouw inprincipe niet om te doen maar vind het een aparte move van goose.

Misschien kan @wjb hier een toelichting op geven.

p.s @Skinamp is de asus router snel zat btw ?
Wellicht is dit een leuke router om het vpn verhaal op te zetten van buiten af kosten vallen dan enorm mee met deze asus router.
Reputatie 2
Badge
Feedback,

complimenten voor de service van Goose.....

Binnen 1 minuut was de VPN verbinding opgezet, enkele aanpassingen waren nodig.
DNS server 1 & 2 handmatig ingegeven
Firewall op de Asus uitgezet
en gekozen voor L2TP i.p.v. OpenVPN

De medewerker van Goose gaf aan dat L2TP op Asus routers het beste werkt, aangezien hij
een server in Amsterdam had ingesteld "niet wetende dat ik een Duits IP adres wil", ben ik zelf
bezig geweest en heb met OpenVPN nu dat de overige instellingen goed staan, probleemloos
een OpenVPN verbinding kunnen maken met een Duitse server....

Loopt als een trein!

Bedankt voor de support hier op het Forum
draadje kan dicht 😉
Reputatie 7
De router blijft klagen dat z'n WAN IP niet gelijk is aan m'n Externe IP.Dat klopt en dat is inherent aan het feit dat je twee routers achter elkaar hebt staan. Dat noemen we double nat.
Ik weet niet of dit de reden kan zijn dat OpenVPN niet werkend te krijgen is.OpenVPN is juist een VPN methode die prima overweg kan met double nat dus dat kan het probleem niet zijn. Ook die GL-iNet AR-750 van mij resulteert in een double nat, maar die OpenVPN cliënt functioneert prima.
Reputatie 2
Badge
De router blijft klagen dat z'n WAN IP niet gelijk is aan m'n Externe IP.
Ik weet niet of dit de reden kan zijn dat OpenVPN niet werkend te krijgen is.

Morgen dan maar een teamviewer verbinding met Goose, misschien ligt de fout gewoon bij
de configuratie file van Goose en heeft het niets met deze WAN IP melding te maken...

P.S.
Feedback komt later, de teamviewer verbinding wordt op z'n vroegst dinsdag a.s.
Reputatie 7
Beetje een rare terminologie, maar zo te lezen moet je inderdaad de Wireless router mode hebben. Als ik die term lees zou ik verwachten dat die router dan draadloos aangesloten is, maar dat is dus blijkbaar niet zo.
Reputatie 2
Badge
Ik heb de router testwijze even als AP geconfigureerd, in AP modus is er helemaal geen VPN mogelijkheid aanwezig. Alleen 2 mogelijkheden zijn aanwezig. Wireless router mode is degene waar ik OpenVPN kan instellen.
Reputatie 7
Wat voor een mogelijkheden heb je daar dan allemaal?
Reputatie 2
Badge
Ja klopt, is dat verkeerd. Het is toch geen accespoint of zie ik dat verkeerd?
Reputatie 7
Waarom heb je voor Wireless router mode gekozen, hij is toch met een kabel aangesloten op de Experia Box?
Reputatie 2
Badge
@wjb
De WAN connectie staat op automatisch..
Deze "om het gele uitroepteken uit te krijgen" kort op handmatig instellen gezet. Doe ik dit, dan heb ik meteen geen internet meer en heb ik dus op automatisch teruggezet.

Met de bovengenoemde instellingen krijg ik OpenVPN niet ingeschakeld.

Morgen heb ik een teamviewer verbinding met Goose, hopelijk komt daar een oplossing uit. Meld me daarna nog terug. Tenzij er in mijn opgenoemd instellingen nu misschien al een fout is te ontdekken.
Reputatie 7
Waarom zou je de WAN connection type van automatisch IP naar handmatig willen zetten. De Asus krijgt zijn IP adres toch automatisch van de DHCP server van de Experia Box.
Als je hem op handmatig zet, dan zal je ook handmatig de DNS servers moeten instellen op de Asus, want die krijg je dan ook niet meer aangeleverd van de Experia Box.
Persoonlijk zeg ik: Laat gewoon op automatisch IP staan.
Reputatie 2
Badge
Na veel wikken en wegen voor de Asus gekozen, de RT-AC51U
de router heeft veel mogelijkheden, voor mij misschien teveel :_)

Ik heb een probleem met instellen van OpenVPN via Goose

Met ondergenoemde instellingen heb ik internet zowel via de V10 als ook via de Asus
maar Ik krijg GEEN OpenVPN verbinding tot stand.
Het gele uitroepteken knippert en geeft aan : The WAN IP is not the external IP. External IP-Based services will not work.

Bekabeling als volgt aangesloten :
LAN1 van V10 naar WAN Asus
KPNTV op V10 aangesloten
PC op LAN 2 Asus

Gedaan op V10:
DHCP Server aan
DHCP binding ingesteld als asusvpn / mac adres / ip 192.168.2.180
DMZ-IPv4 AAN - Mode IP adres / LAN host 192.168.2.180
DynDNS uit
DNS item aangemaakt
Skinvpn / IP adres 192.168.2.180
UPnP uit
ALLE portforwardings verwijderd

Asus :
WAN connection type (automatic IP)
Enable WAN (yes)
Enable NAT (yes)
Enable UPnP (yes)
IP ADRES (192.168.1.1)
Subnmask (255.255.255.0)
Enable DHCP server (Yes)
Connect to DNS Server automatically (yes)
RT-AC51U Domain name (leeg)
IP Pool starting address (192.168.1.2)
IP Pool ens address (192.168.1.254)
DNS Server (leeg)
WINS Server (leeg)
Default Gateway (leeg)
Firmware op laatste stand gebracht
Wireless router mode gekozen

VPN serverlist:
.ovpn file geladen en in asus geupload
CA Certificate geupload

Op het moment dat ik WAN connection type van Automatic IP op Handmati g zet
en de IP gegevens 192.168.2.180 en subnetmask 255.255.255.0 instel heb ik gelijk via
de Asus geen internet meer.

Wat doe ik verkeerd ?
Reputatie 2
Badge
Oke, Ik zit nu in een testmaand bij goose geen Duitse VPN provider, op een kleinigheid na werkt Goose naar behoren. Volgende stap waarschijnlijk de ar-750.... Of een Asus RT-AC51U

Ik ben er alleen nog niet achter of bij deze modems ook het probleem speelt dat VoIP niet mogelijk is bij een VPN verbinding, hier wordt bij verschillende VPN modems over geklaagd.

Reageer