Beantwoord

VOIP configureren op FritzBox mislukt

  • 24 juli 2021
  • 11 reacties
  • 128 keer bekeken

Wanneer ik mijn Experiabox vervang door een Fritzbox lukt het niet om telefonie werkend te krijgen.

De fritzbox 7581 draait op de laatste versie (07.15) en die heeft een wizard voor KPN. Die doorlopen en internet en IPTV werken zonder problemen.

Alleen telefonie mislukt. Via servicetools de SIP gegevens opgevraagd (en wachtwoord ingesteld) en in de Fritzbox ingevoerd. Check bij save mislukt, en als je in de log kijkt zie je:

Registration of Internet telephone number failed. Remote site reports reason for error.

Ook getracht telefoonnummer te registeren als other met alle KPN vermelde setting. Fritzbox zie dan gelijk dat het KPN is, maar registratie mislukt nog steeds.

Zie ik iets over het hoofd of gaat er iets mis met mijn account?

(reden waarom ik twijfel over mijn account is dat toen abonnement begon KPN veilig ook niet werkte, ondanks dat het zichtbaar was als product in het overzicht, gaf bij inloggen op veilig.kpn.com het systeem aan dat er geen abonnementen beschikbaar waren. Toen is het product verwijderd en opnieuw toegevoegd om het op te lossen. Zou iets degelijks ook het geval kunnen zijn bij de telefonie)

icon

Beste antwoord door Tazwaterpolo 25 juli 2021, 11:28

dank iedereen voor het meedenken.

 

Het is gelukt door ipv het KPN profiel (werkt niet) of de proxy FQDN voip1-ext.kpn.net (werkt dus ook niet)  de proxy-setting op 145.7.97.53 te zetten.

de setting 

    outboundproxy = "voip1-ext.kpn.net";

moet dus zijn

    outboundproxy = "145.7.97.53";

 

Blijkbaar gaat er iets fout met dns wanneer je voor de proxy de FQDN gebruikt. 

Bekijk origineel

11 reacties

Reputatie 4
Badge +1

Op het forum worden meerdere problemen met telefonie gemeld. 
Maar begin eens met testen of je wel de nieuwste software hebt. 
Op avm.de staat voor de meeste Fritzboxen 7.25 en hoger vermeld. 

van MyFritz!:

 

FRITZ!OS installed: 7.15 (Version up to date)

As of 24 July 2021, 17:38

 

Systeem draait dus op de laatste versie.

 

En ik heb het forum ook al doorgespit. Helaas tot op heden daar nog niet de oplossing gevonden.

Reputatie 4
Badge +1

Volgens Knowledge-base artikel #3548 Fritzbox voor gebruik op de KPN-aansluiting configureren, op nl.avm.de, moet je minimaal 7.20 hebben. 

ik heb het artikel bij AVM gevonden (https://nl.avm.de/service/knowledge-base/dok/FRITZ-Box-7590/3548_FRITZ-Box-voor-gebruik-op-de-aansluiting-van-KPN-configureren/). Dank hiervoor.

omdat de fritzbox wel een profiel heeft voor KPN verwachte ik dat het oké was, maar helaas voor telefonie dus niet.

 Zal dan toch moeten investeren in een nieuwere fritzbox.

Reputatie 5
Badge +6

Ik denk dat ik er toch een fout zit in je settings aangezien hier een 7581 draait met KPN nummer.

 

post je settings eens zonder vermelding van login en wachtwoord en maak de laatste 8 cijfers van je vaste lijn even onherkenbaar

**** CFGFILE:voip.cfg

/*

* /var/tmp.cfg

* Sun Jul 25 08:45:29 2021

*/

 

meta { encoding = "utf-8"; }

 

voipcfg {

        dnsport = 7077;

        rtpport_start = 7078;

        sip_srcport = 5060;

        ua1 {

                enabled = yes;

                username = "<removed>";

                authname = "<removed>";

                passwd = "<removed>";

                registrar = "ims.imscore.net";

                ttl = 1h;

                sipping_enabled = no;

                sipping_interval = 280s;

                name = "18xxxxxxx";

                providername = "provider_id=kpn;parentprovider_id=undefined;numberprefix=+31;usersprefix=;usersuffix=;phoneExtension=";

                voip_providerlist_id = "kpn";

                ims_client = no;

                with_displayname = no;

                read_from_displayname = yes;

                dtmfcfg = dtmfcfg_rtp_or_inband;

                rtpevent_keep_packetrate = no;

                register_failwait = 0w;

                register_failwaitmax = 30m;

                register_failover_fallback_process = no;

                stunserver = "";

                stunserverport = 3478;

                use_internat_calling_numb = no;

                is_nat_aware = no;

                localip = 0.0.0.0;

                protocolprefer = protocolprefer_ipv4only;

                ignore_received_header = no;

                always_clir = no;

                clirtype = clir_star31star;

                reject_anonymous_call_with_433 = no;

                colptype = colp_none;

                clipnstype = clipns_off;

                vad_enabled = no;

                only_one_dialog = no;

                presence_supported = no;

                mwi_supported = no;

                mwi_inmemoria = no;

                ccbs_supported = no;

                reg_support = regsupport_auto;

                packetization = packetization_fixed;

                tx_packetsize_in_ms = 20;

                xrtp_periodic = 0;

                reject_refer = yes;

                sip_instance = no;

                no_register_fetch = yes;

                do_not_register = no;

                only_call_from_registrar = no;

                mobile_capability = voip_over_mobile_all;

                invite_without_register_allowed = no;

                outboundproxy = "voip1-ext.kpn.net";

                outboundproxy_without_route_header = no;

                factory_3pty_uri = "";

                no_hold_speech = no;

                dditype = ddi_none;

                ddireception = "";

                ddimynumber_with_plusprefix = no;

                webui_trunk_id = "normal:80111225-260336-12258011-17801117";

                alias_head_number = "";

                cfxsignaling = cfx_standard;

                backup_wanted = no;

                use_session_timer = no;

                use_rport = yes;

                add_rtpmap_for_all_codecs = no;

                answer_only_one_codec = no;

                without_annexb_no = no;

                tls_version = tlsv1_2;

                srtp_supported = no;

                crypto_avp_mode = crypto_mode_avp_only;

                use_488_for_no_t38 = no;

                g726_via_rfc3551 = no;

                no_g726_32_offer_with_pt2 = no;

                g726_fixed_ptime30 = no;

                dtmf_inband_on_g711g722 = no;

                codec_override = "PCMA/8000/1", "PCMU/8000/1", "G722/8000/1";

                enable_3xx = yes;

                t38_reinvite_from_remote = no;

                use_t38version0 = no;

                rtcp_xr_media_attribute = no;

                ptime_a_attribute = yes;

                tones_and_announcements_for_service = no;

                read_p_asserted_identity_header = no;

                route_always_over_internet = yes;

                sipiface = sipiface_automatic;

                altc_attribute_rfc6947 = no;

                send_extended_sip_client_info = no;

                gui_readonly = no;

                convertstate = 0;

                snmp_instance = 0;

                loopback_client_username_fos = "";

                loopback_client_username_pass_through = "";

                directloopback_client_username = "";

        }

        ua2 {

                enabled = no;

                username = "";

                authname = "";

                passwd = "";

                registrar = "";

                ttl = 30m;

                sipping_enabled = no;

                sipping_interval = 280s;

                name = "";

                providername = "";

                voip_providerlist_id = "";

                ims_client = no;

                with_displayname = no;

                read_from_displayname = yes;

                dtmfcfg = dtmfcfg_automatic;

                rtpevent_keep_packetrate = no;

                register_failwait = 0w;

                register_failwaitmax = 30m;

                register_failover_fallback_process = no;

                stunserver = "";

                stunserverport = 3478;

                use_internat_calling_numb = no;

                is_nat_aware = no;

                localip = 0.0.0.0;

                protocolprefer = protocolprefer_ipv4only;

                ignore_received_header = no;

                always_clir = no;

                clirtype = clir_displayname;

                reject_anonymous_call_with_433 = no;

                colptype = colp_none;

                clipnstype = clipns_off;

                vad_enabled = no;

                only_one_dialog = no;

                presence_supported = no;

                mwi_supported = yes;

                mwi_inmemoria = no;

                ccbs_supported = no;

                reg_support = regsupport_auto;

                packetization = packetization_fixed;

                tx_packetsize_in_ms = 20;

                xrtp_periodic = 0;

                reject_refer = yes;

                sip_instance = no;

                no_register_fetch = no;

                do_not_register = no;

                only_call_from_registrar = no;

                mobile_capability = voip_over_mobile_all;

                invite_without_register_allowed = no;

                outboundproxy = "";

                outboundproxy_without_route_header = no;

                factory_3pty_uri = "";

                no_hold_speech = no;

                dditype = ddi_none;

                ddireception = "";

                ddimynumber_with_plusprefix = no;

                webui_trunk_id = "";

                alias_head_number = "";

                cfxsignaling = cfx_standard;

                backup_wanted = no;

                use_session_timer = no;

                use_rport = yes;

                add_rtpmap_for_all_codecs = no;

                answer_only_one_codec = no;

                without_annexb_no = no;

                tls_version = tlsv1_2;

                srtp_supported = no;

                crypto_avp_mode = crypto_mode_avp_only;

                use_488_for_no_t38 = no;

                g726_via_rfc3551 = no;

                no_g726_32_offer_with_pt2 = no;

                g726_fixed_ptime30 = no;

                dtmf_inband_on_g711g722 = no;

                enable_3xx = yes;

                t38_reinvite_from_remote = no;

                use_t38version0 = no;

                rtcp_xr_media_attribute = no;

                ptime_a_attribute = yes;

                tones_and_announcements_for_service = no;

                read_p_asserted_identity_header = no;

                route_always_over_internet = no;

                sipiface = sipiface_automatic;

                altc_attribute_rfc6947 = no;

                send_extended_sip_client_info = no;

                gui_readonly = no;

                convertstate = 0;

                snmp_instance = 0;

                loopback_client_username_fos = "";

                loopback_client_username_pass_through = "";

                directloopback_client_username = "";

        }

        register_sequence_timer = 0;

        use_krtp = yes;

        use_audiocodecs = no;

        audiocodecs = "PCMA", "PCMU", "G726-32", "G726-40", "G726-24";

        verbose = no;

        capi_blocksize_in_ms = 30;

        sip_prio = 0;

        rtp_prio = 0;

        rtcp_prio = 0;

        dyn_codecs = yes;

        prio_low_codec = no;

        send_ringtone = no;

        t38_support_enabled = yes;

        t38_ignore_provider_profil = no;

        reduce_data_rate = yes;

        enum_support_enabled = no;

        bandwidth_to_leave_KBits = 0;

        dialoglimit = 0;

        enumdomains = "e164.arpa", "e164.org", "openenum.eu";

        rtpstream {

                voice_activity_detection {

                        vad_enabled = vadenabled_no;

                        vad_threshold = 10000;

                }

                plc {

                        in_the_stack = yes;

                }

                jitter {

                        auto_on = yes;

                        in_ms = 50;

                        in_packets = 0;

                }

                rtcp_enabled = yes;

                silence_detection = no;

        }

        voip_assi_enabled = no;

        mobile_capability = voip_over_mobile_no;

        gui_readonly = no;

        voipcfg_version = 21;

        extension_version = 1;

}

 

 

// EOF

Op het forum worden meerdere problemen met telefonie gemeld. 
Maar begin eens met testen of je wel de nieuwste software hebt. 
Op avm.de staat voor de meeste Fritzboxen 7.25 en hoger vermeld. 


De 7581 is al even uit de ondersteuning, er zou na 7.13 al geen nieuwe firmware meer komen, kwam er onverwachts toch nog 7.15 met wat verbeteringen, maar dit is echt de laatste die er komt, AVM heeft hem in de afvalbak gegooid, de 7583 en de 7590 zijn hem opgevolgd.

 

@Tazwaterpolo , heb je een reset geprobeerd, kan zomaar de oplossing zijn, gaat soms wel eens iets fout met de update.

Reputatie 5
Badge +6

Ben nu aan het werk en kan vanavond pas kijken hoe mijn configuratie is.

 

 

@Tazwaterpolo, heb je een reset geprobeerd, kan zomaar de oplossing zijn, gaat soms wel eens iets fout met de update.

 

Reset, harde reset, terug naar fabrieksinstellingen => allemaal gedaan, helaas geen resultaat. Hopelijk heeft @Speedmaster vanavond uit zijn werk het magische antwoord aangezien hij wel een 7581 werkend heeft.

dank iedereen voor het meedenken.

 

Het is gelukt door ipv het KPN profiel (werkt niet) of de proxy FQDN voip1-ext.kpn.net (werkt dus ook niet)  de proxy-setting op 145.7.97.53 te zetten.

de setting 

    outboundproxy = "voip1-ext.kpn.net";

moet dus zijn

    outboundproxy = "145.7.97.53";

 

Blijkbaar gaat er iets fout met dns wanneer je voor de proxy de FQDN gebruikt. 

Reputatie 7
Badge +17

Hi @Tazwaterpolo, top dat je het euvel gevonden hebt en de telefonie aan de praat hebt gekregen! :muscle_tone2:

Reageer