Beantwoord

ICMP error (TTL exceeded) bij ping vanuit WAN, routing issue?

  • 8 augustus 2020
  • 9 reacties
  • 90 keer bekeken

Reputatie 2
Badge

T.b.v. monitoring stuur ik via Nagios iedere 5 minuten een ping naar de router van mijn vader. Ik ben bij Ziggo, hij bij XS4ALL (FttH). Sinds eergisteren zie ik sporadisch een probleem:

Service Ok[2020-08-08 14:13:30] SERVICE ALERT: _Router;Ping;OK;SOFT;2;PING OK - Packet loss = 0%, RTA = 12.97 msService Critical[2020-08-08 14:12:26] SERVICE ALERT: _Router;Ping;CRITICAL;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Host Up[2020-08-08 08:36:51] HOST ALERT: _Router;UP;SOFT;1;PING OK - Packet loss = 0%, RTA = 11.55 mHost Down[2020-08-08 08:36:19] HOST ALERT: _Router;DOWN;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Host Up[2020-08-08 06:16:23] HOST ALERT: _Router;UP;SOFT;1;PING OK - Packet loss = 0%, RTA = 11.30 msHost Down[2020-08-08 06:15:19] HOST ALERT: _Router;DOWN;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Service Ok[2020-08-08 04:11:22] SERVICE ALERT: _Router;Ping;OK;SOFT;2;PING OK - Packet loss = 0%, RTA = 11.66 msService Critical[2020-08-08 04:10:18] SERVICE ALERT: _Router;Ping;CRITICAL;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Service Ok[2020-08-08 04:09:18] SERVICE ALERT: _Router;Ping;OK;SOFT;2;PING OK - Packet loss = 0%, RTA = 11.50 msService Critical[2020-08-08 04:08:14] SERVICE ALERT: _Router;Ping;CRITICAL;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Service Ok[2020-08-08 00:12:14] SERVICE ALERT: _Router;Ping;OK;SOFT;2;PING OK - Packet loss = 0%, RTA = 11.36 msService Critical[2020-08-08 00:11:10] SERVICE ALERT: _Router;Ping;CRITICAL;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Service Ok[2020-08-07 21:02:47] SERVICE ALERT: _Server;SSH;OK;SOFT;2;SSH OK - OpenSSH_7.9p1 Raspbian-10+deb10u2 (protocol 2.0)Service Critical[2020-08-07 21:01:47] SERVICE ALERT: _Server;SSH;CRITICAL;SOFT;1;connect to address 82.161.x.x and port 2201: No route to hostHost Up[2020-08-07 17:07:55] HOST ALERT: _Router;UP;SOFT;1;PING OK - Packet loss = 0%, RTA = 11.17 msHost Down[2020-08-07 17:06:51] HOST ALERT: _Router;DOWN;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Host Up[2020-08-07 16:16:51] HOST ALERT: _Router;UP;SOFT;1;PING OK - Packet loss = 0%, RTA = 12.71 msHost Down[2020-08-07 16:16:09] HOST ALERT: _Router;DOWN;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Host Up[2020-08-07 08:16:12] HOST ALERT: _Router;UP;SOFT;1;PING OK - Packet loss = 0%, RTA = 12.09 msHost Down[2020-08-07 08:15:08] HOST ALERT: _Router;DOWN;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Host Up[2020-08-07 02:05:08] HOST ALERT: _Router;UP;SOFT;1;PING OK - Packet loss = 0%, RTA = 11.73 msHost Down[2020-08-07 02:04:04] HOST ALERT: _Router;DOWN;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Service Ok[2020-08-07 00:00:09] SERVICE ALERT: _Router;Ping;OK;SOFT;2;PING OK - Packet loss = 0%, RTA = 14.81 msService Critical[2020-08-06 23:59:04] SERVICE ALERT: _Router;Ping;CRITICAL;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Service Ok[2020-08-06 20:43:04] SERVICE ALERT: _Router;Ping;OK;SOFT;2;PING OK - Packet loss = 0%, RTA = 14.64 msService Critical[2020-08-06 20:42:00] SERVICE ALERT: _Router;Ping;CRITICAL;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)Host Up[2020-08-06 20:26:51] HOST ALERT: _Router;UP;SOFT;1;PING OK - Packet loss = 0%, RTA = 11.63 msHost Down[2020-08-06 20:25:50] HOST ALERT: _Router;DOWN;SOFT;1;CRITICAL - Time to live exceeded (82.161.x.x)

De foutmelding (Time to live exceeded) impliceert een probleem in de routing tussen onze routers, waarschijnlijk een loop tussen twee routers in de infrastructuur waardoor de TTL steeds verder afneemt. Te zien is dat het probleem zich steeds slechts een minuut voordoet en daarna oplost, er geen sprake is van packet loss en de latency goed is (vanuit mijn router naar CMTS is 8~9 ms).

Ik vermoed dat het probleem in de infrastructuur zit omdat ik pings stuur naar diverse andere hosts op internet en dit probleem alleen met deze host voorkomt.

In de logs van de router van mijn vader (FRITZ!Box 7490) is er niets te zien van dit probleem en heb er ook (nog) geen klachten over gekregen van hem.

Komt iemand dit probleem bekend voor?

P.S.: Excuses voor de opmaak van de logs, forum haalt steeds de returns weg.

 

icon

Beste antwoord door tobiastheebe 28 augustus 2020, 15:52

De FRITZ!Box heeft zichzelf op 26 augustus om 3:00 opnieuw verbonden met internet c.q. de DHCP-lease vernieuwd, sindsdien is probleem niet meer voorgekomen.

Bekijk origineel

9 reacties

Reputatie 7
Badge +14

Ik denk dat u dat beter bij XS4ALL na kunt vragen. Niet hier op het forum van KPN.

Reputatie 2
Badge

Klopt, maar heb hier een account en daar niet. :) Gaat tevens over dezelfde infra.

Reputatie 7
Badge +14

Klopt, maar heb hier een account en daar niet. :) Gaat tevens over dezelfde infra.

De infra gaat KPN Netwerk NL over. Dit forum is van KPN provider. 

Reputatie 7

Doe dan eens een traceroute naar dat IP adres, dan zie je direct of er sprake is van een loop.

Reputatie 2
Badge

Het lastige is dat het zo sporadisch voorkomt. Het komt op een bepaald moment voor en een minuut later is het weer weg. Ik kan later vanavond eens kijken of ik er toevallig met traceroute tegenaan loop maar acht de kans vrij klein.

Reputatie 2
Badge

Traceroute vanaf server gaat prima:

 

Reputatie 2
Badge

Hierbij tevens nog een duidelijker stukje alerts history:

Sinds 14:13 is het overigens niet meer voorgekomen, hopelijk blijft het zo.

Reputatie 2
Badge

Zojuist nog even gekeken, probleem speelt nog steeds.

Reputatie 2
Badge

De FRITZ!Box heeft zichzelf op 26 augustus om 3:00 opnieuw verbonden met internet c.q. de DHCP-lease vernieuwd, sindsdien is probleem niet meer voorgekomen.

Reageer