Vraag

VOIP/SIP Instellingen Yealink W60B

  • 16 July 2020
  • 38 reacties
  • 6103 keer bekeken

Sinds enige tijd gebruiken we onze eigen router voor (glasvezel)internet, maar ik krijg VOIP nog steeds niet aan de praat. Ik maak gebruik van de gegevens op de pagina die KPN aanbiedt, maar ik weet niet zeker welke gegevens ik waar moet invullen op de Yealink pagina. Bij alle pogingen krijg ik tot nu toe “Register Failed”

Ik heb na lang zwoegen eindelijk succesvol een SIP wachtwoord aangemaakt (kon alleen terwijl ik verbonden was met de ExperiaBox). Die is nu weer ontkoppeld.

Ik maak gebruik van een Netgate router met pFsense erop. VLAN6 werkt (want internet werkt).

In de bijlage een overzicht van de register gegevens. Ik heb hier al lekker in zitten te prutsen. Maar krijg het niet aan de praat.

Ik vraag me af:

  • of ik ergens het telefoonnummer moet invullen
  • of ik niet nog iets moet port forwarden of een andere instelling in de router moet wijzigen?
  • Display Name zou volgens een Google zoektocht het caller ID moeten zijn. Dus wat in beeld komt bij anderen. Geen idee of ik daar iets mee moet. 
  • Welke server vul ik waar in? ims.imscore.net is de Registrar, maar niet Register Name?
  • Is de SIP server hetzelfde als die ims.imscore.net of moet ik daar dezelfde als bij de Proxy invullen?
  • Is de outbound-proxy noodzakelijk?
  • Ik gok dat ik de User Name correct heb ingevuld? (nu even met xxxxxx)

Ik hoor het graag als er meer gegevens nodig zijn. 

 

 


38 reacties

Reputatie 7
Badge +10

Diverse instellingen verkeerd ingegeven:

  1. Belangrijkste:
    Line Active = Disabled, ofwel je hebt de lijn / het SIP account niet eens geactiveerd.
     
  2. Displayname: Het nummer wat je op de display van de handsets wilt laten zien
    als te gebruiken herkenning bij de te kiezen lijn voor actieve verbindingen. (Is nu leeg).
     
  3. Register name:  Dat zou de login naam moeten zijn.
    De gegevens die jij bij   “Username”  hebt ingegeven.
     
  4. Bij “Username” vul je je telefoonnummer in, volledig met +31 notatie

Daarna zou je bij de instellingen elders in de W60B --→ Accounts --→ Number Assignment
je handsets nog moeten toewijzen, dat zij het bewuste SIP-account gebruiken.

Bedankt voor je antwoord! Ik zal de gegevens in elk geval omwisselen! Ik had nooit bedacht het telefoonnummer bij username in te vullen.

En ik waardeer je opmerking over enabled/disabled, want stel je voor dat het zo simpel was als dat. Soms zie ik, net als iedereen, ook dat soort dingen over het hoofd.

Maar dit keer niet hoor. Ik had hem uitstaan omdat ik las dat KPN je account tijdelijk kon blokkeren na een x aantal mislukte aanmeldpogingen.

Ik ga dit straks proberen en laat de uitkomst weten.

Reputatie 7

Maar dit keer niet hoor. Ik had hem uitstaan omdat ik las dat KPN je account tijdelijk kon blokkeren na een x aantal mislukte aanmeldpogingen.

Waar heb je dat gelezen?

Hoi @wjb 

Allereerst nog even bedankt voor alle bijdragen die jij hier levert. Geweldig!

Dit staat op dé pagina van eigen modem: https://www.kpn.com/service/internet/wifi-en-modems/eigen-modem-instellen-en-gebruiken.htm

Bij foutieve gegevens, zal de centrale, in verband met de veiligheid, het account tijdelijk blokkeren. Afhankelijk van de fabrikant, model en softwareversie, kunnen automatisch meerdere inlogpogingen worden uitgevoerd. De KPN-centrale zal deze automatische inlogpogingen zien als een reden om je account te blokkeren. Na ongeveer 15 minuten zal het account weer worden vrijgegeven.  

Ik heb de instellingen veranderd zoals @Babylonia voorstelde, maar er verandert niets aan het resultaat. In de meeste gevallen blijft de status lang op “Registering...” staan, maar uiteindelijk komt er steeds “Failed” te staan. 

In deze screenshot heb ik NAT op STUN gezet, maar dit heb ik ook op disabled laten staan in andere pogingen. 

Reputatie 7
Badge +10

Er zit in de Yealink soms een vreemde achterliggende fout, alsof een eerdere ingave wordt onthouden?

Zet de poortnummers eens overal waar nu 5060 staat even tijdelijk op 5070, en “confirm”.
Daarna nog eens opnieuw terug naar 5060 en “confirm”.

Mogelijk dat het ook met het volgende te maken zou kunnen hebben??
 

Bij foutieve gegevens, zal de centrale, in verband met de veiligheid, het account tijdelijk blokkeren. Afhankelijk van de fabrikant, model en softwareversie, kunnen automatisch meerdere inlogpogingen worden uitgevoerd. De KPN-centrale zal deze automatische inlogpogingen zien als een reden om je account te blokkeren. Na ongeveer 15 minuten zal het account weer worden vrijgegeven.  

Probeer het na een half uurtje anders nog eens.
(Datgene wat ik hierboven bij de tweede alinea heb aangegeven).

Reputatie 3
Badge

Ja, die Yealink is vreemd…

Voor zowel “User Name” als “Register Name” moet het 10-cijferige (?) telefoonnummer worden ingevoerd, in elk geval het volledige nummer in beide vakjes.

Reputatie 7
Badge +10

Nee, dat klopt niet met wat je schrijft.

Buiten de VOIP server gegevens, bestaat een SIP-account uit:

  • Een gebruiker inlognaam / authenticatie
  • Een wachtwoord
  • Het expliciete telefoonnummer zelf

Die gegevens zul je dan ook zonder uitzondering alle drie moeten invullen.  En niet een gebruiker authenticatie overslaan, en een telefoonnummer als aanmelding twee keer invullen.

Wat ik bij mijn reactie eerder niet heb vermeld,
is dat bij KPN nog een STUN-server gebruikelijk is in te zetten..
Die zou je dan nog kunnen invullen in het menu bij:   NAT  -  Network

Algemeen te gebruiken STUN-servers:

stun.l.google.com          -     poort  19302
stun.voipbuster.com      -     poort  3478
stun.voipstunt.com        -     poort  3478

En nog een hele lijst:
https://gist.github.com/mondain/b0ec1cf5f60ae726202e

Zou wel een STUN-server nemen die in Nederland opereert.
De drie bovenstaande vernoemde STUN-servers hebben voor Nederland in ieder geval ook servers in Nederland staan. Daar maakt het VOIP/SIP-account dan ook gebruik van.
(De verwijzing gaat automatisch daar naartoe).

En test alle mogelijkheden in die lijst beslist niet allemaal uit. Er komen mogelijk ook verouderde niet meer officieel gebruikte servers naar voren, die naar een ander domein verwijzen, en vervolgens weer naar beslist dubieuze hyperlinks waarmee je malware binnenhaalt. (Heb ik onlangs ondervonden).

Reputatie 7

Op een Gigaset N300A IP wordt de login als onderstaand ingevuld.

Als ik dat vertaal naar jouw screenshot dan zou t.a.v. de login alles goed ingesteld staan.

Reputatie 7
Badge +10

De instellingen van  @MarkMul  heb ik bij mezelf ook nog eens vergeleken in de Yealink W60B.  Verder enkele opvolgende tests gedaan met enkele kleine wijzigingen en wat het met die wijzigingen doet.

Daar waar  MarkMul  in zijn eerste reactie de “Display Name” leeg had,
en naar ik dacht de weergave is van hetgeen op de display van de “handsets”, wordt getoond.
Klopt bij nader inzien toch niet.
Het is hetgeen wat wordt getoond op het display bij degene die je belt.  Dus bij de ander.

Zelf heb ik bij dat veld normaal gezien mijn eigen telefoonnummer ingevuld (met +31 notatie).
Dat krijgt degenen die je belt dan te zien.

Als men men daar invult  “KPN1”, krijgt degene naar wie je belt die tekst te zien.
Je zou er dan beter je eigen naam, of bijv. die van je eigen bedrijf daar kunnen neerzetten.
(In zoverre je niet je eigen telefoonnummer zou willen ingeven).

Ik heb het getest met de tekst “zomaar een naam”.   Als je nummer nog niet in de contactlijst van de aan te roepen telefoon staat, wordt die tekst getoond.

De instellingen in de Yealink W60B:


Bij een oproep naar mijn mobiele nummer (mijn eigen nummer uit de contactlijst gehaald).
Het scherm toont de tekst “zomaar een naam”.  (Crop uit het volledige schermbeeld):


 

Als extra opmerking m.b.t. het gebruikte VOIP-account:
Zoals te zien bij de eerste schermafbeelding van de instellingen bij mijn Yealink W60B.
Staat er bij het onderdeel “Label” - Telfort
Daar heb ik namelijk ik officieel nog mijn internet account. Zoals bekend is het gewoon onderdeel van KPN, en wordt dat onderdeel als provider-naam binnen enkele maanden volledig opgeheven. (Bij mobiel is dat al zo, en heb daar nu een volledig “Mijn KPN” account).

Dat een en ander achter de schermen van dezelfde VOIP-servers en SIP-opbouw gebruik maakt,
moge duidelijk zijn uit de verdere gegevens.  Zelfs bij “Outbound Proxy server 1” de inmiddels door KPN gebruikte domeinnaam  “voip1-ext.kpn.net”  is functioneel voor “Telfort”.
Zoals te zien, is het VOIP SIP-nummer actief / geregistreerd.

Het werkt overigens ook nog als men de “oude” notatie hanteert van een proxy server IP-adres.
In mijn situatie (dat kan namelijk per regio verschillend zijn), is dat:   145.7.97.53

Opmerkelijk is overigens wel, dat ik mijn geval de instelling van een STUN-server niet nodig is.


De registratie met nog de oude schrijfwijze van de proxy-server
(en het eigen telefoonnummer voor de Display Name):

 

Reputatie 7

Of je een STUN server nodig hebt bij KPN is afhankelijk van de gebruikte router en de SIP ALG functionaliteit op die router.

Als je op de router de SIP ALG functionaliteit uit zet en een STUN server gebruikt, dan werkt het altijd.

Ok. Er is vooruitgang! Na ook wat zaken in de router te wijzigen (iets met outbound NAT) is het gelukt om het account te registeren. Echter is het nog niet gelukt om te bellen/gebeld te worden. Ik heb het account gekoppeld aan de juiste handset.  

In mijn router zit geen SIP ALG functionaliteit en ik heb zelf geen STUN server. Er is wel een plugin voor pFsense die daarbij kan helpen geloof ik, maar ik lees dat je die alleen nodig hebt in zeer specifieke gevallen. 

(Overigens zeggen deze termen mijn niets: SIP ALG en STUN: ik weet niet wat het doet en wanneer ik het wel of niet nodig heb)

Edit:

De vraag is nu waarom het bellen/gebeld worden nog niet lukt. “Het nummer is tijdelijk niet in gebruik”. Kan het zijn dat het even duurt? Ik heb niet echt een checklist van zaken die belangrijk zijn, vanwege een gebrek aan kennis op VOIP gebied. 

Ik had overigens oorspronkelijk gehoopt de ExperiaBox op een of andere manier naast mijn nieuwe router te gebruiken, puur voor telefonie. Dat is echter niet nodig, vertelde ook het Tech Team van KPN mij.

 

 

Reputatie 7
Badge +10

Als het VOIP account is geregistreerd zou bellen gewoon moeten werken.
Probeer eens te bellen met het volledige nummer inclusief de  +31  of  0031  notatie.
Het is de gebruikelijke manier om VOIP daarmee te testen. Dat zou altijd moeten werken.

Ik vermoed dat je namelijk nog helemaal niets hebt gedaan met een “Dial Plan” (bel-schema).
Een manier van instellen, dat aan de hand van de cijfers waar je mee begint om te bellen, automatisch het volledige telefoonnummer als internationale nummerreeks wordt uitgevoerd.

Of nog verder wordt aangevuld met netnummer, als je daar ook niet eens mee begint.

Internationaal bellen begint met   “+”   of  “00” gevolgd met het landnummer (31)
Een netnummer met één enkele “0” gevolgd door andere cijfers dan “0”
Een abonneenummer in de regio alles behalve een “0”

Daar kun je bel-schema’s op inregelen, toegespitst op je eigen situatie.
Verder kun je daarmee bijv. ook nummers uitsluiten (blokkeren). De Yealink heeft daar enkele menu’s voor om in te regelen, die anders zijn dan met wat je vindt op bijv. een Grandstream of Cisco ATA-adapter. Elk merk heeft zo wel zijn eigen manier daarvoor.
Bij de Yealink relatief makkelijk in te stellen, omdat ze wat intuïtiever de menu’s hebben opgesteld. Te vinden onder het menu bovenaan bij “Settings”, dan linkerkant “Dial Plan”.

Test het eerst eens uit met bellen volgens een internationale nummerreeks invoermethode.
Dan geef ik in een vervolgreactie voorbeelden over het in te voeren “Dial Plan”.

Ik zal dinsdag a.s. zelf weer op deze bewuste locatie zijn en ga ik zelf verder proberen te bellen en gebeld te worden. Bedankt voor alle hulp tot zover! Ik houd jullie op de hoogte. 

Reputatie 7

Gaat de telefoon wel over als je gebeld wordt?

Staat SIP ALG uit op de router?

Welke codecs heb je ingesteld staan?

De telefoon gaat niet over en er is geen kiestoon. 

SIP ALG functionaliteit is standaard niet beschikbaar op mijn router. Wel is er evt een plugin te downloaden die iets met een proxy doet:

Someone has made a siproxd proxy package for pfSense, but it's something that would need to be knowingly installed.

 

De standaard Yealink codecs staan aan:

G722
PCMU
PCMA
G729

Onderstaand lijstje is evt. nog beschikbaar. 

Nog beschikbare codecs

 

Reputatie 7
Badge +10

De standaard Yealink codecs staan aan:

Dat gaat voor het KPN VOIP account helaas niet lukken.

Alleen:

  1.  PCMA
  2.  PCMU

Afhankelijk van type router zou je nog kunnen proberen:
(Bij mij lukt dat niet)

  1.  G722
  2.  PCMA
  3.  PCMU

Als alternatief als het er slechts twee mogen zijn:

  1.  G722
  2.  PCMA


Bij drie andere VOIP providers kan ik wel meerdere codecs gebruiken:

  1.  G722
  2.  Opus
  3.  PCMA
  4.  PCMU
  5.  G729


Zou overigens altijd even controleren of er nog een firmware update is geweest.
Zowel voor het DECT basis station, als de handsets (zijn aparte firmware versies).
http://support.yealink.com/documentFront/forwardToDocumentDetailPage?documentId=206

Reputatie 7

Ik gebruik op mijn Gigaset N300A IP

 

Reputatie 7
Badge +10

@MarkMul  ben je er inmiddels uitgekomen? Niets meer van je vernomen of het is gelukt.
(Vaak een aanwijzing dat het probleem is opgelost).

Ik ben er helaas nog niet uit @Babylonia.

  • De telefoon staat nu als ‘Registered’
  • Telefoon 1 is toegewezen aan account/lijn 1 (er is maar 1 tel. en 1 lijn)
  • Dial plan van lijn 1 ook al ingesteld om prefix 0 te vervangen door 0031
  • Codecs: PCMA en PCMU actief (komt denk ik overeen met G711a en G711µ)
  • Ook het bellen naar +31 of 0031 nummers werkt niet: geen toon.
  • Gebeld worden “dit nummer is tijdelijk buiten gebruik” 

Ik heb een sterk vermoeden dat de rest van het probleem zich afspeelt in de router. Ik weet alleen nog niet waar. De router is een pfSense (netgate) box die rechtstreeks aan de ethernetaansluiting van het glasvezelkastje hangt. 

Mijn volgende doel is om de telefoon (tijdelijk) in een DMZ te zetten om de router uit te sluiten. Maar dat is met pfSense iets meer werk dan ik dacht. (nieuwe interface + vlan aanmaken met specifieke firewall regels). Dit moet daarom nog. 

 

Reputatie 7
  • Ook het bellen naar +31 of 0031 nummers werkt niet: geen toon.
  • Gebeld worden “dit nummer is tijdelijk buiten gebruik” 

Dan is de kans groot dat je een STUN server moet gebruiken en daarbij moet de SIP functionaliteit op die pfSense uit staan.

Reputatie 7
Badge +10

Activeren van een STUN-server zou mogelijk inderdaad de oplossing kunnen zijn?

Zelf maak ik o.a. gebruik van 3CX softphone op een laptop, met daarin mijn VOIP/SIP accounts. Ongeacht waar ik ben kan ik daar mee uitbellen (en telefoongesprekken ontvangen). Uiteraard zijn er nergens instellingen in een router specifiek aangepast aan mijn situatie. Toch werkt het.

Naar ik vermoed omdat standaard in de 3CX softphone een STUN-server is ingesteld?
Die kun je niet eens uitschakelen. Leegmaken van het veld, wordt die weer ingevuld.
Je kunt hooguit een andere server kiezen. (Andere benaming geven dan die van 3CX zelf).

Overigens niet met een KPN VOIP/SIP account, want die is gebonden aan een KPN netwerk. Werkt wel met VOIP van CheapConnect, en uitbel accounts van Voipbuster en PowerVoip.

Hi @Babylonia en @wjb,


Nogmaals veel dank voor jullie toewijding. Ik heb informatie gevonden over pfSense dat er geen SIP functionaliteit is ingebouwd en dat staat dus altijd uit. 

Ik zou echter wel wat hulp kunnen gebruiken voor een STUN server. Want daar heb ik 0,0 ervaring mee: 

  • Moet ik een externe server gebruiken?
  • Zo ja, hoe zorg ik ervoor dat belverkeer via de STUN server loopt
  • Wat doet een STUN server eigenlijk? :P
Reputatie 7
Badge +10

Eerder hierboven in het onderwerp benoem ik een paar STUN-servers.

Eentje ervan zou je kunnen invullen, met de poort die erbij hoort.

Invullen bij deze pagina van de Yealink gebruikersinterface (en activeren):
 

 

Wat een STUN-server doet, zie uitleg bij 3CX:
https://www.3cx.nl/voip-sip/stun-server/

Ik heb een W52, maar krijg hem niet geregistreerd.

Kan het zijn dat je eerst een VLAN7 moet aanmaken met je router?
 

Reageer