Welkom op het

KPN Forum

Recent online

Gebruik een eigen router i.p.v. de Experia Box


Reputatie 7
  • wjb
  • 23258 reacties
Wil je om wat voor een reden dan ook af van de Experia Box, vervang deze dan door een eigen router. Voor glasvezelabonnees is dat vandaag de dag mogelijk, al kan het best een uitdaging zijn om een eigen router zo te configureren dat deze goed overweg kan met het iTV platform van KPN.
Randvoorwaarde is wel dat je voor telefonie de Experia Box helaas nog altijd als een "veredelde" telefoonadapter in jouw netwerk moet opnemen. Ik hoop echter dat KPN op korte termijn met een alternatief zal komen.

Met dit topic hoop ik dat wij als abonnees van KPN elkaar kunnen helpen met het configureren van een eigen router.

LET OP: Het onderstaande zal helaas al snel een vrij hoog technisch gehalte gaan krijgen waardoor het voor velen best lastig te volgen zou kunnen zijn. Toch hoop ik dat uiteindelijk in dit topic goede en begrijpelijke handleidingen zullen ontstaan waardoor ook de minder technisch aangelegde abonnee in staat zal zijn zijn/haar eigen router te gebruiken.
Mocht je denken ... dit gaat me toch echt mijn pet te boven ... dan is wellicht het volgende topic iets voor jou: Gebruik een eigen router achter de Experia Box.

Wees je er overigens terdege van bewust dat lang niet elke router geschikt is om de Experia Box te vervangen. Met name de configuratie van het iTV gedeelte kan nog wel eens een spelbreker blijken te zijn. Gelukkig zijn er echter ook routers te vinden waarmee de Experia Box wel succesvol vervangen kan worden.
Zelf heb ik een Ubiquiti EdgeRouter Lite 3 ingezet om de Experia Box te vervangen en alle tests verlopen tot nu toe succesvol. Deze router heeft geen ingebouwde wifi, maar daarvoor gebruik ik losse WiFi accesspoints zoals de EDIMAX CAP1200, de KPN WiFi "versterker", de Experia wiFi of bijvoorbeeld de Ubiquiti Unifi AP AC PRO.
Onderstaand een screenshot van het dashboard van mijn EdgeRouter Lite 3 waarin zichtbaar is dat deze een (pppoe) verbinding opgebouwd heeft met het KPN netwerk op vlan 6, dat het IPTV op vlan 4 operationeel is en dat de telefoon op vlan 7 actief is.

Ik hoop dat voor een aantal geschikte routers configuratie tutorials geschreven gaan worden die we dan hier op kunnen nemen.

Configuratie tutorials
Ubiquiti EdgeRouter Lite 3
Met behulp van de onderstaande configuratie opdrachten zal de EdgeRouter Lite 3 geconfigureerd worden voor gebruik op het KPN netwerk.
De opdrachten in de code blokken kunnen eenvoudig met copy-paste naar een telnet of ssh sessie gekopieerd worden en uitgevoerd worden.

Configureer de Firewall zodat inkomend alles geblokkeerd wordt.
code:

configure

delete firewall

set firewall all-ping enable
set firewall broadcast-ping disable
set firewall ipv6-receive-redirects disable
set firewall ipv6-src-route disable
set firewall ip-src-route disable
set firewall log-martians enable
set firewall receive-redirects disable
set firewall send-redirects enable
set firewall source-validation disable
set firewall syn-cookies enable

set firewall ipv6-name WANv6_IN default-action drop
set firewall ipv6-name WANv6_IN description 'WAN IPv6 naar Intern'
set firewall ipv6-name WANv6_IN enable-default-log
set firewall ipv6-name WANv6_IN rule 10 action accept
set firewall ipv6-name WANv6_IN rule 10 description 'Allow established/related'
set firewall ipv6-name WANv6_IN rule 10 state established enable
set firewall ipv6-name WANv6_IN rule 10 state related enable
set firewall ipv6-name WANv6_IN rule 20 action drop
set firewall ipv6-name WANv6_IN rule 20 description 'Drop invalid state'
set firewall ipv6-name WANv6_IN rule 20 state invalid enable

set firewall ipv6-name WANv6_LOCAL default-action drop
set firewall ipv6-name WANv6_LOCAL description 'WAN IPv6 naar Router'
set firewall ipv6-name WANv6_LOCAL enable-default-log
set firewall ipv6-name WANv6_LOCAL rule 10 action accept
set firewall ipv6-name WANv6_LOCAL rule 10 description 'Allow established/related'
set firewall ipv6-name WANv6_LOCAL rule 10 state established enable
set firewall ipv6-name WANv6_LOCAL rule 10 state related enable
set firewall ipv6-name WANv6_LOCAL rule 20 action drop
set firewall ipv6-name WANv6_LOCAL rule 20 description 'Drop invalid state'
set firewall ipv6-name WANv6_LOCAL rule 20 state invalid enable
set firewall ipv6-name WANv6_LOCAL rule 30 action accept
set firewall ipv6-name WANv6_LOCAL rule 30 description 'Allow IPv6 icmp'
set firewall ipv6-name WANv6_LOCAL rule 30 protocol ipv6-icmp
set firewall ipv6-name WANv6_LOCAL rule 30 source
set firewall ipv6-name WANv6_LOCAL rule 40 action accept
set firewall ipv6-name WANv6_LOCAL rule 40 description 'allow dhcpv6'
set firewall ipv6-name WANv6_LOCAL rule 40 destination port 546
set firewall ipv6-name WANv6_LOCAL rule 40 protocol udp
set firewall ipv6-name WANv6_LOCAL rule 40 source port 547

set firewall name WAN_IN default-action drop
set firewall name WAN_IN description 'WAN naar Intern'
set firewall name WAN_IN enable-default-log
set firewall name WAN_IN rule 10 action accept
set firewall name WAN_IN rule 10 description 'Allow established/related'
set firewall name WAN_IN rule 10 log enable
set firewall name WAN_IN rule 10 protocol all
set firewall name WAN_IN rule 10 state established enable
set firewall name WAN_IN rule 10 state related enable
set firewall name WAN_IN rule 20 action drop
set firewall name WAN_IN rule 20 description 'Drop invalid state'
set firewall name WAN_IN rule 20 log enable
set firewall name WAN_IN rule 20 protocol all
set firewall name WAN_IN rule 20 state invalid enable

set firewall name WAN_LOCAL default-action drop
set firewall name WAN_LOCAL description 'WAN naar Router'
set firewall name WAN_LOCAL enable-default-log
set firewall name WAN_LOCAL rule 10 action accept
set firewall name WAN_LOCAL rule 10 description 'Allow established/related'
set firewall name WAN_LOCAL rule 10 log disable
set firewall name WAN_LOCAL rule 10 protocol all
set firewall name WAN_LOCAL rule 10 state established enable
set firewall name WAN_LOCAL rule 10 state invalid disable
set firewall name WAN_LOCAL rule 10 state new disable
set firewall name WAN_LOCAL rule 10 state related enable

set firewall name WAN_LOCAL rule 20 action drop
set firewall name WAN_LOCAL rule 20 description 'Drop invalid state'
set firewall name WAN_LOCAL rule 20 log disable
set firewall name WAN_LOCAL rule 20 protocol all
set firewall name WAN_LOCAL rule 20 state established disable
set firewall name WAN_LOCAL rule 20 state invalid enable
set firewall name WAN_LOCAL rule 20 state new disable
set firewall name WAN_LOCAL rule 20 state related disable

commit
save
exit

Configureer de interfaces.
Op ethernet poort 0 wordt de NTU (glasvezelmodem) aangesloten.
Op ethernet poort 1 wordt de switch voor het interne netwerk aangesloten.
Op ethernet poort 2 wordt, indien van toepassing, de Experia Box aangesloten voor telefonie.
LET OP: Vervang in de regel "set interfaces ethernet eth0 vif 6 pppoe 0 user-id XX-XX-XX-XX-XX-XX@internet" XX-XX-XX-XX-XX-XX door het MAC adres van ethernet poort 0.
Dit MAC adres kan je met de onderstaande commando's achterhalen.
code:

sudo su
mac_address=$(ifconfig | grep -m 1 eth0 | awk '{print $5}' | awk -F':' '{print ""$1"-"$2"-"$3"-"$4"-"$5"-"$6""}')
echo "$mac_address"
exit


LET OP: In het volgende blok moeten de dubbele quotes vervangen worden door de tekst &-quot; maar dan zonder het minteken (-). Helaas wordt die tekst (&-quot; zonder de -) hier op de site vervangen door een echte quote, maar bij het doorvoeren van het commando leidt dat tot een foutmelding.
De regel waar het om gaat moet er dus als onderstaand uit gaan zien.

code:

configureren

delete interfaces

set interfaces bridge br0 aging 300
set interfaces bridge br0 bridged-conntrack disable
set interfaces bridge br0 description 'KPN Telefonie'
set interfaces bridge br0 hello-time 2
set interfaces bridge br0 max-age 20
set interfaces bridge br0 priority 32768
set interfaces bridge br0 promiscuous disable
set interfaces bridge br0 stp false

set interfaces ethernet eth0 description FTTH
set interfaces ethernet eth0 duplex auto
set interfaces ethernet eth0 mtu 1508
set interfaces ethernet eth0 speed auto

set interfaces ethernet eth0 vif 4 address dhcp
set interfaces ethernet eth0 vif 4 description 'KPN IPTV'
set interfaces ethernet eth0 vif 4 dhcp-options client-option 'send vendor-class-identifier "IPTV_RG";'
set interfaces ethernet eth0 vif 4 dhcp-options client-option 'request subnet-mask, routers, rfc3442-classless-static-routes;'
set interfaces ethernet eth0 vif 4 dhcp-options default-route no-update
set interfaces ethernet eth0 vif 4 dhcp-options default-route-distance 210
set interfaces ethernet eth0 vif 4 dhcp-options name-server update

set interfaces ethernet eth0 vif 6 description 'KPN Internet'
set interfaces ethernet eth0 vif 6 mtu 1508
set interfaces ethernet eth0 vif 6 pppoe 0 default-route auto
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd pd 0 interface eth1 prefix-id ':1'
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd pd 0 interface eth1 service slaac
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd pd 0 prefix-length /48
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd rapid-commit enable
set interfaces ethernet eth0 vif 6 pppoe 0 firewall in ipv6-name WANv6_IN
set interfaces ethernet eth0 vif 6 pppoe 0 firewall in name WAN_IN
set interfaces ethernet eth0 vif 6 pppoe 0 firewall local ipv6-name WANv6_LOCAL
set interfaces ethernet eth0 vif 6 pppoe 0 firewall local name WAN_LOCAL
set interfaces ethernet eth0 vif 6 pppoe 0 idle-timeout 180
set interfaces ethernet eth0 vif 6 pppoe 0 ipv6 address autoconf
set interfaces ethernet eth0 vif 6 pppoe 0 ipv6 dup-addr-detect-transmits 1
set interfaces ethernet eth0 vif 6 pppoe 0 ipv6 enable
set interfaces ethernet eth0 vif 6 pppoe 0 mtu 1500
set interfaces ethernet eth0 vif 6 pppoe 0 name-server auto
set interfaces ethernet eth0 vif 6 pppoe 0 password kpn
set interfaces ethernet eth0 vif 6 pppoe 0 user-id XX-XX-XX-XX-XX-XX@internet

set interfaces ethernet eth0 vif 7 bridge-group bridge br0
set interfaces ethernet eth0 vif 7 description 'KPN Telefonie'
set interfaces ethernet eth0 vif 7 mtu 1500

set interfaces ethernet eth1 address 192.168.2.254/24
set interfaces ethernet eth1 description 'Thuis netwerk'
set interfaces ethernet eth1 duplex auto
set interfaces ethernet eth1 speed auto

set interfaces ethernet eth1 ipv6 dup-addr-detect-transmits 1
set interfaces ethernet eth1 ipv6 router-advert cur-hop-limit 64
set interfaces ethernet eth1 ipv6 router-advert link-mtu 0
set interfaces ethernet eth1 ipv6 router-advert managed-flag false
set interfaces ethernet eth1 ipv6 router-advert max-interval 600
set interfaces ethernet eth1 ipv6 router-advert name-server '2a02:a47f:e000::53'
set interfaces ethernet eth1 ipv6 router-advert name-server '2a02:a47f:e000::54'
set interfaces ethernet eth1 ipv6 router-advert other-config-flag false
set interfaces ethernet eth1 ipv6 router-advert prefix '::/64' autonomous-flag true
set interfaces ethernet eth1 ipv6 router-advert prefix '::/64' on-link-flag true
set interfaces ethernet eth1 ipv6 router-advert prefix '::/64' valid-lifetime 2592000
set interfaces ethernet eth1 ipv6 router-advert radvd-options 'RDNSS 2a02:a47f:e000::53 2a02:a47f:e000::54 {};'
set interfaces ethernet eth1 ipv6 router-advert reachable-time 0
set interfaces ethernet eth1 ipv6 router-advert retrans-timer 0
set interfaces ethernet eth1 ipv6 router-advert send-advert true

set interfaces ethernet eth2 description 'KPN Experia Box'
set interfaces ethernet eth2 duplex auto
set interfaces ethernet eth2 speed auto
set interfaces ethernet eth2 vif 7 bridge-group bridge br0
set interfaces ethernet eth2 vif 7 description 'KPN Telefonie'
set interfaces ethernet eth2 vif 7 mtu 1500

set interfaces loopback lo

commit
save
exit

Configureer de IGMP proxy server t.b.v. IPTV.
code:

configure

delete protocols

set protocols igmp-proxy disable-quickleave
set protocols igmp-proxy interface eth0.4 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth0.4 role upstream
set protocols igmp-proxy interface eth0.4 threshold 1
set protocols igmp-proxy interface eth1 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth1 role downstream
set protocols igmp-proxy interface eth1 threshold 1
set protocols static interface-route6 '::/0' next-hop-interface pppoe

commit
save
exit

Configureer de DHCP server, dns services en NAT regels.
Tevens wordt hier ingesteld dat de EdgeRouter zowel via ssh als via telnet benaderd kan (blijven) worden. Je doet er verstandig aan om na een succesvolle configuratie deze allebei uit te zetten via de beheerpagina van de EdgeRouter op http://192.168.2.254 (tabblad "Config tree").
code:

configure

delete service

set service dhcp-server disabled false
set service dhcp-server global-parameters 'option vendor-class-identifier code 60 = string;'
set service dhcp-server global-parameters 'option broadcast-address code 28 = ip-address;'
set service dhcp-server hostfile-update disable
set service dhcp-server shared-network-name Thuis authoritative enable
set service dhcp-server shared-network-name Thuis subnet 192.168.2.0/24 default-router 192.168.2.254
set service dhcp-server shared-network-name Thuis subnet 192.168.2.0/24 dns-server 192.168.2.254
set service dhcp-server shared-network-name Thuis subnet 192.168.2.0/24 domain-name Thuis
set service dhcp-server shared-network-name Thuis subnet 192.168.2.0/24 lease 86400
set service dhcp-server shared-network-name Thuis subnet 192.168.2.0/24 start 192.168.2.1 stop 192.168.2.200
set service dhcp-server static-arp disable
set service dhcp-server use-dnsmasq disable

set service dns forwarding cache-size 4000
set service dns forwarding listen-on eth1
set service dns forwarding name-server 195.121.1.34
set service dns forwarding name-server 195.121.1.66
set service dns forwarding name-server '2a02:a47f:e000::53'
set service dns forwarding name-server '2a02:a47f:e000::54'
set service dns forwarding options listen-address=192.168.2.254

set service gui http-port 80
set service gui https-port 443
set service gui older-ciphers enable

set service nat rule 5000 description IPTV
set service nat rule 5000 destination address 213.75.112.0/21
set service nat rule 5000 log disable
set service nat rule 5000 outbound-interface eth0.4
set service nat rule 5000 protocol all
set service nat rule 5000 type masquerade

set service nat rule 5010 description 'KPN Internet'
set service nat rule 5010 log disable
set service nat rule 5010 outbound-interface pppoe0
set service nat rule 5010 protocol all
set service nat rule 5010 type masquerade

set service ssh
set service telnet port 23
set service unms disable

commit
save
exit

Configureer de systeem instellingen zoals login, dns servers en ntp servers.
De login is Admin met wachtwoord Admin. Uiteraard moet je deze direct na configuratie zelf wel even aanpassen.
code:

configure

delete system

set system domain-name Thuis
set system host-name Thuis
set system login user Admin authentication encrypted-password '$6$AA4wzrDs$yCVKfo/Y30KjIWKD6NTfVo0Ia/WJ8zZMQr4mCm5nyonQ95l.fDhZcZfcrdGumcFXv3NKBbFeYyvKP.YqdMkEN/'
set system login user Admin level admin
set system name-server 127.0.0.1
set system ntp server 0.nl.pool.ntp.org
set system ntp server 1.nl.pool.ntp.org
set system ntp server ntp0.nl.net
set system ntp server ntp1.nl.net
set system ntp server time.kpn.net

set system offload hwnat disable
set system offload ipsec enable
set system offload ipv4 forwarding enable
set system offload ipv4 pppoe enable
set system offload ipv4 vlan enable
set system offload ipv6 forwarding enable
set system offload ipv6 pppoe enable

set system syslog global facility all level notice
set system syslog global facility protocols level debug

set system time-zone Europe/Amsterdam

commit
save
exit


Ubiquiti EdgeRouter X

Ubiquiti UniFi Security Gateway
To do....
Wie heeft er een UniFi Security Gateway draaien en wil zijn/haar configuratie hier met ons delen?

34 Reacties

Reputatie 1
/volg!

Mooi werk! Ik hou het in de gaten!
Reputatie 7
De site KRIEGSMAN.io biedt en behoorlijk goede tutorial voor het configureren van een Ubiquiti EdgeRouter Lite.
Reputatie 7
De tests t.a.v. Internet, IPTV en telefonie zijn succesvol verlopen en de EdgeRouter is klaar om de rol van de Experia Box over te nemen.
Speedtests geven aan dat ik zowel bekabeld als via wifi de volledige snelheid van mijn glasvezel internetverbinding haal.

Vanavond een avondje proefdraaien om te zien of alles een beetje vloeiend loopt, maar tot nu toe ziet het er veel belovend uit.
Reputatie 7
De avond is probleemloos verlopen. Zowel Internet als televisie storingsvrij.
Alle port-forwardings naar services op het eigen netwerk (beveiligingscamera's, NAS, webserver, etc.) zijn ook up and running.
Het initiëren van een site-2-site VPN tunnel vanuit thuis naar kantoor was succesvol.
Straks controleren of het initiëren van een site-2-site VPN tunnel vanuit kantoor naar thuis ook succesvol is.
Reputatie 7
Ook het initiëren van een site-2-site VPN tunnel vanuit kantoor naar thuis is succesvol verlopen.
Dat betekent dat ik ook definitief afscheid heb genomen van mijn Cisco RV180W VPN firewall die als tweede router achter de Experia Box stond voor mijn zakelijk netwerk.
Ik ga dit topic in de gaten houden!
Al langere tijd aan het uitzoeken hoe ik de experiabox kan vervangen (gebruik geen telefonie).
Doel is om het servernetwerk(nu een Netgear GS716T switch, misschien later een Unifi 16/24 poorts switch (geen PoE)) en thuis netwerk(Unifi switch) te scheiden.

Afgelopen week unifi spullen gekocht (USG, AC Lite + AC Pro, 8p switch(voor thuisnetwerk) en de controller). Ook nog via via een Edgerouter Lite gekregen, dus even kijken of ik de USG of de Edgerouter ga gebruiken.
Reputatie 7
Voor het configureren van een USG zou de GitHub van Bas Meerman een goede bron kunnen zijn.
Voor het configureren van een EdgeRouter Lite 3 is de site KRIEGSMAN.io een goede bron.
Zelf heb ik veel aan de laatste site gehad om de basisinrichting voor elkaar te krijgen.

Ik wil lezers wel waarschuwen dat het inrichten van een Ubiquiti router echt geen sinecure is en dat accuratesse en technische affiniteit absoluut vereist zijn om de configuratie tot een goed einde te brengen. Ik ben nog aan het nadenken hoe ik de door mij opgedane kennis hier op een dusdanige manier kan delen dat dit eenvoudig te begrijpen is.
Reputatie 1
wjb schreef:

Voor het configureren van een USG zou de GitHub van Bas Meerman een goede bron kunnen zijn.
Voor het configureren van een EdgeRouter Lite 3 is de site KRIEGSMAN.io een goede bron.
Zelf heb ik veel aan de laatste site gehad om de basisinrichting voor elkaar te krijgen.

Ik wil lezers wel waarschuwen dat het inrichten van een Ubiquiti router echt geen sinecure is en dat accuratesse en technische affiniteit absoluut vereist zijn om de configuratie tot een goed einde te brengen. Ik ben nog aan het nadenken hoe ik de door mij opgedane kennis hier op een dusdanige manier kan delen dat dit eenvoudig te begrijpen is.



Je mag langskomen hoor, koffie staat klaar 😉
Reputatie 7
Op de site KRIEGSMAN.io wordt de onderstaande static route aangemaakt om het iTV platform te kunnen benaderen.

code:

route 213.75.112.0/21 {
next-hop [ROUTER-IP] {
}
}


Hierbij moet [ROUTER-IP] vervangen worden door het adres van de KPN router op vlan 4 waarmee de eigen router in verbinding moet staan om het iTV platform te kunnen benaderen.
Dit IP adres kan wijzigen als de verbinding met het iTV platform om wat voor reden dan ook een keer verbroken wordt. Vandaar dat KRIEGSMAN.io bovenaan de pagina ook spreekt over een script om het ROUTER-IP adres voor die static route automatisch aan te passen.

Dit is echter niet (meer) nodig, de EdgeRouter maakt (tegenwoordig) zelf automatisch een (kernel) route aan op basis van de onderstaande NAT rule waar de IP adressen voor het iTV platform aan vlan 4 gekoppeld worden.

code:

rule 5000 {
description IPTV
destination {
address 213.75.112.0/21
}
log disable
outbound-interface eth0.4
protocol all
source {
}
type masquerade
}


De eerder genoemde static route hoeft dus niet (meer) opgenomen te worden en daarmee is het script dus ook niet (meer) benodigd.

Dat vereenvoudigt de configuratie aanzienlijk.

Ook is de installatie van de system repository wheezy niet nodig en mag dus rustig overgeslagen worden. Mijn motto in deze is ... hoe minder hoe beter.
Reputatie 7
KRIEGSMAN.io configureert de servers van Google voor DNS. Persoonlijk ben ik, i.v.m. privacy, geen voorstander van het gebruik van de DNS servers van Google.
Uiteraard kan je ook andere DNS servers instellen. Vervang dan de IP adressen in de onderstaande regels door de IP adressen van de te gebruiken DNS servers.

IPv4:
set system name-server 8.8.8.8
set system name-server 8.8.4.4
IPv6:
set system name-server 2001:4860:4860::8888
set system name-server 2001:4860:4860::8844
Reputatie 2
Zeer interessant topic en mooi om te lezen dat een en ander succesvol is omgezet naar een snelle en stabiele verbinding.
Heb zelf ook nog eens op dit onderwerp gezocht op het internet en kwam daar deze blog tegen waarin ook informatie uit verschillende bronnen is samengevat in een werkende oplossing.

Ben benieuwd of je nog de tijd vindt om de openings post aan te passen met de configuratie bestanden en een duidelijke uitleg daarbij waarom je juist die keuzes maakt. Hierin kan je dan ook de replay posts verwerken en ontstaat een nette levende handleiding voor en door mede forum gebruikers. @wjb👌🏻
Reputatie 7
Ik heb de configuratie opdrachten voor een EdgeRouter Lite 3 in het openingsbericht opgenomen.
Wie o wie gaat ons helpen aan een werkende configuratie voor de EdgeRouter X en de UniFi Security Gateway.
Reputatie 7
Woutertjuh1988 schreef:

Afgelopen week unifi spullen gekocht (USG, AC Lite + AC Pro, 8p switch(voor thuisnetwerk) en de controller). Ook nog via via een Edgerouter Lite gekregen, dus even kijken of ik de USG of de Edgerouter ga gebruiken.

Reputatie 7
Ik heb de onderstaande configuratie voor een EdgeRouter X niet kunnen testen omdat ik geen EdgeRouter X heb, maar theoretisch zou deze moeten werken.
Wie o wie wil dat uitproberen?

Configuratie tutorial Ubiquiti EdgeRouter X
Met behulp van de onderstaande configuratie opdrachten zal de EdgeRouter X geconfigureerd worden voor gebruik op het KPN netwerk.
De opdrachten in de code blokken kunnen eenvoudig met copy-paste naar een telnet of ssh sessie gekopieerd worden en uitgevoerd worden.

Configureer de Firewall zodat inkomend alles geblokkeerd wordt.
code:

configure

delete firewall

set firewall all-ping enable
set firewall broadcast-ping disable
set firewall ipv6-receive-redirects disable
set firewall ipv6-src-route disable
set firewall ip-src-route disable
set firewall log-martians enable
set firewall receive-redirects disable
set firewall send-redirects enable
set firewall source-validation disable
set firewall syn-cookies enable

set firewall ipv6-name WANv6_IN default-action drop
set firewall ipv6-name WANv6_IN description 'WAN IPv6 naar Intern'
set firewall ipv6-name WANv6_IN enable-default-log
set firewall ipv6-name WANv6_IN rule 10 action accept
set firewall ipv6-name WANv6_IN rule 10 description 'Allow established/related'
set firewall ipv6-name WANv6_IN rule 10 state established enable
set firewall ipv6-name WANv6_IN rule 10 state related enable
set firewall ipv6-name WANv6_IN rule 20 action drop
set firewall ipv6-name WANv6_IN rule 20 description 'Drop invalid state'
set firewall ipv6-name WANv6_IN rule 20 state invalid enable

set firewall ipv6-name WANv6_LOCAL default-action drop
set firewall ipv6-name WANv6_LOCAL description 'WAN IPv6 naar Router'
set firewall ipv6-name WANv6_LOCAL enable-default-log
set firewall ipv6-name WANv6_LOCAL rule 10 action accept
set firewall ipv6-name WANv6_LOCAL rule 10 description 'Allow established/related'
set firewall ipv6-name WANv6_LOCAL rule 10 state established enable
set firewall ipv6-name WANv6_LOCAL rule 10 state related enable
set firewall ipv6-name WANv6_LOCAL rule 20 action drop
set firewall ipv6-name WANv6_LOCAL rule 20 description 'Drop invalid state'
set firewall ipv6-name WANv6_LOCAL rule 20 state invalid enable
set firewall ipv6-name WANv6_LOCAL rule 30 action accept
set firewall ipv6-name WANv6_LOCAL rule 30 description 'Allow IPv6 icmp'
set firewall ipv6-name WANv6_LOCAL rule 30 protocol ipv6-icmp
set firewall ipv6-name WANv6_LOCAL rule 30 source
set firewall ipv6-name WANv6_LOCAL rule 40 action accept
set firewall ipv6-name WANv6_LOCAL rule 40 description 'allow dhcpv6'
set firewall ipv6-name WANv6_LOCAL rule 40 destination port 546
set firewall ipv6-name WANv6_LOCAL rule 40 protocol udp
set firewall ipv6-name WANv6_LOCAL rule 40 source port 547

set firewall name WAN_IN default-action drop
set firewall name WAN_IN description 'WAN naar Intern'
set firewall name WAN_IN enable-default-log
set firewall name WAN_IN rule 10 action accept
set firewall name WAN_IN rule 10 description 'Allow established/related'
set firewall name WAN_IN rule 10 log enable
set firewall name WAN_IN rule 10 protocol all
set firewall name WAN_IN rule 10 state established enable
set firewall name WAN_IN rule 10 state related enable
set firewall name WAN_IN rule 20 action drop
set firewall name WAN_IN rule 20 description 'Drop invalid state'
set firewall name WAN_IN rule 20 log enable
set firewall name WAN_IN rule 20 protocol all
set firewall name WAN_IN rule 20 state invalid enable

set firewall name WAN_LOCAL default-action drop
set firewall name WAN_LOCAL description 'WAN naar Router'
set firewall name WAN_LOCAL enable-default-log
set firewall name WAN_LOCAL rule 10 action accept
set firewall name WAN_LOCAL rule 10 description 'Allow established/related'
set firewall name WAN_LOCAL rule 10 log disable
set firewall name WAN_LOCAL rule 10 protocol all
set firewall name WAN_LOCAL rule 10 state established enable
set firewall name WAN_LOCAL rule 10 state invalid disable
set firewall name WAN_LOCAL rule 10 state new disable
set firewall name WAN_LOCAL rule 10 state related enable

set firewall name WAN_LOCAL rule 20 action drop
set firewall name WAN_LOCAL rule 20 description 'Drop invalid state'
set firewall name WAN_LOCAL rule 20 log disable
set firewall name WAN_LOCAL rule 20 protocol all
set firewall name WAN_LOCAL rule 20 state established disable
set firewall name WAN_LOCAL rule 20 state invalid enable
set firewall name WAN_LOCAL rule 20 state new disable
set firewall name WAN_LOCAL rule 20 state related disable

commit
save
exit

Configureer de interfaces.
Op ethernet poort 0 wordt de NTU (glasvezelmodem) aangesloten.
Ethernet poort 1, 2 en 3 zijn voor het interne netwerk.
Op ethernet poort 4 wordt, indien van toepassing, de Experia Box aangesloten voor telefonie.
LET OP: Vervang in de regel "set interfaces ethernet eth0 vif 6 pppoe 0 user-id XX-XX-XX-XX-XX-XX@internet" XX-XX-XX-XX-XX-XX door het MAC adres van ethernet poort 0.
Dit MAC adres kan je met de onderstaande commando's achterhalen.
code:

sudo su
mac_address=$(ifconfig | grep -m 1 eth0 | awk '{print $5}' | awk -F':' '{print ""$1"-"$2"-"$3"-"$4"-"$5"-"$6""}')
echo "$mac_address"
exit


LET OP: In het volgende blok moeten de dubbele quotes vervangen worden door de tekst &-quot; maar dan zonder het minteken (-). Helaas wordt die tekst (&-quot; zonder de -) hier op de site vervangen door een echte quote, maar bij het doorvoeren van het commando leidt dat tot een foutmelding.
De regel waar het om gaat moet er dus als onderstaand uit gaan zien.

code:

configure

delete interfaces

set interfaces bridge br0 aging 300
set interfaces bridge br0 bridged-conntrack disable
set interfaces bridge br0 description 'KPN Telefonie'
set interfaces bridge br0 hello-time 2
set interfaces bridge br0 max-age 20
set interfaces bridge br0 priority 32768
set interfaces bridge br0 promiscuous disable
set interfaces bridge br0 stp false

set interfaces ethernet eth0 description FTTH
set interfaces ethernet eth0 duplex auto
set interfaces ethernet eth0 mtu 1508
set interfaces ethernet eth0 speed auto

set interfaces ethernet eth0 vif 4 address dhcp
set interfaces ethernet eth0 vif 4 description 'KPN IPTV'
set interfaces ethernet eth0 vif 4 dhcp-options client-option 'send vendor-class-identifier "IPTV_RG";'
set interfaces ethernet eth0 vif 4 dhcp-options client-option 'request subnet-mask, routers, rfc3442-classless-static-routes;'
set interfaces ethernet eth0 vif 4 dhcp-options default-route no-update
set interfaces ethernet eth0 vif 4 dhcp-options default-route-distance 210
set interfaces ethernet eth0 vif 4 dhcp-options name-server update

set interfaces ethernet eth0 vif 6 description 'KPN Internet'
set interfaces ethernet eth0 vif 6 mtu 1508
set interfaces ethernet eth0 vif 6 pppoe 0 default-route auto
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd pd 0 interface eth1 prefix-id ':1'
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd pd 0 interface eth1 service slaac
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd pd 0 prefix-length /48
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd rapid-commit enable
set interfaces ethernet eth0 vif 6 pppoe 0 firewall in ipv6-name WANv6_IN
set interfaces ethernet eth0 vif 6 pppoe 0 firewall in name WAN_IN
set interfaces ethernet eth0 vif 6 pppoe 0 firewall local ipv6-name WANv6_LOCAL
set interfaces ethernet eth0 vif 6 pppoe 0 firewall local name WAN_LOCAL
set interfaces ethernet eth0 vif 6 pppoe 0 idle-timeout 180
set interfaces ethernet eth0 vif 6 pppoe 0 ipv6 address autoconf
set interfaces ethernet eth0 vif 6 pppoe 0 ipv6 dup-addr-detect-transmits 1
set interfaces ethernet eth0 vif 6 pppoe 0 ipv6 enable
set interfaces ethernet eth0 vif 6 pppoe 0 mtu 1500
set interfaces ethernet eth0 vif 6 pppoe 0 name-server auto
set interfaces ethernet eth0 vif 6 pppoe 0 password kpn
set interfaces ethernet eth0 vif 6 pppoe 0 user-id XX-XX-XX-XX-XX-XX@internet

set interfaces ethernet eth0 vif 7 bridge-group bridge br0
set interfaces ethernet eth0 vif 7 description 'KPN Telefonie'
set interfaces ethernet eth0 vif 7 mtu 1500

set interfaces ethernet eth1 description 'Thuis netwerk poort 1'
set interfaces ethernet eth1 duplex auto
set interfaces ethernet eth1 speed auto

set interfaces ethernet eth2 description 'Thuis netwerk poort 2'
set interfaces ethernet eth2 duplex auto
set interfaces ethernet eth2 speed auto

set interfaces ethernet eth3 description 'Thuis netwerk poort 3'
set interfaces ethernet eth3 duplex auto
set interfaces ethernet eth3 speed auto

set interfaces ethernet eth4 description 'KPN Experia Box'
set interfaces ethernet eth4 duplex auto
set interfaces ethernet eth4 speed auto
set interfaces ethernet eth4 vif 7 bridge-group bridge br0
set interfaces ethernet eth4 vif 7 description 'KPN Telefonie'
set interfaces ethernet eth4 vif 7 mtu 1500

set interfaces loopback lo

set interfaces switch switch0 address 192.168.2.254/24
set interfaces switch switch0 description 'Thuis netwerk'
set interfaces switch switch0 mtu 1500
set interfaces switch switch0 switch-port interface eth1
set interfaces switch switch0 switch-port interface eth2
set interfaces switch switch0 switch-port interface eth3
set interfaces switch switch0 switch-port vlan-aware disable

set interfaces switch switch0 ipv6 dup-addr-detect-transmits 1
set interfaces switch switch0 ipv6 router-advert cur-hop-limit 64
set interfaces switch switch0 ipv6 router-advert link-mtu 0
set interfaces switch switch0 ipv6 router-advert managed-flag false
set interfaces switch switch0 ipv6 router-advert max-interval 600
set interfaces switch switch0 ipv6 router-advert name-server '2a02:a47f:e000::53'
set interfaces switch switch0 ipv6 router-advert name-server '2a02:a47f:e000::54'
set interfaces switch switch0 ipv6 router-advert other-config-flag false
set interfaces switch switch0 ipv6 router-advert prefix '::/64' autonomous-flag true
set interfaces switch switch0 ipv6 router-advert prefix '::/64' on-link-flag true
set interfaces switch switch0 ipv6 router-advert prefix '::/64' valid-lifetime 2592000
set interfaces switch switch0 ipv6 router-advert radvd-options 'RDNSS 2a02:a47f:e000::53 2a02:a47f:e000::54 {};'
set interfaces switch switch0 ipv6 router-advert reachable-time 0
set interfaces switch switch0 ipv6 router-advert retrans-timer 0
set interfaces switch switch0 ipv6 router-advert send-advert true

commit
save
exit

Configureer de IGMP proxy server t.b.v. IPTV.
code:

configure

delete protocols

set protocols igmp-proxy disable-quickleave
set protocols igmp-proxy interface eth0.4 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth0.4 role upstream
set protocols igmp-proxy interface eth0.4 threshold 1
set protocols igmp-proxy interface switch0 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface switch0 role downstream
set protocols igmp-proxy interface switch0 threshold 1
set protocols static interface-route6 '::/0' next-hop-interface pppoe

commit
save
exit

Configureer de DHCP server, dns services en NAT regels.
Tevens wordt hier ingesteld dat de EdgeRouter zowel via ssh als via telnet benaderd kan (blijven) worden. Je doet er verstandig aan om na een succesvolle configuratie deze allebei uit te zetten via de beheerpagina van de EdgeRouter op http://192.168.2.254 (tabblad "Config tree").
code:

configure

delete service

set service dhcp-server disabled false
set service dhcp-server global-parameters 'option vendor-class-identifier code 60 = string;'
set service dhcp-server global-parameters 'option broadcast-address code 28 = ip-address;'
set service dhcp-server hostfile-update disable
set service dhcp-server shared-network-name Thuis authoritative enable
set service dhcp-server shared-network-name Thuis subnet 192.168.2.0/24 default-router 192.168.2.254
set service dhcp-server shared-network-name Thuis subnet 192.168.2.0/24 dns-server 192.168.2.254
set service dhcp-server shared-network-name Thuis subnet 192.168.2.0/24 domain-name Thuis
set service dhcp-server shared-network-name Thuis subnet 192.168.2.0/24 lease 86400
set service dhcp-server shared-network-name Thuis subnet 192.168.2.0/24 start 192.168.2.1 stop 192.168.2.200
set service dhcp-server static-arp disable
set service dhcp-server use-dnsmasq disable

set service dns forwarding cache-size 4000
set service dns forwarding listen-on switch0
set service dns forwarding name-server 195.121.1.34
set service dns forwarding name-server 195.121.1.66
set service dns forwarding name-server '2a02:a47f:e000::53'
set service dns forwarding name-server '2a02:a47f:e000::54'
set service dns forwarding options listen-address=192.168.2.254

set service gui http-port 80
set service gui https-port 443
set service gui older-ciphers enable

set service nat rule 5000 description IPTV
set service nat rule 5000 destination address 213.75.112.0/21
set service nat rule 5000 log disable
set service nat rule 5000 outbound-interface eth0.4
set service nat rule 5000 protocol all
set service nat rule 5000 type masquerade

set service nat rule 5010 description 'KPN Internet'
set service nat rule 5010 log disable
set service nat rule 5010 outbound-interface pppoe0
set service nat rule 5010 protocol all
set service nat rule 5010 type masquerade

set service ssh
set service telnet port 23
set service unms disable

commit
save
exit

Configureer de systeem instellingen zoals login, dns servers en ntp servers.
De login is Admin met wachtwoord Admin. Uiteraard moet je deze direct na configuratie zelf wel even aanpassen.
code:

configure

delete system

set system domain-name Thuis
set system host-name Thuis
set system login user Admin authentication encrypted-password '$6$AA4wzrDs$yCVKfo/Y30KjIWKD6NTfVo0Ia/WJ8zZMQr4mCm5nyonQ95l.fDhZcZfcrdGumcFXv3NKBbFeYyvKP.YqdMkEN/'
set system login user Admin level admin
set system name-server 127.0.0.1
set system ntp server 0.nl.pool.ntp.org
set system ntp server 1.nl.pool.ntp.org
set system ntp server ntp0.nl.net
set system ntp server ntp1.nl.net
set system ntp server time.kpn.net

set system offload hwnat disable
set system offload ipsec enable
set system offload ipv4 forwarding enable
set system offload ipv4 pppoe enable
set system offload ipv4 vlan enable
set system offload ipv6 forwarding enable
set system offload ipv6 pppoe enable

set system syslog global facility all level notice
set system syslog global facility protocols level debug

set system time-zone Europe/Amsterdam

commit
save
exit

Reputatie 7
Ik heb vandaag wat geëxperimenteerd met de instellingen t.b.v. VoIP en ben nu zo ver dat ik nog maar één ding mis en dat is het wachtwoord van de SIP login. Alle andere benodigde instellingen heb ik ondertussen tot mijn beschikking.
Zo weet ik dat ik een pppoe verbinding op vlan 7 kan opzetten met login "ppp@voip" en wachtwoord "ppp", ken ik de IP adressen voor de proxy server die naar vlan 7 doorgezet moeten worden en heb ik de SIP login user met WireShark kunnen vaststellen. Daarmee is op één ding na alle informatie beschikbaar om mijn EdgeRouter en mijn Siemens Gigaset N300A IP in te kunnen richten om ook de telefonie af te gaan wikkelen.

Ik hoop dat KPN mij dat éne laatste blokje info wil mailen. Mocht het zo zijn dat ik daar een NDA of vrijwaringsdocument voor moet tekenen, dan ben ik daar gaarne toe bereid. Tevens kan KPN een andere abonnee wellicht blij maken met de V10 die ik dan zal retourneren. Met andere woorden een win-win-win situatie ... dus kom op KPN vertel me die laatste 20 lettertjes (wachtwoord) die ik nodig heb.

Overigens kan de VoIP sessie ook via vlan 6 opgezet worden, maar dan heeft VoIP geen voorrang meer op iTV en Internet en zal je misschien zelf QoS moeten inrichten. Vandaar dat ik het prefereer om VoIP over vlan 7 te laten blijven lopen.
Na een half jaar gebruik te hebben gemaakt van de "Kriegsman-methode" heb ik nu de "WJB-methode" ingevoerd en werkend gekregen op m'n ER Lite 3.
Ik heb het echter met twee aanpassingen moeten doen.

-set interfaces ethernet eth0 vif 4 dhcp-options client-option 'send vendor-class-identifier "IPTV_RG";'
(was:"set interfaces ethernet eth0 vif 4 dhcp-options client-option 'send vendor-class-identifier "IPTV_RG";')

-Het laatste gedeelte van het blok: set interfaces ethetnet eth2 (van description t/m mtu) heb ik apart in moeten voeren. Het hele blok set interfaces in een keer invoeren werd niet geslikt.

Dit weekend eens alles uittesten.
set interfaces ethernet eth0 vif 4 dhcp-options client-option 'send vendor-class-identifier "IPTV_RG";'
Niet alle tekens worden in het reageerblok goed weer gegeven.
Reputatie 7
FredK2017 schreef:

set interfaces ethernet eth0 vif 4 dhcp-options client-option 'send vendor-class-identifier "IPTV_RG";'
Niet alle tekens worden in het reageerblok goed weer gegeven.

Goed te lezen dat het je gelukt is om de configuratie in te lezen in jouw EdgeRouter.
Ik ben wel benieuwd hoe je die codeblokken naar die .txt bestanden gekopieerd hebt.
Als ik die bewuste regel in ssh direct naar de EdgeRouter kopieer, dan blijven die quotes (") ook echte quotes en worden ze niet omgezet naar &-quot;
Welke browser gebruikte je bij dat kopiëren?
wjb schreef:

FredK2017 schreef:

set interfaces ethernet eth0 vif 4 dhcp-options client-option 'send vendor-class-identifier "IPTV_RG";'
Niet alle tekens worden in het reageerblok goed weer gegeven.

Goed te lezen dat het je gelukt is om de configuratie in te lezen in jouw EdgeRouter.
Ik ben wel benieuwd hoe je die codeblokken naar die .txt bestanden gekopieerd hebt.
Als ik die bewuste regel in ssh direct naar de EdgeRouter kopieer, dan blijven die quotes (") ook echte quotes en worden ze niet omgezet naar &-quote;
Welke browser gebruikte je bij dat kopiëren?



Ik heb daar Microsoft Edge voor gebruikt.
FredK2017 schreef:

wjb schreef:

FredK2017 schreef:

set interfaces ethernet eth0 vif 4 dhcp-options client-option 'send vendor-class-identifier "IPTV_RG";'
Niet alle tekens worden in het reageerblok goed weer gegeven.

Goed te lezen dat het je gelukt is om de configuratie in te lezen in jouw EdgeRouter.
Ik ben wel benieuwd hoe je die codeblokken naar die .txt bestanden gekopieerd hebt.
Als ik die bewuste regel in ssh direct naar de EdgeRouter kopieer, dan blijven die quotes (") ook echte quotes en worden ze niet omgezet naar &-quote;
Welke browser gebruikte je bij dat kopiëren?



Ik heb daar Microsoft Edge voor gebruikt.



Ter verduidelijking:
Ik heb (") om moeten zetten naar (&-quote).
Reputatie 7
FredK2017 schreef:

Ter verduidelijking:
Ik heb (") om moeten zetten naar (&-quote).

Helder, de originele tekst bevat inderdaad ook de &-quot; (zonder de -) notatie voor elke dubbele quote, maar helaas maakt het forum daar gewone quotes van. En bij het copy-pasten dus ook.
Ik heb een opmerking in de turorials opgenomen.
Reputatie 7
Alles draait uitermate stabiel.
Nu die "veredelde" telefoon adapter (de V10) er nog uit.
Ik hoop echt dat KPN mij hier aan wil helpen ookal heb ik een geen zakelijk maar een consumenten abonnement.
Na de code regels van WJB geïnstalleerd te hebben loop ik tocht tegen een probleem aan bij IP-tv.
Internet en telefonie werken prima. Bij iptv lijkt de IGMP proxy/snooping niet goed te werken. Na 5 zenders gezapt te hebben loopt het vast en kan de tv geen kant meer op. Ook geen beeld meer. De tv uit en aan te zetten geeft weer respijt tot de volgende zap-sessie.

Kriegsmans methode werkte wel. Ik wil gewoon WJB's methode ook bij mij aan het werk krijgen.

-ER Lite 3 firmware 1.10.6, 2 X Netgear GS108E zonder wifi access-point. (wifi was ik nog niet aan toe gekomen).

Ik kan eventueel m'n code hier plaatsen.
Suggesties?
Reputatie 7
Kan jij hier een de nat regels en het stukje voor de IGMP proxy eens posten?

Ik heb de IGMP proxy server ondertussen aangepast waarbij ik op eth0.4 i.p.v. het subnet 0.0.0.0/0 de subnetten 10.16.0.0/16 en 213.75.0.0/16 opgenomen heb.

Tevens heb ik een extra nat entry gemaakt voor het subnet 10.16.0.0/16 naar eth0.4

set service nat rule 5005 description IPTV
set service nat rule 5005 destination address 10.16.0.0/16
set service nat rule 5005 log disable
set service nat rule 5005 outbound-interface eth0.4
set service nat rule 5005 protocol all
set service nat rule 5005 type masquerade
wjb schreef:

Kan jij hier een de nat regels en het stukje voor de IGMP proxy eens posten?

Ik heb de IGMP proxy server ondertussen aangepast waarbij ik op eth0.4 i.p.v. het subnet 0.0.0.0/0 de subnetten 10.16.0.0/16 en 213.75.0.0/16 opgenomen heb.

Tevens heb ik een extra nat entry gemaakt voor het subnet 10.16.0.0/16 naar eth0.4

set service nat rule 5005 description IPTV
set service nat rule 5005 destination address 10.16.0.0/16
set service nat rule 5005 log disable
set service nat rule 5005 outbound-interface eth0.4
set service nat rule 5005 protocol all
set service nat rule 5005 type masquerade



Bij deze:

nat {
rule 5000 {
description IPTV
destination {
address 213.75.112.0/21
}
log disable
outbound-interface eth0.4
protocol all
type masquerade
}
rule 5010 {
description "KPN Internet"
log disable
outbound-interface pppoe0
protocol all
type masquerade
}

en:

protocols {
igmp-proxy {
disable-quickleave
interface eth0.4 {
alt-subnet 0.0.0.0/0
role upstream
threshold 1
}
interface eth1 {
alt-subnet 0.0.0.0/0
role downstream
threshold 1
}
}
static {
interface-route6 ::/0 {
next-hop-interface pppoe {
}
}
}

Reageer