Sticky

Gebruik een eigen router i.p.v. de Experia Box

  • 8 September 2018
  • 8565 reacties
  • 564837 keer bekeken
Gebruik een eigen router i.p.v. de Experia Box

Toon eerste bericht

8565 reacties

Reputatie 7

Als jij geen TV van KPN gebruikt dan kan je de Experia/KPN Box er eenvoudig tussenuit snijden.

Het enige is dat jouw eigen router een PPPoE verbinding op vlan 6 op moet zetten.

Heb je een glasvezelaansluiting of een VDSL aansluiting?

 

Ik heb glasvezel aansluiting.

Kan je de pppoe verbinding op een apart vlan {vlan 6) opzetten?

Plaats hier anders eens screenshots van de configuratie mogelijkheden van de Internet verbinding (WAN poort).

 

Reputatie 4
Badge +1

Ik heb nu sinds een tijd problemen met een tv ontvanger.
Gaat schokken en daarna blauw scherm met foutmelding. Als je zender wisselt dan gebeurd zelfde weer.

De andere tv ontvanger draait probleemloos.
Zit op een edgerouter 4 en eth0 en eth1
Enige verschil dat ik nu zo kan zien is dat de pool size bij iptv-1 200 is en bij de ander 6 (iptv-2).
Waarom is dat verschil er maar dat zou toch niet uit moeten maken omdat er maar 1 ip adres in dat subnet gebruikt word?

 

Ik ga morgen iig proberen om de tv ontvangers een te wisselen en de poort.
 

Reputatie 7

Enige verschil dat ik nu zo kan zien is dat de pool size bij iptv-1 200 is en bij de ander 6 (iptv-2).
Waarom is dat verschil er maar dat zou toch niet uit moeten maken omdat er maar 1 ip adres in dat subnet gebruikt word?

Ik heb die pool size op 6 gezet omdat er maximaal 6 TV ontvangers gecontracteerd kunnen worden en er dus toch nooit meer dan 6 apparaten aangesloten zullen zijn.

Reputatie 2

Hoi @wjb,

 

Ik ben bang dat ik je toch weer eens nodig heb.

 

Thuis heb ik nu van KPN een mooie 1000/1000 aansluiting liggen welke ik rechtstreeks aangesloten heb op mijn USG3P en dat werkt perferct voor internet en IPTV, maar ik krijg het VOIP gedeelte maar niet aan de praat,…

 

WAN1 is dus netjes verbonden met XGS-PON

LAN1 is mijn interne netwerk & IPTV

WAN2/LAN2 gaat naar de Experia Box WAN poort.

 

Nu heb ik de json config file aangepast om vif-7 te bridgen naar WAN2/LAN2 zodat de ExperiaBox het VOIP gedeelte kan afhandelen, maar ik denk dat ik iets over het hoofd zie.

Zou jij eens mee willen/kunnen kijken?

 

Config;

{
"system": {
"offload": {
"ipv4": {
"forwarding": "enable",
"gre": "enable",
"pppoe": "enable",
"vlan": "enable"
},
"ipv6": {
"forwarding": "enable",
"pppoe": "enable",
"vlan": "disable"
}
}
},
"firewall": {
"ipv6-name": {
"WANv6_LOCAL": {
"rule": {
"1": {
"action": "accept",
"description": "Allow ICMPv6",
"log": "enable",
"protocol": "icmpv6"
},
"2": {
"action": "accept",
"description": "DHCPv6",
"destination": {
"port": "546"
},
"protocol": "udp",
"source": {
"port": "547"
}
}
}
},
"WANv6_IN": {
"rule": {
"1": {
"action": "accept",
"description": "Allow ICMPv6",
"log": "enable",
"protocol": "icmpv6"
}
}
}
}
},
"interfaces": {
"bridge": {
"br0": {
"aging": "300",
"bridged-conntrack": "disable",
"description": "KPN Telefonie",
"hello-time": "2",
"max-age": "20",
"priority": "32768",
"promiscuous": "disable",
"stp": "false"
}
},
"ethernet": {
"eth0": {
"dhcp-options": {
"default-route": "no-update",
"default-route-distance": "1",
"name-server": "no-update"
},
"description": "WAN",
"vif": {
"4": {
"address": [
"dhcp"
],
"description": "IPTV",
"dhcp-options": {
"client-option": [
"send vendor-class-identifier "IPTV_RG";",
"request subnet-mask, routers, rfc3442-classless-static-routes;"
],
"default-route": "no-update",
"default-route-distance": "210",
"name-server": "no-update"
},
"ip": {
"source-validation": "loose"
},
"mtu": "1500"
},
"6": {
"firewall": {
"in": {
"ipv6-name": "WANv6_IN",
"name": "WAN_IN"
},
"local": {
"ipv6-name": "WANv6_LOCAL",
"name": "WAN_LOCAL"
},
"out": {
"ipv6-name": "WANv6_OUT",
"name": "WAN_OUT"
}
},
"pppoe": {
"2": {
"dhcpv6-pd": {
"no-dns": "''",
"pd": {
"0": {
"interface": {
"eth1": {
"host-address": "::1",
"prefix-id": ":1",
"service": "slaac"
}
},
"prefix-length": "/48"
}
},
"rapid-commit": "disable"
},
"firewall": {
"in": {
"ipv6-name": "WANv6_IN",
"name": "WAN_IN"
},
"local": {
"ipv6-name": "WANv6_LOCAL",
"name": "WAN_LOCAL"
},
"out": {
"ipv6-name": "WANv6_OUT",
"name": "WAN_OUT"
}
},
"ipv6": {
"address": {
"autoconf": "''"
},
"dup-addr-detect-transmits": "1",
"enable": "''"
},
"default-route": "auto",
"mtu": "1500",
"name-server": "auto",
"password": "kpn",
"user-id": "kpn"
}
}
},
"7": {
"bridge-group": {
"bridge": "br0"
},
"description": "KPN Telefonie",
"mtu": "1500"
}
}
},
"eth1": {
"description": "LAN",
"ipv6": {
"address": {
"autoconf": "''"
},
"dup-addr-detect-transmits": "1",
"router-advert": {
"cur-hop-limit": "64",
"link-mtu": "0",
"managed-flag": "true",
"max-interval": "600",
"name-server": [
"2606:4700:4700::1111",
"2606:4700:4700::1001"
],
"other-config-flag": "false",
"prefix": {
"::/64": {
"autonomous-flag": "true",
"on-link-flag": "true",
"valid-lifetime": "2592000"
}
},
"radvd-options": "RDNSS 2606:4700:4700::1111 2606:4700:4700::1001 {};",
"reachable-time": "0",
"retrans-timer": "0",
"send-advert": "true"
}
}
},
"eth2": {
"description": "KPN Experia Box",
"duplex": "auto",
"ipv6": {
"address": {
"autoconf": "''"
},
"dup-addr-detect-transmits": "1"
},
"speed": "auto",
"vif": {
"7": {
"bridge-group": {
"bridge": "br0"
},
"description": "KPN Telefonie",
"mtu": "1500"
}
}
}
}
},
"protocols": {
"igmp-proxy": {
"interface": {
"eth0.4": {
"alt-subnet": [
"0.0.0.0/0"
],
"role": "upstream",
"threshold": "1"
},
"eth1": {
"alt-subnet": [
"0.0.0.0/0"
],
"role": "downstream",
"threshold": "1"
}
}
},
"static": {
"interface-route6": {
"::/0": {
"next-hop-interface": {
"pppoe2": "''"
}
}
}
}
},
"port-forward": {
"wan-interface": "pppoe2"
},
"service": {
"dns": {
"forwarding": {
"except-interface": [
"pppoe2"
]
}
},
"nat": {
"rule": {
"5000": {
"description": "MASQ all traffic to IPTV network",
"destination": {
"address": "0.0.0.0/0"
},
"log": "disable",
"outbound-interface": "eth0.4",
"protocol": "all",
"type": "masquerade"
},
"6001": {
"outbound-interface": "pppoe2"
},
"6002": {
"outbound-interface": "pppoe2"
},
"6003": {
"outbound-interface": "pppoe2"
}
}
}
}
}

Alvast bedankt!

Groeten Wouter

Reputatie 7

Die config lijkt er goed uit te zien.

Welke Experia Box heb je?

Is die Experia Box ook rechtstreeks aangesloten geweest zodat de telefonie instellingen naar de Experia Box gepusht zijn?

Reputatie 2

Hoi @wjb,

Ik heb die zwarte box gekregen van Kpn, volgens mij de v12?

Ps; als antwoord op je andere vraag, ja hij werkt namelijk perfect als ik hem aansluit zoals het hoort ;)

Reputatie 7

Ik heb die zwarte box gekregen van Kpn, volgens mij de v12?

In het openingsbericht van dit topic kan je lezen dat de V12 niet geschikt is om voor telefonie achter een eigen router te gebruiken. Dan zal je een oudere Experia Box moeten aansluiten.

De V12 en V14 gebruiken immers niet meer vlan 7 maar vlan 6 (Internet) voor telefonie en vlan 6 kan niet gebridged worden naar de Experia/KPN Box.

Reputatie 2

Ik heb die zwarte box gekregen van Kpn, volgens mij de v12?

In het openingsbericht van dit topic kan je lezen dat de V12 niet geschikt is om voor telefonie achter een eigen router te gebruiken. Dan zal je een oudere Experia Box moeten aansluiten.

De V12 en V14 gebruiken immers niet meer vlan 7 maar vlan 6 (Internet) voor telefonie en vlan 6 kan niet gebridged worden naar de Experia/KPN Box.

Ai, dat gedeelte heb ik even over het hoofd gezien! Excuus!

Vraag ik me af; Kan ik dan wel een VOIP ATA gebruiken en die achter de USG aansluiten?

Zoals de HT812 bijvoorbeeld?

 

Alvast bedankt 

Reputatie 7

wverbeek schreef:

Kan ik dan wel een VOIP ATA gebruiken en die achter de USG aansluiten?

Zoals de HT812 bijvoorbeeld?

Dat kan maar dat doe je dan op het gewone thuisnetwerk.

En daarbij zal je de KPN SIP/VoIP Servicetool moeten gebruiken om een wachtwoord in te stellen.

Zelf heb ik een Gigaset N300A IP achter mijn EdgeRouter 4 geplaatst.

Reputatie 4
Badge +1

Enige verschil dat ik nu zo kan zien is dat de pool size bij iptv-1 200 is en bij de ander 6 (iptv-2).
Waarom is dat verschil er maar dat zou toch niet uit moeten maken omdat er maar 1 ip adres in dat subnet gebruikt word?

Ik heb die pool size op 6 gezet omdat er maximaal 6 TV ontvangers gecontracteerd kunnen worden en er dus toch nooit meer dan 6 apparaten aangesloten zullen zijn.

Ik heb vandaag de netgear switches vervangen door unifi.
De aris’ontvangers een hard reset gegeven.

Alleen ik kwam er door unifi achter dat ik een “loop” had. Dus op een netgear switch 1 kabel in twee poorten. Nu lijkt alles weer goed te zijn. Kan een loop op de hoofdswitch problemen met tv veroorzaken?

(cable management is het volgende project samen met de foscam nvr vervangen ;))

 

 

Reputatie 7

fubje schreef:

Kan een loop op de hoofdswitch problemen met tv veroorzaken?

Dat kan zeer zeker immers dan kan er een broadcast storm onstaan die zorgt voor overbelasting.

Mijn advies is dan ook altijd om "Loop Detection" aan te zetten.

 

Reputatie 4
Badge +1

Het gekke is dat elke zender het nu doet. Het zappen gaat ook vlot. 
 

maar ga ik naar nl1 dan gaat hij schokken en binnen 5 seconden vastlopen en blauw scherm 

Stb-Nmb-400

 

verbinding met modem verloren. 
 

zap ik naar een andere zender en het werkt weer direct. 

Reputatie 7

Geef in de cli van de EdgeRouter eens het commando restart igmp-proxy.

Is het probleem daarmee verholpen?

Reputatie 4
Badge +1

Geef in de cli van de EdgeRouter eens het commando restart IGMP-proxy.

Is het probleem daarmee verholpen?

Het commando lijkt niet te bestaan / te werken?

Ik heb nu ontdekt dat de tv op eth1 gewoon goed werkt.

de tv op eth0 werkt dus nederland 1 niet. even beeld….haperen, beeld, geluid weg, vastloper en foutmelding.
Als ik de lan kabels wissel dan heeft de andere tv het probleem. Het zit dus op eth0 en dus geen kabel/tv ontvanger probleem?

 

 

Reputatie 7

In mijn vorige bericht was igmp door de autocorrect vervangen door IGMP en dat was niet de bedoeling.

Het commando is restart igmp-proxy.

Ik ben toch benieuwd of de TV ontvanger dan ook op eth0 weer werkt.

Reputatie 4
Badge +1

In mijn vorige bericht was igmp door de autocorrect vervangen door IGMP en dat was niet de bedoeling.

Het commando is restart igmp-proxy.

Ik ben toch benieuwd of de TV ontvanger dan ook op eth0 weer werkt.

je krijgt geen melding dat het succesvol is uitgevoerd?

De ontvanger werkt wel op eth0 behalve zender nederland1

video van probleem:

https://file.io/uJet1GnKCifP

Reputatie 7

Klopt, je krijgt inderdaad geen melding.

Dat filmpje ga ik niet downloaden, 644MB is het me niet waard.

Reputatie 4
Badge +1

Klopt, je krijgt inderdaad geen melding.

Dat filmpje ga ik niet downloaden, 644MB is het me niet waard.

dat was idd beetje groot.
 

 

Reputatie 7

Zet de TV ontvangers beide eens helemaal uit.

Geef in de cli het commando restart igmp-proxy.

Controleer of er geen TV streams actief zijn door in de dashboard naar het dataverbruik te kijken.

Sluit de TV ontvangers weer aan.

Is het probleem er dan nog steeds?

Kan je het igmp-proxy stukje uit jouw config.boot hier met ons delen?

Reputatie 4
Badge +1

Zet de TV ontvangers beide eens helemaal uit.

Geef in de cli het commando restart igmp-proxy.

Controleer of er geen TV streams actief zijn door in de dashboard naar het dataverbruik te kijken.

Sluit de TV ontvangers weer aan.

Is het probleem er dan nog steeds?

Kan je het igmp-proxy stukje uit jouw config.boot hier met ons delen?

helaas gaf dit niet gewenste resultaat.

}
protocols {
    igmp-proxy {
        interface eth0 {
            alt-subnet 192.168.0.0/24
            role downstream
            threshold 1
        }
        interface eth1 {
            alt-subnet 192.168.1.0/24
            role downstream
            threshold 1
        }
        interface eth3.4 {
            alt-subnet 0.0.0.0/0
            role upstream
            threshold 1
        }
    }
    static {
        interface-route6 ::/0 {
            next-hop-interface pppoe0 {
            }
        }
    }
}

Reputatie 7

Dit ziet er goed uit. Ik neem aan dat de TV ontvanger op eth0 een IP adres uit het subnet 192.168.0.0/24 heeft en die op eth1 uit het subnet 192.168.1.0/24. Klopt dat?

Reputatie 4
Badge +1

Okay, Het probleem doet zich voor als op beide otvangers hetzelfde kanaal word bekeken.
dus als ik bij ene tv op ned3 zet werkt op andere ned1 weer maar kan ik geen ned3 kijken want dan gebeurd zelfde als in video.

Reputatie 4
Badge +1

Dit ziet er goed uit. Ik neem aan dat de TV ontvanger op eth0 een IP adres uit het subnet 192.168.0.0/24 heeft en die op eth1 uit het subnet 192.168.1.0/24. Klopt dat?

Ja.
 

 

Reputatie 7

Okay, Het probleem doet zich voor als op beide otvangers hetzelfde kanaal word bekeken.
dus als ik bij ene tv op ned3 zet werkt op andere ned1 weer maar kan ik geen ned3 kijken want dan gebeurd zelfde als in video.

Dat is een interessante constatering.

Dat zou betekenen dat de igmp proxy server niet in staat is dezelfde TV stream naar twee subnetten te routeren. Dan heb ik niet zo snel een oplossing anders dan een switch achter eth0 of eth1 te hangen en daar beide TV ontvangers op aan te sluiten.

Reputatie 4
Badge +1

Okay, Het probleem doet zich voor als op beide otvangers hetzelfde kanaal word bekeken.
dus als ik bij ene tv op ned3 zet werkt op andere ned1 weer maar kan ik geen ned3 kijken want dan gebeurd zelfde als in video.

Dat is een interessante constatering.

Dat zou betekenen dat de igmp proxy server niet in staat is dezelfde TV stream naar twee subnetten te routeren. Dan heb ik niet zo snel een oplossing anders dan een switch achter eth0 of eth1 te hangen en daar beide TV ontvangers op aan te sluiten.

Raar dat ik dan de eerste ben met dit probleem of zou het ook weer te maken hebben dat ik een edgerouter 4 heb?

Als ik het andere script gebruik en een vlan4 aan maak dan moet het wel werken?
https://kpn.wjb4all.nl/EdgeRouter-4-SFP-KPN-zonder-VoIP-met-vlan4-voor-TV.zip

Reageer