Sticky

Gebruik een eigen router i.p.v. de Experia Box

  • 8 september 2018
  • 3525 reacties
  • 252827 keer bekeken


Toon eerste bericht

3525 reacties

Reputatie 4
Badge +4

@semafoor_dommel,

Ik draai nagenoeg dezelfde setup. Ik gebruik voor IPTV wel een VLAN op eth1 maar dit is niet noodzakelijk. Als je dit ook wilt uittesten dan moet je wel een aantal aanpassingen doen, een nadeel aan het aanmaken van een apart VLAN voor IPTV is dat je niet zomaar weer de Experiabox kan aansluiten gezien die geen VLAN ondersteuning heeft aan de LAN kant.

kan als je wilt wel wat screenshots geven 

Hoor het wel.

EDIT: geef je wel na het inspoelen van het script op de edgerouter een restart igmp-proxy command?

dus via de CLI inloggen het volgende commando  geven: restart igmp-proxy

Ik heb de IGMP proxy zojuist herstart. Had dit, toen ik de setup draaide met de enhanced multicasting aan al eens geprobeerd, maar misschien biedt het nu soelaas.

Wat bedoel je precies met het inspoelen van het script op de edgerouter eigenlijk? Ik verander nu alleen settings op via de controller-software op de cloud-key.

Met het inspoelen bedoel ik het laden van het script van wjb op pagina 1 van dit forum.

Elke keer als je de Edgerouter opnieuw opstart is het geen overbodige luxe om een keer een restart igmp-proxy te geven. Dit heeft te maken  dat het laden van de igmp proxy sneller lijkt te starten dan dat alle andere settings waardoor de proxy wel start maar niet op het gewenste moment (te vroeg). Wjb is hiervan op de hoogte en is volgens mij aan het kijken of hier een oplossing voor is. Tevens komt binnenkort firmware 2.0.9 uit (deze is staat nu op beta 5) waar mogelijk ook verbeteringen komen.

Helaas IGMP proxy herstarten lost niets op. IPTV loopt weer vast.

 

Kan het misschien dat een client op het WIFI negatieve impact heeft op de IPTV datastroom?

 

Het begint wel heel mysterieus te worden waarom IPTV het niet doet met de InWall AP’s op het netwerk.:nerd:

Reputatie 7

Daarna de stoute schoenen aangetrokken en ook de andere Inwall aangesloten tussen de switch en de IPTV. Direct hier ook weer freezes en de hele rataplan.

Heb je ook al eens beide Inwalls aangesloten gehad waarbij de TV ontvanger op de US-8 aangesloten blijft?

Reputatie 4
Badge +4

Helaas IGMP proxy herstarten lost niets op. IPTV loopt weer vast.

 

Kan het misschien dat een client op het WIFI negatieve impact heeft op de IPTV datastroom?

 

Het begint wel heel mysterieus te worden waarom IPTV het niet doet met de InWall AP’s op het netwerk.:nerd:

Je weet dat je de 2 poorten onderaan de unifi inwall ook kan instellen en toewijzen. Ik gebruik ook 1 unifi inWall  waarbij ik poort 2 op IPTV vlan 4 heb draaien maar die poort moet je in de inwall wel configureren. 

Daarna de stoute schoenen aangetrokken en ook de andere Inwall aangesloten tussen de switch en de IPTV. Direct hier ook weer freezes en de hele rataplan.

Heb je ook al eens beide Inwalls aangesloten gehad waarbij de TV ontvanger op de US-8 aangesloten blijft?

@wjb ja, dat heb ik gisteren gedaan. Het leek toen goed te werken als de AP’s en de IPV allemaal individueel op de switch aangesloten zijn. Het lastige is de tijd die ik moet testen. Dat is best lang, toch wel een aantal uur achter elkaar waarbij TV gekeken moet blijven worden om de freezes te zien. Deze herstellen zich namelijk na verloop van tijd wel weer uit zichzelf. 

Heb een uurtje terug het wifi uitgezet. En problemen leken verholpen te zijn. Zojuist weer aangezet om te zien of de problemen weer terugkeren. Als dit zo zou zijn, zou je logischerwijs concluderen dat er dan een client op wifi een storende factor is. Tot nu toe echter nog geen freezes. Tricky business zo:thinking: 

 

Helaas IGMP proxy herstarten lost niets op. IPTV loopt weer vast.

 

Kan het misschien dat een client op het WIFI negatieve impact heeft op de IPTV datastroom?

 

Het begint wel heel mysterieus te worden waarom IPTV het niet doet met de InWall AP’s op het netwerk.:nerd:

Je weet dat je de 2 poorten onderaan de unifi inwall ook kan instellen en toewijzen. Ik gebruik ook 1 unifi inWall  waarbij ik poort 2 op IPTV vlan 4 heb draaien maar die poort moet je in de inwall wel configureren. 

@Multiedje Ik weet inderdaad dat alle poorten op de Unifi geconfigureerd kunnen worden. Dit is het grote voordeel van de Unifi apartuur als je het mij vraagt :) Raad je aan om voor de IPTV een apart VLAN te maken?

 

(On the side, vind het wel heel erg tof dat jullie zo meedenken!)

Reputatie 4
Badge +4

@semafoor_dommel ,

Ik zat net nog even terug te lezen en heb nog paar vraagjes opmerkingen:

  1. heb je het 192.168.2.1 adres al aangepast naar 192.168.2.254?
  2. Ik zie dat alle devices multicast verkeer ontvangen vanuit jou screenshot
  3. Als ik deze draai zie ik het volgende (zit weliswaar op een VLAN maar daarvoor het ik dit niet. alleen de 2 ontvangers in vlan 4

    staan je proxy settings ook goed?

    bij interface 1.4 moet bij jou eth1 staan gezien je geen VLAN gebruikt.

  4. Als je een apart VLAN gebruikt kan je wel een aantal zaken uitsluiten, als de TV daarna nog vast loopt zit de oorzaak mogelijk in andere apparatuur

EDIT: het is overigens niet veel werk om je STB's op apart VLAN te zetten, dus proberen kan je het sws

@Multiedje

  1. heb je het 192.168.2.1 adres al aangepast naar 192.168.2.254?
    Yes.
  2. Ik zie dat alle devices multicast verkeer ontvangen vanuit jou screenshot
    Als ik deze draai zie ik het volgende (zit weliswaar op een VLAN maar daarvoor het ik dit niet. alleen de 2 ontvangers in vlan 4
    Hier snap ik ook niets van. Vond het ook een enorme lijst en veel packets bij wrong. Probeer nog op internet uit te zoeken wat dat precies inhoud. Én waarom bij mij daar bijna alle clients van het netwerk instaan.
  3. staan je proxy settings ook goed?

    bij interface 1.4 moet bij jou eth1 staan gezien je geen VLAN gebruikt.
    Zekers. Inmiddels na de tips van @wjb goed gezet, analoog aan jouw settings.

Vreemd genoeg na uitzetten van het WLAN en na een uurtje aanzetten nog geen freezes gehad. De duurtest is nu ingezet. [hopen dat ik niet weer op de bank hoef te slapen met dat netwerk gekloot :grin: ]

Reputatie 7

Pakketjes van het multicast adres 239.255.255.250 kan je negeren, dat adres wordt gebruikt voor UPnP (Universal Plug and Play)/SSDP (Simple Service Discovery Protocol).

 

@semafoor_dommel, heb jij een Qnap?

 

  1. Als je een apart VLAN gebruikt kan je wel een aantal zaken uitsluiten, als de TV daarna nog vast loopt zit de oorzaak mogelijk in andere apparatuur

EDIT: het is overigens niet veel werk om je STB's op apart VLAN te zetten, dus proberen kan je het sws

Zou je kunnen adviseren/laten zien hoe jij dit VLAN hebt ingesteld? Ik probeer dit graag, maar heb nog geen ervaring om zelf bewust een VLAN op te zetten en daarover zowel andere VLANs (IPTV en internet) te routeren.

 

@wjb het muticast verkeer exclusief 239.255.255.250 ziet er dan zo uit:

En ja ik heb een QNAP NAS.

Reputatie 4
Badge +4

@semafoor_dommel,

Zou je kunnen adviseren/laten zien hoe jij dit VLAN hebt ingesteld? Ik probeer dit graag, maar heb nog geen ervaring om zelf bewust een VLAN op te zetten en daarover zowel andere VLANs (IPTV en internet) te routeren.

Jazeker, here we go:

  1. ga naar Edgerouter op naar tabblad Dashboard, klik op add interface, kies VLAN nummer bijvoorbeeld 4, naam (IPTV) en een gewenst IP range (manual define), ik gebruik 192.168.4.254

     

  2. Ga naar Services tabblad en maak een DHCP server aan op hetzelfde adres welk je zojuist hebt opgegeven als gewenste DHCP naam, subnet en range

     

  3. ga naar Firewall NAT en tabblad NAT en pas de source aan naar je gemaakte subnet
  4. pas de IGMP proxy regels toe die ik in de post hiervoor heb opgeven, dus eth1.4 in plaats van eth1
  5. en als laatste ga je naar je Unifi controller en maak je een VLAN (4) aan met IGMP snooping aan en vergeet niet je poorten op de switch waar de STB's op zitten op VLAN 4 te zetten.
  6. daarna een reboot van de edgerouter, restart IGMP-proxy en een provision van de switch EN ook de Unifi InWall! en haal de stroom even van de STB's want die krijgen een nieuw IP adres.

maak voor dat je begint even een backup van je huidige settings, dan kan je altijd terug!

Goeie uitleg @Multiedje! Dank je, ik ga morgen de boel instellen. Nog even voor wat belangrijke online meetings de boel overdag niet per ongeluk verzieken :)

Voor wat betreft de stap over de VLAN op de poorten instellen. Ik heb nu switch—>AP—>STB. Waar zet ik VLAN 4 op? Is dat op de switch poort naar de AP; AP poort naar STB of op beide? Clients die met WiFi of een van de andere poorten op het AP zitten moeten natuurlijk nog wel met het “normale” LAN kunnen kletsen. 

Reputatie 4
Badge +4

Goeie uitleg @Multiedje! Dank je, ik ga morgen de boel instellen. Nog even voor wat belangrijke online meetings de boel overdag niet per ongeluk verzieken :)

Voor wat betreft de stap over de VLAN op de poorten instellen. Ik heb nu switch—>AP—>STB. Waar zet ik VLAN 4 op? Is dat op de switch poort naar de AP; AP poort naar STB of op beide? Clients die met WiFi of een van de andere poorten op het AP zitten moeten natuurlijk nog wel met het “normale” LAN kunnen kletsen. 

Via de controller moet je eerst een profiel opzetten en toewijzen, na het opslaan van dit profiel zie je op de switch per poort welk doel (lan, vlan, IPTV ect) deze heeft. Dit betreffende profiel, bijvoorbeeld IPTV moet je in de hele keten van switch t/m InWall (dus per poort) doorvoeren. zie voorbeeld:

  • dus het is edgerouter→ Switch uplink op (ALL),
  • STBS's op IPTV VLAN(4) per poort op switch en InWall (nieuwe subnet, bijvoorbeeld 192.168.4.0)
  • overig verkeer wifi, QNAP ect op 192.168.2.X op LAN

Succes Morgen , ik ga ook down;-)

Als de situatie is:

Router → Switch → AP → STB

En op de link Switch → AP zet ik VLAN 4, dan krijgt het AP toch alleen VLAN 4 en alle apparaten die op dat AP zowel bedraad als draadloos zijn aangesloten zitten dan op VLAN 4?

 

Hoe verloopt regulier internetverkeer dat de STB (en andere clients op dat VLAN) ook nodig heeft/hebben over dat VLAN 4? Of gebeurd dat in de router vanzelf als je daar niets specifieks voor doet?

Reputatie 4
Badge +4

Als de situatie is:

Router → Switch → AP → STB

En op de link Switch → AP zet ik VLAN 4, dan krijgt het AP toch alleen VLAN 4 en alle apparaten die op dat AP zowel bedraad als draadloos zijn aangesloten zitten dan op VLAN 4?

 

Hoe verloopt regulier internetverkeer dat de STB (en andere clients op dat VLAN) ook nodig heeft/hebben over dat VLAN 4? Of gebeurd dat in de router vanzelf als je daar niets specifieks voor doet?

De edgerouter stuurt naar de Switch op eth1 het LAN en VLAN verkeer, deze poort staat dus op ALL. De poorten voor je reguliere LAN verkeer zet je op de Switch op LAN behalve de poort waar je STB op zit, die moet ook op ALL.Op de achterkant van je inWall Zet je de poort op ALL zodat deze LAN en VLAN krijgen. Op 1 van de WallIn poorten (waar de STB opkomt) zet je ALLEEN Vlan IPTV aan. Zo krijgt het AP gedeelte nog zijn reguliere LAN en alleen het poortje onder op de InWall het benodigde VLAN verkeer

Als de situatie is:

Router → Switch → AP → STB

En op de link Switch → AP zet ik VLAN 4, dan krijgt het AP toch alleen VLAN 4 en alle apparaten die op dat AP zowel bedraad als draadloos zijn aangesloten zitten dan op VLAN 4?

 

Hoe verloopt regulier internetverkeer dat de STB (en andere clients op dat VLAN) ook nodig heeft/hebben over dat VLAN 4? Of gebeurd dat in de router vanzelf als je daar niets specifieks voor doet?

De edgerouter stuurt naar de Switch op eth1 het LAN en VLAN verkeer, deze poort staat dus op ALL. De poorten voor je reguliere LAN verkeer zet je op de Switch op LAN behalve de poort waar je STB op zit, die moet ook op ALL.Op de achterkant van je inWall Zet je de poort op ALL zodat deze LAN en VLAN krijgen. Op 1 van de WallIn poorten (waar de STB opkomt) zet je ALLEEN Vlan IPTV aan. Zo krijgt het AP gedeelte nog zijn reguliere LAN en alleen het poortje onder op de InWall het benodigde VLAN verkeer

Deze optie ben ik nog niet tegen gekomen. Of is het zo dat de InWall luistert naar wat hij van de switch poort (ALL) krijgt?

 

Bij het aanpassen van de NAT viel mij op dat ik daar helemaal geen sources heb staan en twee ipv 1 regel. gaat dat wel allemaal goed?

 

Reputatie 4
Badge +4

Als de situatie is:

Router → Switch → AP → STB

En op de link Switch → AP zet ik VLAN 4, dan krijgt het AP toch alleen VLAN 4 en alle apparaten die op dat AP zowel bedraad als draadloos zijn aangesloten zitten dan op VLAN 4?

 

Hoe verloopt regulier internetverkeer dat de STB (en andere clients op dat VLAN) ook nodig heeft/hebben over dat VLAN 4? Of gebeurd dat in de router vanzelf als je daar niets specifieks voor doet?

De edgerouter stuurt naar de Switch op eth1 het LAN en VLAN verkeer, deze poort staat dus op ALL. De poorten voor je reguliere LAN verkeer zet je op de Switch op LAN behalve de poort waar je STB op zit, die moet ook op ALL.Op de achterkant van je inWall Zet je de poort op ALL zodat deze LAN en VLAN krijgen. Op 1 van de WallIn poorten (waar de STB opkomt) zet je ALLEEN Vlan IPTV aan. Zo krijgt het AP gedeelte nog zijn reguliere LAN en alleen het poortje onder op de InWall het benodigde VLAN verkeer

Deze optie ben ik nog niet tegen gekomen. Of is het zo dat de InWall luistert naar wat hij van de switch poort (ALL) krijgt?

 

Bij het aanpassen van de NAT viel mij op dat ik daar helemaal geen sources heb staan en twee ipv 1 regel. gaat dat wel allemaal goed?

 

  1. Haal regel 2 maar weg en vul regel 1 aan met je subnet waar je de STB's aan hebt hangen, in mijn geval 192.168.4.0 
  1. zoals je ingesloten afbeelding kunt zien staat er op de eerste regel ALL, die moet jij waarschijnlijk ook hebben, tenminste als je meer dan Alleen LAN gebruikt.
  2.  

hmmm.

 

VLAN lijkt het opzich wel te doen. De STB krijgt een IP van de DHCP server, maar met het opstarten van de STB krijg ik het bericht na een tijdje dat het opvragen van de instellingen mislukt zijn en dat de software opnieuw gedownload moet worden. Dit doen?

 

Hieronder wat screens van de instellingen, ik zou zeggen dat e.e.a. volgende je omschrijving @Multiedje wel oke staat toch? 

 

Reputatie 7

Die static route zou niet nodig hoeven zijn mits je rfc3442-classless-static routes actief hebt en dat moet je eigenlijk wel doen immers de next hop voor die route kan wijzigen en die rfc3442-classless-static-routes zorgt er dan voor dat deze weer goed komt te staan.

De tweede NAT entry is niet nodig immers de default route (0.0.0.0/0) wijst al naar pppoe0.

 

Als je een VIP5202 gebruikt, dan kan je beter de DNS servers in de DHCP server IPTV op die van KPN zetten en eth1.4 niet bij de DNS forwarding vastleggen. De VIP5202 kan namelijk alleen maar compressed DHCP requests aan terwijl CloudFlare uncompressed DHCP gebruikt.

Reputatie 4
Badge +4

@semafoor_dommel ,

voer het bovenstaande van wjb ook even door. De settings van de unifi staan zo correct!

ik weet niet welke STB’s je gebruikt en welke DNS servers je in gebruik hebt. Als je cloudfare gebruikt moet je (tijdelijk) even de DNS van KPN opnemen anders haalt de nieuwe SW niet op.

@wjb

weet jij waarom dit is?

 

EDIT: je had al een reactie gegeven😉

Wow hoop informatie @Multiedje en @wjb. Even checken of mijn reptielenbrein dit goed begrijpt :relaxed:

  1. De static route heb ik altijd braaf overgenomen van de handleiding van Pim Widdershoven: https://www.pimwiddershoven.nl/entry/kpn-router-iptv-on-an-ubiquiti-edgerouter-lite-lessons-learned
    Maar dit is overbodig begrijp ik nu. Viel me wel op dat ik zonder dit static route geen gids e.d. heb. 
    Deze static route zou ik kunnen ‘vervangen’ door rfc3442-classless-static routes aanzetten. 
    Doe ik dit door?
set interfaces ethernet eth0 vif 4 dhcp-options client-option "request subnet-mask, routers, rfc3442-classless-static-routes;"

 

  1. De NAT entry “KPN Internet” is niet meer nodig?

 

  1. In de DHCP server van VLAN 4 gebruik ik geen cloudflare DNS, maar die van KPN:
1.1.1.1 --> 195.121.1.34
1.0.0.1 --> 195.121.1.66

 

Reputatie 7

In de configuratiescripts die ik voor de EdgeRouter in het openingsbericht van dit topic heb gezet is de installatie van de rfc3442-classless-static-routes opgenomen.

In de beschrijving staat ook beschreven hoe je die kunt installeren zonder ook de initiële configuratie te installeren.

Mocht je alleen de rfc3442-classless-routes willen installeren, volg dan de onderstaande instructies.

Kopieer het bestand copy-rfc3442-classless-routes naar de directory /config/scripts/post-config.d
Kopieer het bestand rfc3442-classless-routes naar de directory /config/user-data
Login op de EdgeRouter via een telnet of ssh sessie.
Wijzig de rechten van het bestand copy-rfc3442-classless-routes: chmod 744 /config/scripts/post-config.d/copy-rfc3442-classless-routes
Reboot de EdgeRouter

Na de reboot zal de route naar het IPTV platform als kernel route worden weergegeven.

Bij de DHCP options voor eth0.4 zullen de volgende twee entries opgenomen moeten zijn.

send vendor-class-identifier "IPTV_RG";
request subnet-mask, routers, rfc3442-classless-static-routes;

 

Ik zie nu inderdaad een Kernel route! tof.

Heb nog even gecheckt en met het aanpassen van de DNS servers op de DHCP van VLAN 4 naar die van KPN (195.121.1.34 en 195.121.1.66), een reboot en restart van de IGMP proxy nog steeds de melding dat de instellingen niet kunnen worden opgehaald. Ik heb trouwens de vip2952 v2 als STB. 

Wat betreft de DHCP opties voor eth0.4. Bedoel je daarmee deze instellingen?

Of iets via de CLI?

 

Ik dacht dat ik het altijd begon te begrijpen, maar deze opties kan ik nog allemaal niet plaatsen qua impact op de functionaliteit van het systeem.

Reputatie 7

 

@wjb Ik zie net dat deze opties al zijn ingesteld bij mij:

 

Edit: Via de manier hoe ik dit een jaar of twee terug heb ingesteld:

https://kriegsman.io/2016/01/configuring-a-ubiquiti-edgerouter-lite-for-kpn/

configure

set interfaces ethernet eth0 vif 4 address dhcp
set interfaces ethernet eth0 vif 4 description "eth0.4 - IPTV"
set interfaces ethernet eth0 vif 4 dhcp-options client-option "send vendor-class-identifier "IPTV_RG";"
set interfaces ethernet eth0 vif 4 dhcp-options client-option "request subnet-mask, routers, rfc3442-classless-static-routes;"
set interfaces ethernet eth0 vif 4 dhcp-options default-route no-update
set interfaces ethernet eth0 vif 4 dhcp-options default-route-distance 210
set interfaces ethernet eth0 vif 4 dhcp-options name-server update

commit
save
exit

 

Reputatie 7

Heb je ook screenshots van de IGMP proxy server?

Zet de VIP2952 eens helemaal uit en weer aan. Heeft dat effect?

Reageer